1 |
# $Id: smeserver-bugzilla.spec,v 1.3 2010/03/05 18:02:42 snetram Exp $ |
2 |
# Authority: snetram |
3 |
# Name: Jonathan Martens |
4 |
|
5 |
Summary: Set up bugzilla for SME Server. |
6 |
%define name smeserver-bugzilla |
7 |
%define version 0.1 |
8 |
%define release 5 |
9 |
Name: %{name} |
10 |
Version: %{version} |
11 |
Release: %{release}%{?dist} |
12 |
License: GNU GPL version 2 |
13 |
URL: http://www.contribs.org |
14 |
Group: SMEserver/addon |
15 |
Source: %{name}-%{version}.tar.gz |
16 |
Patch0: smeserver-bugzilla-0.1-createlinks.patch |
17 |
Patch1: smeserver-bugzilla-0.1-database.patch |
18 |
Patch2: smeserver-bugzilla-0.1-httpd.conf.patch |
19 |
Patch3: smeserver-bugzilla-0.1-bugzilla.conf.patch |
20 |
Patch4: smeserver-bugzilla-0.1-localconfig.patch |
21 |
Patch5: smeserver-bugzilla-0.1-actionscript.patch |
22 |
Patch6: smeserver-bugzilla-0.1-passwordwarning.patch |
23 |
Patch7: smeserver-bugzilla-0.1-bugzilla-setup.patch |
24 |
Patch8: smeserver-bugzilla-0.1-strong-pwd.patch |
25 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
26 |
BuildArchitectures: noarch |
27 |
BuildRequires: e-smith-devtools >= 1.13.1-03 |
28 |
Requires: e-smith-release >= 7.0 |
29 |
Requires: bugzilla >= 3.0 |
30 |
Requires: perl-CGI >= 3.21 |
31 |
Requires: perl(Digest::SHA) |
32 |
Requires: perl-TimeDate |
33 |
Requires: perl(DateTime) >= 0.28 |
34 |
Requires: perl(DateTime::TimeZone) >= 0.71 |
35 |
Requires: perl(DBI) >= 1.41 |
36 |
Requires: perl(DBD::mysql) >= 4.00 |
37 |
Requires: perl-Template-Toolkit >= 2.22 |
38 |
Requires: perl(Email::Send) >= 2.00 |
39 |
Requires: perl(Email::MIME) >= 1.861 |
40 |
Requires: perl(Email::MIME::Encodings) >= 1.313 |
41 |
Requires: perl(Email::MIME::Modifier) >= 1.442 |
42 |
Requires: perl(URI) |
43 |
|
44 |
Requires: e-smith-base |
45 |
AutoReqProv: no |
46 |
|
47 |
%description |
48 |
rpm to setup bugzilla |
49 |
|
50 |
%changelog |
51 |
* Sat Mar 6 2010 Jonathan Martens <smeserver-contribs@snetram.nl> |
52 |
- Fix date in previous changelog entry |
53 |
- Fix SPEC header to generate proper version and release data |
54 |
|
55 |
* Fri Mar 5 2010 Jonathan Martens <smeserver-contribs@snetram.nl> |
56 |
- Create strong password |
57 |
|
58 |
* Mon Dec 7 2009 Jonathan Martens <smeserver-contribs@snetram.nl> |
59 |
- Apply a more restricted set of privileges to the bugzilla database user |
60 |
|
61 |
* Mon Dec 7 2009 Jonathan Martens <smeserver-contribs@snetram.nl> |
62 |
- Update minimal requirements to match at least bugzilla 3.4.2 |
63 |
- Reserve the /bugzilla URL namespace in the configuration database |
64 |
- Simplify webserver configuration fragment and rely on .htaccess files |
65 |
generated by checksetup.pl |
66 |
- Generate localconfig and populate it with the database settings |
67 |
- Create default input configuration file (/etc/bugzilla.conf) for |
68 |
checksetup.pl so it can be executed unattended |
69 |
- Add a custom template so the initial welcome page will remind the admin to |
70 |
change the password for the admin account |
71 |
- Enable InnoDB as this is required for Bugzilla |
72 |
|
73 |
* Tue Aug 14 2007 Greg Swallow <greg@runlevle7.ca> - 0.1-1 |
74 |
- initial release |
75 |
|
76 |
%prep |
77 |
%setup |
78 |
%patch0 -p1 |
79 |
%patch1 -p1 |
80 |
%patch2 -p1 |
81 |
%patch3 -p1 |
82 |
%patch4 -p1 |
83 |
%patch5 -p1 |
84 |
%patch6 -p1 |
85 |
%patch7 -p1 |
86 |
%patch8 -p1 |
87 |
|
88 |
%build |
89 |
perl createlinks |
90 |
|
91 |
%install |
92 |
rm -rf $RPM_BUILD_ROOT |
93 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
94 |
rm -f %{name}-%{version}-filelist |
95 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
96 |
> %{name}-%{version}-filelist |
97 |
echo "%doc COPYING" >> %{name}-%{version}-filelist |
98 |
|
99 |
%clean |
100 |
rm -rf $RPM_BUILD_ROOT |
101 |
|
102 |
%files -f %{name}-%{version}-filelist |
103 |
%defattr(-,root,root) |