1 |
# $Id: smeserver-bugzilla.spec,v 1.3 2013/10/13 02:35:03 unnilennium Exp $ |
2 |
# Authority: snetram |
3 |
# Name: Jonathan Martens |
4 |
|
5 |
Summary: Set up bugzilla for SME Server. |
6 |
%define name smeserver-bugzilla |
7 |
%define version 1.0 |
8 |
%define release 3 |
9 |
Name: %{name} |
10 |
Version: %{version} |
11 |
Release: %{release}%{?dist} |
12 |
License: GNU GPL version 2 |
13 |
URL: http://www.contribs.org |
14 |
Group: SMEserver/addon |
15 |
Source: %{name}-%{version}.tar.gz |
16 |
Patch0: smeserver-bugzilla-1.0-adminpass.patch |
17 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
18 |
BuildArchitectures: noarch |
19 |
BuildRequires: e-smith-devtools >= 1.13.1-03 |
20 |
Requires: e-smith-release >= 8.0 |
21 |
Requires: bugzilla >= 3.2.10 |
22 |
Requires: bugzilla-contrib |
23 |
Requires: bugzilla-doc |
24 |
#Requires: perl-CGI >= 3.21 |
25 |
#Requires: perl(Digest::SHA) |
26 |
#Requires: perl-TimeDate |
27 |
#Requires: perl(DateTime) >= 0.28 |
28 |
#Requires: perl(DateTime::TimeZone) >= 0.71 |
29 |
Requires: perl(DBI) >= 1.41 |
30 |
Requires: perl(DBD::mysql) >= 4.00 |
31 |
#Requires: perl-Template-Toolkit >= 2.22 |
32 |
#Requires: perl(Email::Send) >= 2.00 |
33 |
#Requires: perl(Email::MIME) >= 1.861 |
34 |
#Requires: perl(Email::MIME::Encodings) >= 1.313 |
35 |
#Requires: perl(Email::MIME::Modifier) >= 1.442 |
36 |
#Requires: perl(URI) |
37 |
|
38 |
Requires: e-smith-base |
39 |
AutoReqProv: no |
40 |
|
41 |
%description |
42 |
rpm to setup bugzilla |
43 |
|
44 |
%changelog |
45 |
* Sun Oct 13 2013 Jean-Philippe Pialasse <tests@pialasse.com> 1.0-3.sme |
46 |
- fixing admin pass too long [SME: 7902] |
47 |
|
48 |
* Sat Oct 12 2013 Jean-Philippe Pialasse <tests@pialasse.com> 1.0-2.sme |
49 |
- fixing localconfig path to etc |
50 |
|
51 |
* Sat Oct 12 2013 Jean-Philippe Pialasse <tests@pialasse.com> 0.1-6.sme |
52 |
- fixing requirement |
53 |
|
54 |
* Sat Mar 6 2010 Jonathan Martens <smeserver-contribs@snetram.nl> |
55 |
- Fix date in previous changelog entry |
56 |
- Fix SPEC header to generate proper version and release data |
57 |
|
58 |
* Fri Mar 5 2010 Jonathan Martens <smeserver-contribs@snetram.nl> |
59 |
- Create strong password |
60 |
|
61 |
* Mon Dec 7 2009 Jonathan Martens <smeserver-contribs@snetram.nl> |
62 |
- Apply a more restricted set of privileges to the bugzilla database user |
63 |
|
64 |
* Mon Dec 7 2009 Jonathan Martens <smeserver-contribs@snetram.nl> |
65 |
- Update minimal requirements to match at least bugzilla 3.4.2 |
66 |
- Reserve the /bugzilla URL namespace in the configuration database |
67 |
- Simplify webserver configuration fragment and rely on .htaccess files |
68 |
generated by checksetup.pl |
69 |
- Generate localconfig and populate it with the database settings |
70 |
- Create default input configuration file (/etc/bugzilla.conf) for |
71 |
checksetup.pl so it can be executed unattended |
72 |
- Add a custom template so the initial welcome page will remind the admin to |
73 |
change the password for the admin account |
74 |
- Enable InnoDB as this is required for Bugzilla |
75 |
|
76 |
* Tue Aug 14 2007 Greg Swallow <greg@runlevle7.ca> - 0.1-1 |
77 |
- initial release |
78 |
|
79 |
%prep |
80 |
%setup |
81 |
%patch0 -p1 |
82 |
#%patch1 -p1 |
83 |
#%patch2 -p1 |
84 |
#%patch3 -p1 |
85 |
#%patch4 -p1 |
86 |
#%patch5 -p1 |
87 |
#%patch6 -p1 |
88 |
#%patch7 -p1 |
89 |
#%patch8 -p1 |
90 |
|
91 |
%build |
92 |
perl createlinks |
93 |
|
94 |
%install |
95 |
rm -rf $RPM_BUILD_ROOT |
96 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
97 |
rm -f %{name}-%{version}-filelist |
98 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
99 |
> %{name}-%{version}-filelist |
100 |
echo "%doc COPYING" >> %{name}-%{version}-filelist |
101 |
|
102 |
%clean |
103 |
rm -rf $RPM_BUILD_ROOT |
104 |
|
105 |
%files -f %{name}-%{version}-filelist |
106 |
%defattr(-,root,root) |