/[smecontribs]/rpms/smeserver-cacti/contribs10/smeserver-cacti.spec
ViewVC logotype

Annotation of /rpms/smeserver-cacti/contribs10/smeserver-cacti.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Tue Jan 5 09:53:36 2021 UTC (3 years, 4 months ago) by brianr
Branch: MAIN
Initial import

1 brianr 1.1 # $Id: smeserver-cacti.spec,v 1.11 2013/11/21 22:31:24 unnilennium Exp $
2     # Authority: nocvs
3     # Name: Michel Van hees
4    
5     Summary: Cacti for smeserver
6     %define name smeserver-cacti
7     Name: %{name}
8     %define version 1.1.19
9     %define release 1
10     Version: %{version}
11     Release: %{release}%{?dist}
12     License: Freely distributable
13     Group: Apache
14     Source: %{name}-%{version}.tar.gz
15     BuildRoot: /var/tmp/e-smith-buildroot
16     BuildRequires: e-smith-devtools
17     BuildArchitectures: noarch
18     Requires: smeserver-release >= 8 , rrdtool >= 1
19     Requires: cacti >= 0.8.8h
20     AutoReqProv: no
21    
22     %changelog
23     * Wed Dec 11 2019 Jean-Philipe Pialasse <tests@pialasse.com> 1.1.19-1.sme
24     - update to cacti-1.1.19 [SME: 8434]
25    
26     * Fri Jun 10 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.8.8h1-2.sme
27     - new version for cacti-0.8.8h-1 [SME: 8434]
28    
29     * Thu Jun 09 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.8.8b1-2.sme
30     - update version Required
31    
32     * Mon Jun 16 2014 JP Pialasse <tests@pialasse.com> 0.8.8b1-1.sme
33     - initial import to SME9 contribs
34    
35     * Thu Nov 21 2013 Jean-Philippe Pialasse <tests@pialasse.com> 0.8.8b-12.sme
36     - fixed poller not running in cron , added to crontab
37     - fixed wrong ownership for db.php, now cacti:www
38     - added status enabled by default
39     - user cacti to run in cron
40    
41     * Tue Nov 14 2013 Jean-Philippe Pialasse <tests@pialasse.com> 0.8.8b-10.sme
42     - typo fix in last patch (7)
43    
44     * Sun Nov 10 2013 Jean-Philippe Pialasse <tests@pialasse.com> 0.8.8b-9.sme
45     - fix paths in sql dump [SME: 7419]
46    
47     * Mon Oct 21 2013 Jean-Philippe Pialasse <tests@pialasse.com> 0.8.8b-8.sme
48     - fixing last template path error in createlinks
49    
50     * Fri Oct 18 2013 Jean-Philippe Pialasse <tests@pialasse.com> 0.8.8b-7.sme
51     - fix missing type
52     - fix wrong path in Virtualhost template
53     - fix DB not creating
54     - fix extra file in template
55     - updated db mysql default
56    
57     * Tue Oct 15 2013 Jean-Philippe Pialasse <tests@pialasse.com> 0.8.8b-3.sme
58     - initial release for SME 8
59     - use el5 repo cacti
60     - fix dependencies
61    
62     * Tue Dec 4 2007 Michel Van hees <michel@vanhees.cc>
63     - Update contrib to 0.8.7a version
64     - Adding access limitation
65     - Adding automatic redirection to https
66     - Automatic Update process from 0.8.6j
67    
68     * Mon Jan 29 2007 Michel Van hees <michel@vanhees.cc>
69     - Based on cacti 0.8.6j
70     - Initial release
71    
72     %description
73     SME server - Cacti
74    
75     %prep
76     %setup
77     #REM contribs9 %patch0 -p1
78     #REM contribs9 %patch1 -p1
79     #REM contribs9 %patch2 -p1
80     #REM contribs9 %patch3 -p1
81     #REM contribs9 %patch4 -p1
82     #REM contribs9 %patch5 -p1
83     #REM contribs9 %patch6 -p1
84     #REM contribs9 %patch7 -p1
85     #REM contribs9 %patch8 -p1
86     #REM contribs9 %patch9 -p1
87    
88     %build
89     perl createlinks
90    
91     %install
92     rm -rf $RPM_BUILD_ROOT
93     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
94     rm -f %{name}-%{version}-filelist
95     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist
96     echo "%doc COPYING" >> %{name}-%{version}-filelist
97    
98     %clean
99     rm -rf $RPM_BUILD_ROOT
100    
101     %pre
102     #/sbin/e-smith/db accounts set cacti reserved
103    
104     %preun
105    
106     %post
107     #/sbin/e-smith/db configuration set cacti service
108     #/sbin/e-smith/db configuration setprop cacti access private
109    
110     #/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf
111     #/sbin/e-smith/expand-template /opt/cacti/include/config.php
112     #service httpd-e-smith sigusr1
113    
114    
115     #cactiVersion=`mysql cacti_sme -N -s -e"select * from version"`
116     #case "$cactiVersion" in
117     # 0.8.6j)
118     # echo ""
119     # echo "Upgrade process !!!!!!"
120     # mysql cacti_sme < /opt/cacti/cacti_upg086j.sql
121     # rm -f /opt/cacti/cacti_sme.sql
122     # rm -f /opt/cacti/cacti_upg086j.sql
123     # echo "Upgrade complete ..."
124     # echo ""
125     # ;;
126     # 0.8.7a)
127     # # Shoul not be here for the moment
128     # ;;
129     # *)
130     # # Fresh install
131     # echo ""
132     # echo "fresh install..."
133     # mysqladmin create cacti_sme
134     # mysql cacti_sme < /opt/cacti/cacti_sme.sql
135     # rm -Rf /opt/cacti/install
136     # rm -f /opt/cacti/cacti_sme.sql
137     # rm -f /opt/cacti/cacti_upg086j.sql
138     # echo "Install complete ..."
139     # echo ""
140     #esac
141    
142    
143     %postun
144    
145     %files -f %{name}-%{version}-filelist
146     %defattr(-,root,root)

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed