1 |
unnilennium |
1.3 |
# $Id: smeserver-cacti.spec,v 1.2 2013/10/16 03:07:57 unnilennium Exp $ |
2 |
unnilennium |
1.1 |
# Authority: nocvs |
3 |
|
|
# Name: Michel Van hees |
4 |
|
|
|
5 |
|
|
Summary: Cacti for smeserver |
6 |
|
|
%define name smeserver-cacti |
7 |
|
|
Name: %{name} |
8 |
unnilennium |
1.2 |
%define version 0.8.8b |
9 |
unnilennium |
1.3 |
%define release 2 |
10 |
unnilennium |
1.1 |
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: Freely distributable |
13 |
|
|
Group: Apache |
14 |
|
|
Source: %{name}-%{version}.tar.gz |
15 |
|
|
#Patch0: %{name}-%{version}.patch.yyyymmddnn |
16 |
|
|
BuildRoot: /var/tmp/e-smith-buildroot |
17 |
|
|
BuildRequires: e-smith-devtools |
18 |
|
|
BuildArchitectures: noarch |
19 |
unnilennium |
1.3 |
Requires: smeserver-release >= 8 , rrdtool >= 1 |
20 |
unnilennium |
1.2 |
Requires: cacti-0.8.8b-2.el5 |
21 |
unnilennium |
1.1 |
AutoReqProv: no |
22 |
|
|
|
23 |
|
|
%changelog |
24 |
unnilennium |
1.3 |
* Tue Oct 15 2013 Jean-Philippe Pialasse <tests@pialasse.com> 0.8.8b.sme-2 |
25 |
unnilennium |
1.2 |
- initial release for SME 8 |
26 |
|
|
- use el5 repo cacti |
27 |
|
|
|
28 |
unnilennium |
1.1 |
* Tue Dec 4 2007 Michel Van hees <michel@vanhees.cc> |
29 |
|
|
- Update contrib to 0.8.7a version |
30 |
|
|
- Adding access limitation |
31 |
|
|
- Adding automatic redirection to https |
32 |
|
|
- Automatic Update process from 0.8.6j |
33 |
|
|
|
34 |
|
|
* Mon Jan 29 2007 Michel Van hees <michel@vanhees.cc> |
35 |
|
|
- Based on cacti 0.8.6j |
36 |
|
|
- Initial release |
37 |
|
|
|
38 |
|
|
%description |
39 |
|
|
SME server - Cacti |
40 |
|
|
|
41 |
|
|
%prep |
42 |
|
|
%setup |
43 |
|
|
#%patch0 -p1 |
44 |
|
|
#%patch1 -p1 |
45 |
|
|
|
46 |
|
|
%build |
47 |
|
|
perl createlinks |
48 |
|
|
|
49 |
|
|
%install |
50 |
|
|
rm -rf $RPM_BUILD_ROOT |
51 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
52 |
|
|
rm -f %{name}-%{version}-filelist |
53 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
54 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
55 |
|
|
|
56 |
|
|
%clean |
57 |
|
|
rm -rf $RPM_BUILD_ROOT |
58 |
|
|
|
59 |
|
|
%pre |
60 |
unnilennium |
1.2 |
#/sbin/e-smith/db accounts set cacti reserved |
61 |
unnilennium |
1.1 |
|
62 |
|
|
%preun |
63 |
|
|
|
64 |
|
|
%post |
65 |
unnilennium |
1.2 |
#/sbin/e-smith/db configuration set cacti service |
66 |
|
|
#/sbin/e-smith/db configuration setprop cacti access private |
67 |
unnilennium |
1.1 |
|
68 |
unnilennium |
1.2 |
#/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
69 |
|
|
#/sbin/e-smith/expand-template /opt/cacti/include/config.php |
70 |
|
|
#service httpd-e-smith sigusr1 |
71 |
|
|
|
72 |
|
|
|
73 |
|
|
#cactiVersion=`mysql cacti_sme -N -s -e"select * from version"` |
74 |
|
|
#case "$cactiVersion" in |
75 |
|
|
# 0.8.6j) |
76 |
|
|
# echo "" |
77 |
|
|
# echo "Upgrade process !!!!!!" |
78 |
|
|
# mysql cacti_sme < /opt/cacti/cacti_upg086j.sql |
79 |
|
|
# rm -f /opt/cacti/cacti_sme.sql |
80 |
|
|
# rm -f /opt/cacti/cacti_upg086j.sql |
81 |
|
|
# echo "Upgrade complete ..." |
82 |
|
|
# echo "" |
83 |
|
|
# ;; |
84 |
|
|
# 0.8.7a) |
85 |
|
|
# # Shoul not be here for the moment |
86 |
|
|
# ;; |
87 |
|
|
# *) |
88 |
|
|
# # Fresh install |
89 |
|
|
# echo "" |
90 |
|
|
# echo "fresh install..." |
91 |
|
|
# mysqladmin create cacti_sme |
92 |
|
|
# mysql cacti_sme < /opt/cacti/cacti_sme.sql |
93 |
|
|
# rm -Rf /opt/cacti/install |
94 |
|
|
# rm -f /opt/cacti/cacti_sme.sql |
95 |
|
|
# rm -f /opt/cacti/cacti_upg086j.sql |
96 |
|
|
# echo "Install complete ..." |
97 |
|
|
# echo "" |
98 |
|
|
#esac |
99 |
unnilennium |
1.1 |
|
100 |
|
|
|
101 |
|
|
%postun |
102 |
|
|
|
103 |
|
|
%files -f %{name}-%{version}-filelist |
104 |
|
|
%defattr(-,root,root) |