1 |
unnilennium |
1.4 |
# $Id: smeserver-cacti.spec,v 1.3 2013/10/16 03:09:42 unnilennium Exp $ |
2 |
unnilennium |
1.1 |
# Authority: nocvs |
3 |
|
|
# Name: Michel Van hees |
4 |
|
|
|
5 |
|
|
Summary: Cacti for smeserver |
6 |
|
|
%define name smeserver-cacti |
7 |
|
|
Name: %{name} |
8 |
unnilennium |
1.2 |
%define version 0.8.8b |
9 |
unnilennium |
1.4 |
%define release 3 |
10 |
unnilennium |
1.1 |
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: Freely distributable |
13 |
|
|
Group: Apache |
14 |
|
|
Source: %{name}-%{version}.tar.gz |
15 |
|
|
#Patch0: %{name}-%{version}.patch.yyyymmddnn |
16 |
|
|
BuildRoot: /var/tmp/e-smith-buildroot |
17 |
|
|
BuildRequires: e-smith-devtools |
18 |
|
|
BuildArchitectures: noarch |
19 |
unnilennium |
1.3 |
Requires: smeserver-release >= 8 , rrdtool >= 1 |
20 |
unnilennium |
1.4 |
Requires: cacti = 0.8.8b-2.el5 |
21 |
unnilennium |
1.1 |
AutoReqProv: no |
22 |
|
|
|
23 |
|
|
%changelog |
24 |
unnilennium |
1.4 |
* Tue Oct 15 2013 Jean-Philippe Pialasse <tests@pialasse.com> 0.8.8b.sme-3 |
25 |
unnilennium |
1.2 |
- initial release for SME 8 |
26 |
|
|
- use el5 repo cacti |
27 |
unnilennium |
1.4 |
- fix dependencies |
28 |
unnilennium |
1.2 |
|
29 |
unnilennium |
1.1 |
* Tue Dec 4 2007 Michel Van hees <michel@vanhees.cc> |
30 |
|
|
- Update contrib to 0.8.7a version |
31 |
|
|
- Adding access limitation |
32 |
|
|
- Adding automatic redirection to https |
33 |
|
|
- Automatic Update process from 0.8.6j |
34 |
|
|
|
35 |
|
|
* Mon Jan 29 2007 Michel Van hees <michel@vanhees.cc> |
36 |
|
|
- Based on cacti 0.8.6j |
37 |
|
|
- Initial release |
38 |
|
|
|
39 |
|
|
%description |
40 |
|
|
SME server - Cacti |
41 |
|
|
|
42 |
|
|
%prep |
43 |
|
|
%setup |
44 |
|
|
#%patch0 -p1 |
45 |
|
|
#%patch1 -p1 |
46 |
|
|
|
47 |
|
|
%build |
48 |
|
|
perl createlinks |
49 |
|
|
|
50 |
|
|
%install |
51 |
|
|
rm -rf $RPM_BUILD_ROOT |
52 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
53 |
|
|
rm -f %{name}-%{version}-filelist |
54 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
55 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
56 |
|
|
|
57 |
|
|
%clean |
58 |
|
|
rm -rf $RPM_BUILD_ROOT |
59 |
|
|
|
60 |
|
|
%pre |
61 |
unnilennium |
1.2 |
#/sbin/e-smith/db accounts set cacti reserved |
62 |
unnilennium |
1.1 |
|
63 |
|
|
%preun |
64 |
|
|
|
65 |
|
|
%post |
66 |
unnilennium |
1.2 |
#/sbin/e-smith/db configuration set cacti service |
67 |
|
|
#/sbin/e-smith/db configuration setprop cacti access private |
68 |
unnilennium |
1.1 |
|
69 |
unnilennium |
1.2 |
#/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
70 |
|
|
#/sbin/e-smith/expand-template /opt/cacti/include/config.php |
71 |
|
|
#service httpd-e-smith sigusr1 |
72 |
|
|
|
73 |
|
|
|
74 |
|
|
#cactiVersion=`mysql cacti_sme -N -s -e"select * from version"` |
75 |
|
|
#case "$cactiVersion" in |
76 |
|
|
# 0.8.6j) |
77 |
|
|
# echo "" |
78 |
|
|
# echo "Upgrade process !!!!!!" |
79 |
|
|
# mysql cacti_sme < /opt/cacti/cacti_upg086j.sql |
80 |
|
|
# rm -f /opt/cacti/cacti_sme.sql |
81 |
|
|
# rm -f /opt/cacti/cacti_upg086j.sql |
82 |
|
|
# echo "Upgrade complete ..." |
83 |
|
|
# echo "" |
84 |
|
|
# ;; |
85 |
|
|
# 0.8.7a) |
86 |
|
|
# # Shoul not be here for the moment |
87 |
|
|
# ;; |
88 |
|
|
# *) |
89 |
|
|
# # Fresh install |
90 |
|
|
# echo "" |
91 |
|
|
# echo "fresh install..." |
92 |
|
|
# mysqladmin create cacti_sme |
93 |
|
|
# mysql cacti_sme < /opt/cacti/cacti_sme.sql |
94 |
|
|
# rm -Rf /opt/cacti/install |
95 |
|
|
# rm -f /opt/cacti/cacti_sme.sql |
96 |
|
|
# rm -f /opt/cacti/cacti_upg086j.sql |
97 |
|
|
# echo "Install complete ..." |
98 |
|
|
# echo "" |
99 |
|
|
#esac |
100 |
unnilennium |
1.1 |
|
101 |
|
|
|
102 |
|
|
%postun |
103 |
|
|
|
104 |
|
|
%files -f %{name}-%{version}-filelist |
105 |
|
|
%defattr(-,root,root) |