1 |
unnilennium |
1.5 |
# $Id: smeserver-cacti.spec,v 1.4 2013/10/18 14:46:30 unnilennium Exp $ |
2 |
unnilennium |
1.1 |
# Authority: nocvs |
3 |
|
|
# Name: Michel Van hees |
4 |
|
|
|
5 |
|
|
Summary: Cacti for smeserver |
6 |
|
|
%define name smeserver-cacti |
7 |
|
|
Name: %{name} |
8 |
unnilennium |
1.2 |
%define version 0.8.8b |
9 |
unnilennium |
1.5 |
%define release 6 |
10 |
unnilennium |
1.1 |
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: Freely distributable |
13 |
|
|
Group: Apache |
14 |
|
|
Source: %{name}-%{version}.tar.gz |
15 |
unnilennium |
1.5 |
Patch0: smeserver-cacti-0.8.8b-patch0.patch |
16 |
|
|
Patch1: smeserver-cacti-0.8.8b-patch1.patch |
17 |
|
|
Patch2: smeserver-cacti-0.8.8b-patch2.patch |
18 |
|
|
Patch3: smeserver-cacti-0.8.8b-patch3.patch |
19 |
|
|
#Patch:%{name}-%{version}.patch.yyyymmddnn |
20 |
unnilennium |
1.1 |
BuildRoot: /var/tmp/e-smith-buildroot |
21 |
|
|
BuildRequires: e-smith-devtools |
22 |
|
|
BuildArchitectures: noarch |
23 |
unnilennium |
1.3 |
Requires: smeserver-release >= 8 , rrdtool >= 1 |
24 |
unnilennium |
1.4 |
Requires: cacti = 0.8.8b-2.el5 |
25 |
unnilennium |
1.1 |
AutoReqProv: no |
26 |
|
|
|
27 |
|
|
%changelog |
28 |
unnilennium |
1.5 |
* Fri Oct 18 2013 Jean-Philippe Pialasse <tests@pialasse.com> 0.8.8b-6.sme |
29 |
|
|
- fix missing type |
30 |
|
|
- fix wrong path in Virtualhost template |
31 |
|
|
- fix DB not creating |
32 |
|
|
- fix extra file in template |
33 |
|
|
|
34 |
|
|
* Tue Oct 15 2013 Jean-Philippe Pialasse <tests@pialasse.com> 0.8.8b-3.sme |
35 |
unnilennium |
1.2 |
- initial release for SME 8 |
36 |
|
|
- use el5 repo cacti |
37 |
unnilennium |
1.4 |
- fix dependencies |
38 |
unnilennium |
1.2 |
|
39 |
unnilennium |
1.1 |
* Tue Dec 4 2007 Michel Van hees <michel@vanhees.cc> |
40 |
|
|
- Update contrib to 0.8.7a version |
41 |
|
|
- Adding access limitation |
42 |
|
|
- Adding automatic redirection to https |
43 |
|
|
- Automatic Update process from 0.8.6j |
44 |
|
|
|
45 |
|
|
* Mon Jan 29 2007 Michel Van hees <michel@vanhees.cc> |
46 |
|
|
- Based on cacti 0.8.6j |
47 |
|
|
- Initial release |
48 |
|
|
|
49 |
|
|
%description |
50 |
|
|
SME server - Cacti |
51 |
|
|
|
52 |
|
|
%prep |
53 |
|
|
%setup |
54 |
unnilennium |
1.5 |
%patch0 -p1 |
55 |
|
|
%patch1 -p1 |
56 |
|
|
%patch2 -p1 |
57 |
|
|
%patch3 -p1 |
58 |
unnilennium |
1.1 |
|
59 |
|
|
%build |
60 |
|
|
perl createlinks |
61 |
|
|
|
62 |
|
|
%install |
63 |
|
|
rm -rf $RPM_BUILD_ROOT |
64 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
65 |
|
|
rm -f %{name}-%{version}-filelist |
66 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
67 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
68 |
|
|
|
69 |
|
|
%clean |
70 |
|
|
rm -rf $RPM_BUILD_ROOT |
71 |
|
|
|
72 |
|
|
%pre |
73 |
unnilennium |
1.2 |
#/sbin/e-smith/db accounts set cacti reserved |
74 |
unnilennium |
1.1 |
|
75 |
|
|
%preun |
76 |
|
|
|
77 |
|
|
%post |
78 |
unnilennium |
1.2 |
#/sbin/e-smith/db configuration set cacti service |
79 |
|
|
#/sbin/e-smith/db configuration setprop cacti access private |
80 |
unnilennium |
1.1 |
|
81 |
unnilennium |
1.2 |
#/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
82 |
|
|
#/sbin/e-smith/expand-template /opt/cacti/include/config.php |
83 |
|
|
#service httpd-e-smith sigusr1 |
84 |
|
|
|
85 |
|
|
|
86 |
|
|
#cactiVersion=`mysql cacti_sme -N -s -e"select * from version"` |
87 |
|
|
#case "$cactiVersion" in |
88 |
|
|
# 0.8.6j) |
89 |
|
|
# echo "" |
90 |
|
|
# echo "Upgrade process !!!!!!" |
91 |
|
|
# mysql cacti_sme < /opt/cacti/cacti_upg086j.sql |
92 |
|
|
# rm -f /opt/cacti/cacti_sme.sql |
93 |
|
|
# rm -f /opt/cacti/cacti_upg086j.sql |
94 |
|
|
# echo "Upgrade complete ..." |
95 |
|
|
# echo "" |
96 |
|
|
# ;; |
97 |
|
|
# 0.8.7a) |
98 |
|
|
# # Shoul not be here for the moment |
99 |
|
|
# ;; |
100 |
|
|
# *) |
101 |
|
|
# # Fresh install |
102 |
|
|
# echo "" |
103 |
|
|
# echo "fresh install..." |
104 |
|
|
# mysqladmin create cacti_sme |
105 |
|
|
# mysql cacti_sme < /opt/cacti/cacti_sme.sql |
106 |
|
|
# rm -Rf /opt/cacti/install |
107 |
|
|
# rm -f /opt/cacti/cacti_sme.sql |
108 |
|
|
# rm -f /opt/cacti/cacti_upg086j.sql |
109 |
|
|
# echo "Install complete ..." |
110 |
|
|
# echo "" |
111 |
|
|
#esac |
112 |
unnilennium |
1.1 |
|
113 |
|
|
|
114 |
|
|
%postun |
115 |
|
|
|
116 |
|
|
%files -f %{name}-%{version}-filelist |
117 |
|
|
%defattr(-,root,root) |