1 |
unnilennium |
1.6 |
# $Id: smeserver-cacti.spec,v 1.5 2013/10/18 20:45:27 unnilennium Exp $ |
2 |
unnilennium |
1.1 |
# Authority: nocvs |
3 |
|
|
# Name: Michel Van hees |
4 |
|
|
|
5 |
|
|
Summary: Cacti for smeserver |
6 |
|
|
%define name smeserver-cacti |
7 |
|
|
Name: %{name} |
8 |
unnilennium |
1.2 |
%define version 0.8.8b |
9 |
unnilennium |
1.6 |
%define release 7 |
10 |
unnilennium |
1.1 |
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: Freely distributable |
13 |
|
|
Group: Apache |
14 |
|
|
Source: %{name}-%{version}.tar.gz |
15 |
unnilennium |
1.5 |
Patch0: smeserver-cacti-0.8.8b-patch0.patch |
16 |
|
|
Patch1: smeserver-cacti-0.8.8b-patch1.patch |
17 |
|
|
Patch2: smeserver-cacti-0.8.8b-patch2.patch |
18 |
|
|
Patch3: smeserver-cacti-0.8.8b-patch3.patch |
19 |
unnilennium |
1.6 |
Patch4: smeserver-cacti-0.8.8b-patch4.patch |
20 |
|
|
Patch5: smeserver-cacti-0.8.8b-patch5.patch |
21 |
unnilennium |
1.5 |
#Patch:%{name}-%{version}.patch.yyyymmddnn |
22 |
unnilennium |
1.1 |
BuildRoot: /var/tmp/e-smith-buildroot |
23 |
|
|
BuildRequires: e-smith-devtools |
24 |
|
|
BuildArchitectures: noarch |
25 |
unnilennium |
1.3 |
Requires: smeserver-release >= 8 , rrdtool >= 1 |
26 |
unnilennium |
1.4 |
Requires: cacti = 0.8.8b-2.el5 |
27 |
unnilennium |
1.1 |
AutoReqProv: no |
28 |
|
|
|
29 |
|
|
%changelog |
30 |
unnilennium |
1.6 |
* Fri Oct 18 2013 Jean-Philippe Pialasse <tests@pialasse.com> 0.8.8b-7.sme |
31 |
unnilennium |
1.5 |
- fix missing type |
32 |
|
|
- fix wrong path in Virtualhost template |
33 |
|
|
- fix DB not creating |
34 |
|
|
- fix extra file in template |
35 |
unnilennium |
1.6 |
- updated db mysql default |
36 |
unnilennium |
1.5 |
|
37 |
|
|
* Tue Oct 15 2013 Jean-Philippe Pialasse <tests@pialasse.com> 0.8.8b-3.sme |
38 |
unnilennium |
1.2 |
- initial release for SME 8 |
39 |
|
|
- use el5 repo cacti |
40 |
unnilennium |
1.4 |
- fix dependencies |
41 |
unnilennium |
1.2 |
|
42 |
unnilennium |
1.1 |
* Tue Dec 4 2007 Michel Van hees <michel@vanhees.cc> |
43 |
|
|
- Update contrib to 0.8.7a version |
44 |
|
|
- Adding access limitation |
45 |
|
|
- Adding automatic redirection to https |
46 |
|
|
- Automatic Update process from 0.8.6j |
47 |
|
|
|
48 |
|
|
* Mon Jan 29 2007 Michel Van hees <michel@vanhees.cc> |
49 |
|
|
- Based on cacti 0.8.6j |
50 |
|
|
- Initial release |
51 |
|
|
|
52 |
|
|
%description |
53 |
|
|
SME server - Cacti |
54 |
|
|
|
55 |
|
|
%prep |
56 |
|
|
%setup |
57 |
unnilennium |
1.5 |
%patch0 -p1 |
58 |
|
|
%patch1 -p1 |
59 |
|
|
%patch2 -p1 |
60 |
|
|
%patch3 -p1 |
61 |
unnilennium |
1.6 |
%patch4 -p1 |
62 |
|
|
%patch5 -p1 |
63 |
|
|
|
64 |
unnilennium |
1.1 |
|
65 |
|
|
%build |
66 |
|
|
perl createlinks |
67 |
|
|
|
68 |
|
|
%install |
69 |
|
|
rm -rf $RPM_BUILD_ROOT |
70 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
71 |
|
|
rm -f %{name}-%{version}-filelist |
72 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
73 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
74 |
|
|
|
75 |
|
|
%clean |
76 |
|
|
rm -rf $RPM_BUILD_ROOT |
77 |
|
|
|
78 |
|
|
%pre |
79 |
unnilennium |
1.2 |
#/sbin/e-smith/db accounts set cacti reserved |
80 |
unnilennium |
1.1 |
|
81 |
|
|
%preun |
82 |
|
|
|
83 |
|
|
%post |
84 |
unnilennium |
1.2 |
#/sbin/e-smith/db configuration set cacti service |
85 |
|
|
#/sbin/e-smith/db configuration setprop cacti access private |
86 |
unnilennium |
1.1 |
|
87 |
unnilennium |
1.2 |
#/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
88 |
|
|
#/sbin/e-smith/expand-template /opt/cacti/include/config.php |
89 |
|
|
#service httpd-e-smith sigusr1 |
90 |
|
|
|
91 |
|
|
|
92 |
|
|
#cactiVersion=`mysql cacti_sme -N -s -e"select * from version"` |
93 |
|
|
#case "$cactiVersion" in |
94 |
|
|
# 0.8.6j) |
95 |
|
|
# echo "" |
96 |
|
|
# echo "Upgrade process !!!!!!" |
97 |
|
|
# mysql cacti_sme < /opt/cacti/cacti_upg086j.sql |
98 |
|
|
# rm -f /opt/cacti/cacti_sme.sql |
99 |
|
|
# rm -f /opt/cacti/cacti_upg086j.sql |
100 |
|
|
# echo "Upgrade complete ..." |
101 |
|
|
# echo "" |
102 |
|
|
# ;; |
103 |
|
|
# 0.8.7a) |
104 |
|
|
# # Shoul not be here for the moment |
105 |
|
|
# ;; |
106 |
|
|
# *) |
107 |
|
|
# # Fresh install |
108 |
|
|
# echo "" |
109 |
|
|
# echo "fresh install..." |
110 |
|
|
# mysqladmin create cacti_sme |
111 |
|
|
# mysql cacti_sme < /opt/cacti/cacti_sme.sql |
112 |
|
|
# rm -Rf /opt/cacti/install |
113 |
|
|
# rm -f /opt/cacti/cacti_sme.sql |
114 |
|
|
# rm -f /opt/cacti/cacti_upg086j.sql |
115 |
|
|
# echo "Install complete ..." |
116 |
|
|
# echo "" |
117 |
|
|
#esac |
118 |
unnilennium |
1.1 |
|
119 |
|
|
|
120 |
|
|
%postun |
121 |
|
|
|
122 |
|
|
%files -f %{name}-%{version}-filelist |
123 |
|
|
%defattr(-,root,root) |