1 |
# $Id: smeserver-cacti.spec,v 1.11 2013/11/21 22:31:24 unnilennium Exp $ |
2 |
# Authority: nocvs |
3 |
# Name: Michel Van hees |
4 |
|
5 |
Summary: Cacti for smeserver |
6 |
%define name smeserver-cacti |
7 |
Name: %{name} |
8 |
%define version 0.8.8b1 |
9 |
%define release 1 |
10 |
Version: %{version} |
11 |
Release: %{release}%{?dist} |
12 |
License: Freely distributable |
13 |
Group: Apache |
14 |
Source: %{name}-%{version}.tar.gz |
15 |
#REM contribs9 Patch0: smeserver-cacti-0.8.8b1-patch0.patch |
16 |
#REM contribs9 Patch1: smeserver-cacti-0.8.8b1-patch1.patch |
17 |
#REM contribs9 Patch2: smeserver-cacti-0.8.8b1-patch2.patch |
18 |
#REM contribs9 Patch3: smeserver-cacti-0.8.8b1-patch3.patch |
19 |
#REM contribs9 Patch4: smeserver-cacti-0.8.8b1-patch4.patch |
20 |
#REM contribs9 Patch5: smeserver-cacti-0.8.8b1-patch5.patch |
21 |
#REM contribs9 Patch6: smeserver-cacti-0.8.8b1-patch6.patch |
22 |
#REM contribs9 Patch7: smeserver-cacti-0.8.8b1-patch7.patch |
23 |
#REM contribs9 Patch8: smeserver-cacti-0.8.8b1-poller.patch |
24 |
#REM contribs9 Patch9: smeserver-cacti-0.8.8b1-disenabled.patch |
25 |
#Patch:%{name}-%{version}.patch.yyyymmddnn |
26 |
BuildRoot: /var/tmp/e-smith-buildroot |
27 |
BuildRequires: e-smith-devtools |
28 |
BuildArchitectures: noarch |
29 |
Requires: smeserver-release >= 8 , rrdtool >= 1 |
30 |
Requires: cacti = 0.8.8b-2.el5 |
31 |
AutoReqProv: no |
32 |
|
33 |
%changelog |
34 |
* Mon Jun 16 2014 JP Pialasse <tests@pialasse.com> 0.8.8b1-1.sme |
35 |
- initial import to SME9 contribs |
36 |
|
37 |
* Thu Nov 21 2013 Jean-Philippe Pialasse <tests@pialasse.com> 0.8.8b-12.sme |
38 |
- fixed poller not running in cron , added to crontab |
39 |
- fixed wrong ownership for db.php, now cacti:www |
40 |
- added status enabled by default |
41 |
- user cacti to run in cron |
42 |
|
43 |
* Tue Nov 14 2013 Jean-Philippe Pialasse <tests@pialasse.com> 0.8.8b-10.sme |
44 |
- typo fix in last patch (7) |
45 |
|
46 |
* Sun Nov 10 2013 Jean-Philippe Pialasse <tests@pialasse.com> 0.8.8b-9.sme |
47 |
- fix paths in sql dump [SME: 7419] |
48 |
|
49 |
* Mon Oct 21 2013 Jean-Philippe Pialasse <tests@pialasse.com> 0.8.8b-8.sme |
50 |
- fixing last template path error in createlinks |
51 |
|
52 |
* Fri Oct 18 2013 Jean-Philippe Pialasse <tests@pialasse.com> 0.8.8b-7.sme |
53 |
- fix missing type |
54 |
- fix wrong path in Virtualhost template |
55 |
- fix DB not creating |
56 |
- fix extra file in template |
57 |
- updated db mysql default |
58 |
|
59 |
* Tue Oct 15 2013 Jean-Philippe Pialasse <tests@pialasse.com> 0.8.8b-3.sme |
60 |
- initial release for SME 8 |
61 |
- use el5 repo cacti |
62 |
- fix dependencies |
63 |
|
64 |
* Tue Dec 4 2007 Michel Van hees <michel@vanhees.cc> |
65 |
- Update contrib to 0.8.7a version |
66 |
- Adding access limitation |
67 |
- Adding automatic redirection to https |
68 |
- Automatic Update process from 0.8.6j |
69 |
|
70 |
* Mon Jan 29 2007 Michel Van hees <michel@vanhees.cc> |
71 |
- Based on cacti 0.8.6j |
72 |
- Initial release |
73 |
|
74 |
%description |
75 |
SME server - Cacti |
76 |
|
77 |
%prep |
78 |
%setup |
79 |
#REM contribs9 %patch0 -p1 |
80 |
#REM contribs9 %patch1 -p1 |
81 |
#REM contribs9 %patch2 -p1 |
82 |
#REM contribs9 %patch3 -p1 |
83 |
#REM contribs9 %patch4 -p1 |
84 |
#REM contribs9 %patch5 -p1 |
85 |
#REM contribs9 %patch6 -p1 |
86 |
#REM contribs9 %patch7 -p1 |
87 |
#REM contribs9 %patch8 -p1 |
88 |
#REM contribs9 %patch9 -p1 |
89 |
|
90 |
%build |
91 |
perl createlinks |
92 |
|
93 |
%install |
94 |
rm -rf $RPM_BUILD_ROOT |
95 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
96 |
rm -f %{name}-%{version}-filelist |
97 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
98 |
echo "%doc COPYING" >> %{name}-%{version}-filelist |
99 |
|
100 |
%clean |
101 |
rm -rf $RPM_BUILD_ROOT |
102 |
|
103 |
%pre |
104 |
#/sbin/e-smith/db accounts set cacti reserved |
105 |
|
106 |
%preun |
107 |
|
108 |
%post |
109 |
#/sbin/e-smith/db configuration set cacti service |
110 |
#/sbin/e-smith/db configuration setprop cacti access private |
111 |
|
112 |
#/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
113 |
#/sbin/e-smith/expand-template /opt/cacti/include/config.php |
114 |
#service httpd-e-smith sigusr1 |
115 |
|
116 |
|
117 |
#cactiVersion=`mysql cacti_sme -N -s -e"select * from version"` |
118 |
#case "$cactiVersion" in |
119 |
# 0.8.6j) |
120 |
# echo "" |
121 |
# echo "Upgrade process !!!!!!" |
122 |
# mysql cacti_sme < /opt/cacti/cacti_upg086j.sql |
123 |
# rm -f /opt/cacti/cacti_sme.sql |
124 |
# rm -f /opt/cacti/cacti_upg086j.sql |
125 |
# echo "Upgrade complete ..." |
126 |
# echo "" |
127 |
# ;; |
128 |
# 0.8.7a) |
129 |
# # Shoul not be here for the moment |
130 |
# ;; |
131 |
# *) |
132 |
# # Fresh install |
133 |
# echo "" |
134 |
# echo "fresh install..." |
135 |
# mysqladmin create cacti_sme |
136 |
# mysql cacti_sme < /opt/cacti/cacti_sme.sql |
137 |
# rm -Rf /opt/cacti/install |
138 |
# rm -f /opt/cacti/cacti_sme.sql |
139 |
# rm -f /opt/cacti/cacti_upg086j.sql |
140 |
# echo "Install complete ..." |
141 |
# echo "" |
142 |
#esac |
143 |
|
144 |
|
145 |
%postun |
146 |
|
147 |
%files -f %{name}-%{version}-filelist |
148 |
%defattr(-,root,root) |