1 |
jpp |
1.8 |
# $Id: smeserver-centos2sme.spec,v 1.7 2021/03/24 18:21:49 jpp Exp $ |
2 |
jpp |
1.1 |
# Authority: unnilennium |
3 |
|
|
# Name: Jean-Philippe Pialasse |
4 |
|
|
|
5 |
|
|
Summary: smeserver-centos2sme |
6 |
|
|
%define name smeserver-centos2sme |
7 |
|
|
%define version 6.9.1 |
8 |
|
|
# version number CentosMajorVersion.SMEmajorVersion.RPMversion |
9 |
jpp |
1.8 |
%define release 12 |
10 |
jpp |
1.1 |
Name: %{name} |
11 |
|
|
Version: %{version} |
12 |
|
|
Release: %{release}%{?dist} |
13 |
|
|
License: GPL |
14 |
|
|
Group: Applications/System |
15 |
|
|
Source: %{name}-%{version}.tgz |
16 |
|
|
Patch0: smeserver-centos2sme-6.9.1-bz10535-fix-path.patch |
17 |
|
|
Patch1: smeserver-centos2sme-6.9.1-bz10535-improvements.patch |
18 |
jpp |
1.2 |
Patch2: smeserver-centos2sme-6.9.1-firstSME10.patch |
19 |
jpp |
1.3 |
Patch3: smeserver-centos2sme-6.9.1-SME10-2.patch |
20 |
jpp |
1.5 |
Patch4: smeserver-centos2sme-6.9.1-secondSME10.patch |
21 |
jpp |
1.8 |
Patch5: smeserver-centos2sme-6.9.1-bz11599-remove-postfix-sendmail.patch |
22 |
jpp |
1.2 |
|
23 |
jpp |
1.1 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
24 |
|
|
BuildArch: noarch |
25 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
26 |
jpp |
1.3 |
Requires: centos-release >= 7 |
27 |
jpp |
1.1 |
|
28 |
|
|
%description |
29 |
|
|
Package to help transform a centos box into a Koozali SME Server. |
30 |
|
|
Just run /usr/bin/centos2sme ; answer the few question and sit back while your base install of centos is morphed into a SME Server. |
31 |
|
|
Do not use on a machine with user data present or with extra packages already installed. |
32 |
|
|
%prep |
33 |
|
|
%setup |
34 |
|
|
%patch0 -p1 |
35 |
|
|
%patch1 -p1 |
36 |
jpp |
1.3 |
%patch2 -p1 |
37 |
jpp |
1.4 |
%patch3 -p1 |
38 |
jpp |
1.5 |
%patch4 -p1 |
39 |
jpp |
1.6 |
mkdir -p root/etc/e-smith/events/smeserver-centos2sme |
40 |
jpp |
1.8 |
%patch5 -p1 |
41 |
jpp |
1.1 |
|
42 |
|
|
%build |
43 |
|
|
# /usr/bin/perl createlinks |
44 |
|
|
|
45 |
|
|
%install |
46 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
47 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
48 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
49 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
50 |
|
|
--file /usr/bin/centos2sme '%attr(0755,root,root)' \ |
51 |
|
|
> %{name}-%{version}-filelist |
52 |
|
|
cat %{name}-%{version}-filelist |
53 |
|
|
%files -f %{name}-%{version}-filelist |
54 |
|
|
%defattr(-,root,root,-) |
55 |
|
|
|
56 |
|
|
%clean |
57 |
|
|
rm -rf $RPM_BUILD_ROOT |
58 |
|
|
|
59 |
|
|
%post |
60 |
|
|
touch /etc/hosts.deny_ssh |
61 |
|
|
|
62 |
|
|
%changelog |
63 |
jpp |
1.8 |
* Sun May 30 2021 Jean-Philippe Pialasse <tests@pialasse.com> 6.9.1-12.sme |
64 |
|
|
- remove sendmail and postfix prior SME install [SME: 11599] |
65 |
|
|
|
66 |
jpp |
1.7 |
* Sun Mar 21 2021 Jean-Philippe Pialasse <tests@pialasse.com> 6.9.1-11.sme |
67 |
|
|
- fix typo [SME: 10850] |
68 |
|
|
|
69 |
jpp |
1.6 |
* Sat Mar 20 2021 Jean-Philippe Pialasse <tests@pialasse.com> 6.9.1-10.sme |
70 |
|
|
- create empty smeserver-centos2sme [SME: 10850] |
71 |
|
|
should not be necessary as it should be installed on bare CentOS, not on SME... |
72 |
|
|
|
73 |
jpp |
1.5 |
* Sat Mar 20 2021 Jean-Philippe Pialasse <tests@pialasse.com> 6.9.1-9.sme |
74 |
|
|
- use systemctl when needed [SME: 10850] |
75 |
|
|
- fix issue with sshd not reloading and locking user [SME: 10850] |
76 |
|
|
- remove rpm -e dhcp-common |
77 |
|
|
|
78 |
jpp |
1.4 |
* Fri Apr 17 2020 Jean-Philipe Pialasse <tests@pialasse.com> 6.9.1-8.sme |
79 |
|
|
- improve script |
80 |
|
|
- TODO: *some deps are forced, might be added as dep for e-smith-base |
81 |
|
|
*some packages conflicting like nm and firewalld are removed should be done via e-smith-base |
82 |
|
|
|
83 |
jpp |
1.3 |
* Fri Apr 17 2020 Jean-Philipe Pialasse <tests@pialasse.com> 6.9.1-7.sme |
84 |
|
|
- fix Requires, improve script |
85 |
|
|
|
86 |
jpp |
1.2 |
* Sun Dec 15 2019 Jean-Philipe Pialasse <tests@pialasse.com> 6.9.1-6.sme |
87 |
|
|
- first build for SME10 |
88 |
|
|
|
89 |
jpp |
1.1 |
* Mon Mar 12 2018 Jean-Philipe Pialasse <tests@pialasse.com> 6.9.1-5.sme |
90 |
|
|
- few improvements and bug fixes see patch improvements |
91 |
|
|
|
92 |
|
|
* Sat Mar 10 2018 Jean-Philipe Pialasse <tests@pialasse.com> 6.9.1-4.sme |
93 |
|
|
- fix execution permission on /usr/bin/centos2sme [SME: 10535] |
94 |
|
|
- added warning at the begining of script to check for working network interface |
95 |
|
|
- added warning at end of script to add a SSH key before the reboot |
96 |
|
|
- added full path to signal-event in the last messages |
97 |
|
|
- set path after first packages installation. |
98 |
|
|
|
99 |
|
|
* Fri Mar 09 2018 Jean-Philipe Pialasse <tests@pialasse.com> 6.9.1-3.sme |
100 |
|
|
- fix bad dependencies to smeserver release and formagick [SME: 10535] |
101 |
|
|
- added requirement for centos-release between 6 and 7. |
102 |
|
|
|
103 |
|
|
* Fri Mar 09 2018 Jean-Philipe Pialasse <tests@pialasse.com> 6.9.1-2.sme |
104 |
|
|
- initial version [SME: 10533] |
105 |
|
|
|