1 |
jpp |
1.9 |
# $Id: smeserver-centos2sme.spec,v 1.8 2021/05/31 01:59:42 jpp Exp $ |
2 |
jpp |
1.1 |
# Authority: unnilennium |
3 |
|
|
# Name: Jean-Philippe Pialasse |
4 |
|
|
|
5 |
|
|
Summary: smeserver-centos2sme |
6 |
|
|
%define name smeserver-centos2sme |
7 |
|
|
%define version 6.9.1 |
8 |
|
|
# version number CentosMajorVersion.SMEmajorVersion.RPMversion |
9 |
jpp |
1.9 |
%define release 13 |
10 |
jpp |
1.1 |
Name: %{name} |
11 |
|
|
Version: %{version} |
12 |
|
|
Release: %{release}%{?dist} |
13 |
|
|
License: GPL |
14 |
|
|
Group: Applications/System |
15 |
|
|
Source: %{name}-%{version}.tgz |
16 |
|
|
Patch0: smeserver-centos2sme-6.9.1-bz10535-fix-path.patch |
17 |
|
|
Patch1: smeserver-centos2sme-6.9.1-bz10535-improvements.patch |
18 |
jpp |
1.2 |
Patch2: smeserver-centos2sme-6.9.1-firstSME10.patch |
19 |
jpp |
1.3 |
Patch3: smeserver-centos2sme-6.9.1-SME10-2.patch |
20 |
jpp |
1.5 |
Patch4: smeserver-centos2sme-6.9.1-secondSME10.patch |
21 |
jpp |
1.8 |
Patch5: smeserver-centos2sme-6.9.1-bz11599-remove-postfix-sendmail.patch |
22 |
jpp |
1.9 |
Patch6: smeserver-centos2sme-6.9.1-bz12075-remi.patch |
23 |
jpp |
1.2 |
|
24 |
jpp |
1.1 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
25 |
|
|
BuildArch: noarch |
26 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
27 |
jpp |
1.3 |
Requires: centos-release >= 7 |
28 |
jpp |
1.1 |
|
29 |
|
|
%description |
30 |
|
|
Package to help transform a centos box into a Koozali SME Server. |
31 |
|
|
Just run /usr/bin/centos2sme ; answer the few question and sit back while your base install of centos is morphed into a SME Server. |
32 |
|
|
Do not use on a machine with user data present or with extra packages already installed. |
33 |
|
|
%prep |
34 |
|
|
%setup |
35 |
|
|
%patch0 -p1 |
36 |
|
|
%patch1 -p1 |
37 |
jpp |
1.3 |
%patch2 -p1 |
38 |
jpp |
1.4 |
%patch3 -p1 |
39 |
jpp |
1.5 |
%patch4 -p1 |
40 |
jpp |
1.6 |
mkdir -p root/etc/e-smith/events/smeserver-centos2sme |
41 |
jpp |
1.8 |
%patch5 -p1 |
42 |
jpp |
1.9 |
%patch6 -p1 |
43 |
jpp |
1.1 |
|
44 |
|
|
%build |
45 |
|
|
# /usr/bin/perl createlinks |
46 |
|
|
|
47 |
|
|
%install |
48 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
49 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
50 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
51 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
52 |
|
|
--file /usr/bin/centos2sme '%attr(0755,root,root)' \ |
53 |
|
|
> %{name}-%{version}-filelist |
54 |
|
|
cat %{name}-%{version}-filelist |
55 |
|
|
%files -f %{name}-%{version}-filelist |
56 |
|
|
%defattr(-,root,root,-) |
57 |
|
|
|
58 |
|
|
%clean |
59 |
|
|
rm -rf $RPM_BUILD_ROOT |
60 |
|
|
|
61 |
|
|
%post |
62 |
|
|
touch /etc/hosts.deny_ssh |
63 |
|
|
|
64 |
|
|
%changelog |
65 |
jpp |
1.9 |
* Mon Jun 20 2022 Jean-Philippe Pialasse <tests@pialasse.com> 6.9.1-13.sme |
66 |
|
|
- fix failure to install due to missing remi-safe repo [SME: 12075] |
67 |
|
|
|
68 |
jpp |
1.8 |
* Sun May 30 2021 Jean-Philippe Pialasse <tests@pialasse.com> 6.9.1-12.sme |
69 |
|
|
- remove sendmail and postfix prior SME install [SME: 11599] |
70 |
|
|
|
71 |
jpp |
1.7 |
* Sun Mar 21 2021 Jean-Philippe Pialasse <tests@pialasse.com> 6.9.1-11.sme |
72 |
|
|
- fix typo [SME: 10850] |
73 |
|
|
|
74 |
jpp |
1.6 |
* Sat Mar 20 2021 Jean-Philippe Pialasse <tests@pialasse.com> 6.9.1-10.sme |
75 |
|
|
- create empty smeserver-centos2sme [SME: 10850] |
76 |
|
|
should not be necessary as it should be installed on bare CentOS, not on SME... |
77 |
|
|
|
78 |
jpp |
1.5 |
* Sat Mar 20 2021 Jean-Philippe Pialasse <tests@pialasse.com> 6.9.1-9.sme |
79 |
|
|
- use systemctl when needed [SME: 10850] |
80 |
|
|
- fix issue with sshd not reloading and locking user [SME: 10850] |
81 |
|
|
- remove rpm -e dhcp-common |
82 |
|
|
|
83 |
jpp |
1.4 |
* Fri Apr 17 2020 Jean-Philipe Pialasse <tests@pialasse.com> 6.9.1-8.sme |
84 |
|
|
- improve script |
85 |
|
|
- TODO: *some deps are forced, might be added as dep for e-smith-base |
86 |
|
|
*some packages conflicting like nm and firewalld are removed should be done via e-smith-base |
87 |
|
|
|
88 |
jpp |
1.3 |
* Fri Apr 17 2020 Jean-Philipe Pialasse <tests@pialasse.com> 6.9.1-7.sme |
89 |
|
|
- fix Requires, improve script |
90 |
|
|
|
91 |
jpp |
1.2 |
* Sun Dec 15 2019 Jean-Philipe Pialasse <tests@pialasse.com> 6.9.1-6.sme |
92 |
|
|
- first build for SME10 |
93 |
|
|
|
94 |
jpp |
1.1 |
* Mon Mar 12 2018 Jean-Philipe Pialasse <tests@pialasse.com> 6.9.1-5.sme |
95 |
|
|
- few improvements and bug fixes see patch improvements |
96 |
|
|
|
97 |
|
|
* Sat Mar 10 2018 Jean-Philipe Pialasse <tests@pialasse.com> 6.9.1-4.sme |
98 |
|
|
- fix execution permission on /usr/bin/centos2sme [SME: 10535] |
99 |
|
|
- added warning at the begining of script to check for working network interface |
100 |
|
|
- added warning at end of script to add a SSH key before the reboot |
101 |
|
|
- added full path to signal-event in the last messages |
102 |
|
|
- set path after first packages installation. |
103 |
|
|
|
104 |
|
|
* Fri Mar 09 2018 Jean-Philipe Pialasse <tests@pialasse.com> 6.9.1-3.sme |
105 |
|
|
- fix bad dependencies to smeserver release and formagick [SME: 10535] |
106 |
|
|
- added requirement for centos-release between 6 and 7. |
107 |
|
|
|
108 |
|
|
* Fri Mar 09 2018 Jean-Philipe Pialasse <tests@pialasse.com> 6.9.1-2.sme |
109 |
|
|
- initial version [SME: 10533] |
110 |
|
|
|