1 |
%define name smeserver-certificate |
2 |
%define version 0.0.4 |
3 |
%define release 15 |
4 |
|
5 |
Name: %{name} |
6 |
Version: %{version} |
7 |
Release: %{release}%{?dist} |
8 |
Summary: allow to manage your ssl certificates |
9 |
|
10 |
Group: SMEserver/addon |
11 |
License: GNU GPL version 2 |
12 |
URL: http://www.contribs.org |
13 |
Source: %{name}-%{version}.tar.gz |
14 |
BuildRoot: %{_tmppath}/%{name}-buildroot |
15 |
BuildArchitectures: noarch |
16 |
BuildRequires: e-smith-devtools |
17 |
Requires: e-smith-release >= 9.0 |
18 |
AutoReqProv: no |
19 |
Patch0: smeserver-certificate-0.0.4-locale-2015-09-12.patch |
20 |
Patch1: smeserver-certificate-0.0.4-locale-2016-03-09.patch |
21 |
Patch2: smeserver-certificate-0.0.4-locale-2017-02-02.patch |
22 |
Patch3: smeserver-certificate-0.0.4-bz11604-sme10.patch |
23 |
Patch4: smeserver-certificate-0.0.4-Eliminate-Error-msg-on-blank-save.patch |
24 |
Patch5: smeserver-certificate-0.0.4-Add-panel-for-SM2.patch |
25 |
Patch6: smeserver-certificate-0.0.4-Update-lex-file.patch |
26 |
Patch7: smeserver-certificate-0.0.4-Fix-Routes.patch |
27 |
Patch8: smeserver-certificate-0.0.4-locale-2022-07-22.patch |
28 |
Patch9: smeserver-certificate-0.0.4-locale-2022-11-11.patch |
29 |
Patch10: smeserver-certificate-0.0.4-Alter-menu-category-for-new-arrangement.patch |
30 |
Patch11: smeserver-certificate-0.0.4-locale-2024-09-04.patch |
31 |
|
32 |
%description |
33 |
allow to add, remove, easily commercial ssl certificate |
34 |
|
35 |
%prep |
36 |
%setup |
37 |
%patch0 -p1 |
38 |
%patch1 -p1 |
39 |
%patch2 -p1 |
40 |
%patch3 -p1 |
41 |
%patch4 -p1 |
42 |
%patch5 -p1 |
43 |
%patch6 -p1 |
44 |
%patch7 -p1 |
45 |
%patch8 -p1 |
46 |
%patch9 -p1 |
47 |
%patch10 -p1 |
48 |
%patch11 -p1 |
49 |
|
50 |
%build |
51 |
perl createlinks |
52 |
|
53 |
%install |
54 |
rm -rf $RPM_BUILD_ROOT |
55 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
56 |
rm -f %{name}-%{version}-filelist |
57 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
58 |
echo "%doc COPYING" >> %{name}-%{version}-filelist |
59 |
|
60 |
%clean |
61 |
cd .. |
62 |
rm -rf %{name}-%{version} |
63 |
|
64 |
%pre |
65 |
%preun |
66 |
%post |
67 |
|
68 |
if (systemctl list-unit-files |grep smanager) then |
69 |
echo "Smanager restart in spec file" |
70 |
/sbin/e-smith/signal-event smanager-refresh; |
71 |
fi |
72 |
|
73 |
%postun |
74 |
|
75 |
%files -f %{name}-%{version}-filelist |
76 |
%defattr(-,root,root) |
77 |
|
78 |
%changelog |
79 |
* Wed Sep 04 2024 Terry Fage <terry@fage.id.au> 0.0.4-15.sme |
80 |
- apply locale 2024-09-04.patch |
81 |
|
82 |
* Fri Mar 01 2024 Brian Read <brianr@koozali.org> 0.0.4-14.sme |
83 |
- Edit SM2 Menu entry to conform to new arrangements [SME: 12493] |
84 |
|
85 |
* Fri Nov 11 2022 Jean-Philippe Pialasse <tests@pialasse.com> 0.0.4-13.sme |
86 |
- apply locale 2022-11-11 patch |
87 |
|
88 |
* Fri Jul 22 2022 Jean-Philippe Pialasse <tests@pialasse.com> 0.0.4-12.sme |
89 |
- translation 2022-07-22 patch |
90 |
|
91 |
* Thu May 26 2022 Brian Read <brianr@bjsystems.co.uk> 0.0.4-11.sme |
92 |
- fix routes [SME: 11926] |
93 |
|
94 |
* Sun Apr 17 2022 Brian Read <brianr@bjsystems.co.uk> 0.0.4-10.sme |
95 |
- Add in updated lex file [SME: 11926] |
96 |
|
97 |
* Wed Mar 30 2022 Brian Read <brianr@bjsystems.co.uk> 0.0.4-9.sme |
98 |
- Add panel for SM2 [SME: 11926] |
99 |
|
100 |
* Tue Mar 29 2022 Brian Read <brianr@bjsystems.co.uk> 0.0.4-8.sme |
101 |
- Eliminate-Error-msg-on-blank-save [SME: 11604] |
102 |
|
103 |
* Tue Feb 01 2022 Terry Fage <terryf@ozemail.com.au> 0.0.4-7.sme |
104 |
- smeserver-certificate-0.0.4-bz11604-to-sme10.patch |
105 |
|
106 |
* Wed Feb 01 2017 Jean-Philipe Pialasse <tests@pialasse.com> 0.0.4-6.sme |
107 |
- apply local 2017-02-02.patch |
108 |
|
109 |
* Wed Mar 09 2016 JP Pialasse <tests@pialasse.com> 0.0.4-4.sme |
110 |
- apply locale 2016-03-09 patch |
111 |
|
112 |
* Sat Sep 12 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 0.0.4-3.sme |
113 |
- Added smeserver-certificate-0.0.4-locale-2015-09-12.patch |
114 |
|
115 |
* Sat Aug 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 0.0.4-2.sme |
116 |
- Initial release to contribs9 |
117 |
|
118 |
|
119 |
* Sun Aug 03 2014 Stephane de Labrusse <stephdl@de-labrusse.fr> -0.0.4-1 |
120 |
- French translation |
121 |
|
122 |
* Tue Jul 01 2014 Stephane de Labrusse <stephdl@de-labrusse.fr> -0.01-1 |
123 |
- Initial Release |
124 |
|