1 |
slords |
1.1 |
# $Id$ |
2 |
|
|
# Authority: vip-ire |
3 |
|
|
# Name: Daniel Berteaud |
4 |
|
|
|
5 |
|
|
Summary: Coova-Chilli, a captive portal based on ChilliSpot configured for SME server |
6 |
|
|
%define name smeserver-coova-chilli |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 0.1 |
9 |
|
|
%define release 1 |
10 |
|
|
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GPL |
13 |
|
|
Group: Networking/Remote access |
14 |
|
|
Source: %{name}-%{version}.tar.gz |
15 |
|
|
Patch1: smeserver-coova-chilli-0.1-bypass_auth_with_squid_fix.patch |
16 |
|
|
Patch2: smeserver-coova-chilli-0.1-expand_masq_fix.patch |
17 |
|
|
URL: http://sme.firewall-services.com |
18 |
|
|
Packager: Daniel Berteaud <daniel@firewall-services.com> |
19 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
20 |
|
|
BuildArchitectures: noarch |
21 |
|
|
Requires: e-smith-release >= 7.0 openssl coova-chilli |
22 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
23 |
|
|
|
24 |
|
|
%description |
25 |
|
|
This package allow you to configure a third interface |
26 |
|
|
(eth2). Just plug a WiFi AP on it, and you'll have |
27 |
|
|
a secured captive portal. Users will be redirected |
28 |
|
|
on a logon page and they'll have to enter credentials |
29 |
|
|
(sme accounts) before the server allows them. By default, |
30 |
|
|
they'll only have web access if they are members of the group "chilli" |
31 |
|
|
|
32 |
|
|
%changelog |
33 |
|
|
* Tue Apr 15 2008 Daniel Berteaud <daniel@firewall-services.com> |
34 |
|
|
- [0.1-1] |
35 |
|
|
- security fixe: auth bypass with squid (patch1) |
36 |
|
|
- masq template not expanded (patch2) |
37 |
|
|
|
38 |
|
|
* Fri Apr 04 2008 Daniel Berteaud <daniel@firewall-services.com> |
39 |
|
|
- [0.1] |
40 |
|
|
- initiale release |
41 |
|
|
|
42 |
|
|
%prep |
43 |
|
|
%setup |
44 |
|
|
%patch1 -p1 |
45 |
|
|
%patch2 -p1 |
46 |
|
|
|
47 |
|
|
%build |
48 |
|
|
/usr/bin/perl createlinks |
49 |
|
|
|
50 |
|
|
%install |
51 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
52 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
53 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
54 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
55 |
|
|
--file /etc/chilli/conup.sh 'attr(0750,root,root)' \ |
56 |
|
|
--file /etc/chilli/condown.sh 'attr(0750,root,root)' \ |
57 |
|
|
> %{name}-%{version}-filelist |
58 |
|
|
|
59 |
|
|
%files -f %{name}-%{version}-filelist |
60 |
|
|
%defattr(-,root,root) |
61 |
|
|
|
62 |
|
|
%clean |
63 |
|
|
rm -rf $RPM_BUILD_ROOT |
64 |
|
|
|
65 |
|
|
%post |
66 |
|
|
if [ ! -e /opt/chilli ]; then |
67 |
|
|
/bin/cp -a /opt/chilli.rpmnew /opt/chilli |
68 |
|
|
fi |
69 |
|
|
|
70 |
|
|
%preun |
71 |
|
|
if [ $1 == 0 ]; then |
72 |
|
|
/sbin/e-smith/db configuration setprop chilli status disabled |
73 |
|
|
/sbin/e-smith/signal-event chilli-update |
74 |
|
|
fi |
75 |
|
|
|