/[smecontribs]/rpms/smeserver-coova-chilli/contribs7/smeserver-coova-chilli.spec
ViewVC logotype

Annotation of /rpms/smeserver-coova-chilli/contribs7/smeserver-coova-chilli.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.8 - (hide annotations) (download)
Wed Aug 27 20:10:47 2008 UTC (15 years, 8 months ago) by snetram
Branch: MAIN
CVS Tags: smeserver-coova-chilli-0_1-3_el4_sme
Changes since 1.7: +13 -3 lines
* Wed Aug 27 2008 Jonathan Martens <smeserver-contribs@snetram.nl> 0.1-3
- Split requirements to one per line
- Removed .rpmnew directory from package
- Removed the need for templates-custom as package now requires e-smith-lib >= 1.0.0-18

1 snetram 1.8 # $Id: smeserver-coova-chilli.spec,v 1.7 2008/08/27 13:44:45 slords Exp $
2 slords 1.7 # Authority: vip-ire
3     # Name: Daniel Berteaud
4    
5 slords 1.1 Summary: Coova-Chilli, a captive portal based on ChilliSpot configured for SME server
6     %define name smeserver-coova-chilli
7     Name: %{name}
8     %define version 0.1
9 snetram 1.8 %define release 3
10 slords 1.1 Version: %{version}
11 vip-ire 1.5 Release: %{release}%{?dist}
12 vip-ire 1.4 License: GPL
13 slords 1.1 Group: Networking/Remote access
14     Source: %{name}-%{version}.tar.gz
15     URL: http://sme.firewall-services.com
16     BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
17     BuildArchitectures: noarch
18 vip-ire 1.6 BuildRequires: e-smith-devtools
19 snetram 1.8 Requires: e-smith-release >= 7.0
20     Requires: openssl
21     Requires: coova-chilli
22     Requires: esmith-radiusd >= 1.0.0-18
23 vip-ire 1.3
24     Patch1: smeserver-coova-chilli-0.1-bypass_auth_with_squid_fix.patch
25     Patch2: smeserver-coova-chilli-0.1-expand_masq_fix.patch
26     Patch3: smeserver-coova-chilli-0.1-firewall2db.patch
27     Patch4: smeserver-coova-chilli-0.1-loginPageDir.patch
28 slords 1.1
29     %description
30     This package allow you to configure a third interface
31     (eth2). Just plug a WiFi AP on it, and you'll have
32     a secured captive portal. Users will be redirected
33     on a logon page and they'll have to enter credentials
34     (sme accounts) before the server allows them. By default,
35 vip-ire 1.5 they'll only have web access if they are members of the group "chilli"
36     This contrib will only work in server&gateway mode
37 slords 1.1
38     %changelog
39 snetram 1.8 * Wed Aug 27 2008 Jonathan Martens <smeserver-contribs@snetram.nl> 0.1-3
40     - Split requirements to one per line
41     - Removed .rpmnew directory from package
42     - Removed the need for templates-custom as package now requires e-smith-lib >= 1.0.0-18
43    
44 vip-ire 1.3 * Tue Aug 26 2008 Daniel B. <daniel@firewall-services.com>
45     - [0.1-2]
46 vip-ire 1.5 - Most firewall customizations (for incomming and forwarded traffic from
47 vip-ire 1.3 chilli network only) can be set through db commands (Patch3)
48     - Outgoing DNS is allowed only for the two DNS servers configured
49 vip-ire 1.5 - Clean spec file, and put php files in /opt/chilli (Patch4)
50 vip-ire 1.3
51 slords 1.1 * Tue Apr 15 2008 Daniel Berteaud <daniel@firewall-services.com>
52     - [0.1-1]
53     - security fixe: auth bypass with squid (patch1)
54     - masq template not expanded (patch2)
55    
56     * Fri Apr 04 2008 Daniel Berteaud <daniel@firewall-services.com>
57     - [0.1]
58     - initiale release
59    
60     %prep
61     %setup
62     %patch1 -p1
63     %patch2 -p1
64 vip-ire 1.3 %patch3 -p1
65     %patch4 -p1
66 snetram 1.8 rm -rf root/opt/chilli.rpmnew/
67     rm -rf root/etc/e-smith/templates-custom/
68 slords 1.1
69     %build
70     /usr/bin/perl createlinks
71    
72     %install
73     /bin/rm -rf $RPM_BUILD_ROOT
74     (cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT)
75     /bin/rm -f %{name}-%{version}-filelist
76     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
77     --file /etc/chilli/conup.sh 'attr(0750,root,root)' \
78     --file /etc/chilli/condown.sh 'attr(0750,root,root)' \
79 vip-ire 1.3 --file /opt/chilli/hotspotlogin-loginform.php 'config(noreplace)' \
80     --file /opt/chilli/hotspotlogin-nonchilli.php 'config(noreplace)' \
81     --file /opt/chilli/hotspotlogin-nonssl.php 'config(noreplace)' \
82     --file /opt/chilli/hotspotlogin.php 'config(noreplace)' \
83     --file /opt/chilli/lang/en.php 'config(noreplace)' \
84     --file /opt/chilli/lang/fr.php 'config(noreplace)' \
85     --file /opt/chilli/lang/main.php 'config(noreplace)' \
86     --file /opt/chilli/template/loggingin.php 'config(noreplace)' \
87     --file /opt/chilli/template/loginform-footer.php 'config(noreplace)' \
88     --file /opt/chilli/template/loginform-header.php 'config(noreplace)' \
89 slords 1.1 > %{name}-%{version}-filelist
90    
91     %files -f %{name}-%{version}-filelist
92     %defattr(-,root,root)
93    
94     %clean
95     rm -rf $RPM_BUILD_ROOT
96    
97     %preun
98 vip-ire 1.3
99 slords 1.1 if [ $1 == 0 ]; then
100     /sbin/e-smith/db configuration setprop chilli status disabled
101 slords 1.7 /etc/rc.d/init.d/chilli stop >& /dev/null || :
102 slords 1.1 fi
103    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed