1 |
# $Id: smeserver-dansguardian.spec,v 1.7 2009/04/30 10:35:51 dungog Exp $ |
2 |
# Authority: dungog |
3 |
# Name: Stephen Noble |
4 |
|
5 |
%define name smeserver-dansguardian |
6 |
%define version 2.9 |
7 |
%define release 7 |
8 |
|
9 |
Summary: Set up dansguardian to filter www content. |
10 |
Name: %{name} |
11 |
Version: %{version} |
12 |
Release: %{release}%{?dist} |
13 |
License: GNU GPL version 2 |
14 |
URL: http://www.dungog.net/sme |
15 |
Group: SMEserver/addon |
16 |
Source: %{name}-%{version}.tar.gz |
17 |
Patch0: smeserver-dansguardian-2.9-unblock80.patch |
18 |
Patch1: smeserver-dansguardian-2.9-block8080.patch |
19 |
Patch2: smeserver-dansguardian-2.9-block8080-2.patch |
20 |
BuildRoot: %{_tmppath}/%{name}-buildroot |
21 |
BuildArchitectures: noarch |
22 |
BuildRequires: e-smith-devtools >= 1.13.1-03 |
23 |
Requires: e-smith-release >= 7.0 |
24 |
Requires: dansguardian >= 2.9 |
25 |
AutoReqProv: no |
26 |
|
27 |
%description |
28 |
rpm to setup dansguardian.org web content filter |
29 |
|
30 |
%changelog |
31 |
* Tue Jun 09 2009 Stephen Noble <support@dungog.net> 2.9-7 |
32 |
- undo portblocking on 443 |
33 |
|
34 |
* Wed Apr 30 2009 Stephen Noble <support@dungog.net> 2.9-6 |
35 |
- portblocking now blocks 443 as well as 3128 |
36 |
|
37 |
* Fri May 30 2008 Stephen Noble <support@dungog.net> 2.9-5 |
38 |
- fix portblocking on 8080 |
39 |
|
40 |
* Fri May 30 2008 Stephen Noble <support@dungog.net> 2.9-4 |
41 |
- $dansguardian{portblocking} = yes, blocks external 8080 |
42 |
|
43 |
* Thu Jul 05 2007 Stephen Noble <support@dungog.net> 2.9-3 |
44 |
- $dansguardian{portblocking} = yes, just blocks 3128 |
45 |
|
46 |
* Thu Jul 05 2007 Stephen Noble <support@dungog.net> |
47 |
- Build on lordsfam |
48 |
|
49 |
* Wed Sep 27 2006 Stephen Noble <support@dungog.net> |
50 |
- lograte gzip's files |
51 |
- uses initialize-default-databases |
52 |
- [2.9-2] |
53 |
|
54 |
* Wed Sep 27 2006 Stephen Noble <support@dungog.net> |
55 |
- update for 2.9 |
56 |
- no longer runs under daemontools |
57 |
- [2.9-1] |
58 |
|
59 |
* Sun Mar 12 2006 Stephen Noble <support@dungog.net> |
60 |
- 15AuthProgramPamAuth, spaces removed from realm |
61 |
- [1.2-4] |
62 |
|
63 |
* Thu Mar 9 2006 Stephen Noble <support@dungog.net> |
64 |
- 15AuthProgramPamAuth, realm put inside quotes |
65 |
- ident added, but it's broken |
66 |
- [1.2-3] |
67 |
|
68 |
* Sun Nov 6 2005 Stephen Noble <support@dungog.net> |
69 |
- db value to block ports changed |
70 |
- ncsa_auth password file changed |
71 |
- [1.2-2] |
72 |
|
73 |
* Fri Sep 16 2005 Stephen Noble <support@dungog.net> |
74 |
- SME7 initial version |
75 |
- runs under daemontools |
76 |
- for DG 2.8.0.6-el4 no patches |
77 |
- [1.2-1] |
78 |
|
79 |
<snip> |
80 |
* Tue Nov 6 2001 Stephen Noble <stephen@dungog.net> 0.1-1 |
81 |
- initial release |
82 |
|
83 |
%prep |
84 |
%setup |
85 |
%patch0 -p1 |
86 |
%patch1 -p1 |
87 |
%patch2 -p1 |
88 |
|
89 |
%build |
90 |
perl createlinks |
91 |
|
92 |
mkdir -p root/etc/e-smith/db/configuration/defaults/dansguardian |
93 |
echo "service" > root/etc/e-smith/db/configuration/defaults/dansguardian/type |
94 |
echo "enabled" > root/etc/e-smith/db/configuration/defaults/dansguardian/status |
95 |
|
96 |
%install |
97 |
rm -rf $RPM_BUILD_ROOT |
98 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
99 |
rm -f %{name}-%{version}-filelist |
100 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
101 |
--file '/etc/cron.weekly/dansguardian-logrotate' 'attr(0755,root,root)' \ |
102 |
> %{name}-%{version}-filelist |
103 |
echo "%doc COPYING" >> %{name}-%{version}-filelist |
104 |
|
105 |
%clean |
106 |
cd .. |
107 |
rm -rf %{name}-%{version} |
108 |
|
109 |
%pre |
110 |
|
111 |
%preun |
112 |
%post |
113 |
|
114 |
#gzip old log files |
115 |
if [ -z /var/log/dansguardian/access.log.1 ] ; then |
116 |
gzip -f /var/log/dansguardian/access.log.1 |
117 |
fi |
118 |
if [ -z /var/log/dansguardian/access.log.2 ] ; then |
119 |
gzip -f /var/log/dansguardian/access.log.2 |
120 |
fi |
121 |
if [ -z /var/log/dansguardian/access.log.3 ] ; then |
122 |
gzip -f /var/log/dansguardian/access.log.3 |
123 |
fi |
124 |
if [ -z /var/log/dansguardian/access.log.4 ] ; then |
125 |
gzip -f /var/log/dansguardian/access.log.4 |
126 |
fi |
127 |
|
128 |
%postun |
129 |
|
130 |
#uninstalls |
131 |
if [ $1 = 0 ] ; then |
132 |
/sbin/e-smith/db configuration setprop squid TransparentPort 3128 |
133 |
/sbin/e-smith/expand-template /etc/httpd/conf/proxy/proxy.pac |
134 |
/sbin/e-smith/expand-template /etc/squid/squid.conf |
135 |
echo 'optionally run signal-event network-create to complete uninstall' |
136 |
fi |
137 |
|
138 |
#&upgrades |
139 |
|
140 |
%files -f %{name}-%{version}-filelist |
141 |
%defattr(-,root,root) |