1 |
%define name smeserver-dhcp-dns |
2 |
%define version 1.2.0 |
3 |
%define release 5 |
4 |
|
5 |
Summary: contrib to update dynamically the dns data |
6 |
Name: %{name} |
7 |
Version: %{version} |
8 |
Release: %{release}%{?dist} |
9 |
Source: %{name}-%{version}.tar.gz |
10 |
Patch0: smeserver-dhcp-dns-1.2.0-systemd.patch |
11 |
|
12 |
License: GNU GPL version 2 |
13 |
URL: http://www.contribs.org |
14 |
Group: SMEserver/addon |
15 |
BuildRoot: %{_tmppath}/%{name}-buildroot |
16 |
BuildArchitectures: noarch |
17 |
BuildRequires: e-smith-devtools |
18 |
Requires: e-smith-release >= 8.0 |
19 |
AutoReqProv: no |
20 |
|
21 |
%description |
22 |
Implementation of some features arround dhcp to dynamically update dns data file whenever the dhcp file changes. |
23 |
This eliminates the 'pc-0001' etc. default names. |
24 |
|
25 |
%changelog |
26 |
* Tue Mar 30 2021 Jean-Philippe Pialasse <tests@pialasse.com> 1.2.0-5.sme |
27 |
- moving to systemd + update event [SME: 11031] |
28 |
|
29 |
* Mon Oct 12 2020 Brian Read <brianr@bjsystems.co.uk> 1.2.0-4.sme |
30 |
- Initial import to SME10 tree [SME: 11031] |
31 |
|
32 |
* Wed Aug 19 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 1.2.0-3 |
33 |
- now released in smecontribs |
34 |
|
35 |
* Thu Jul 30 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 1.2.0-2 |
36 |
- finished lease are now prohibited |
37 |
|
38 |
* Sat Jul 25 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 1.2.0-1 |
39 |
- enhancement following the bug [SME: 2388] |
40 |
- e-smith-tinydns-2.4.0_add_hostname_following_dhcpdleases_hostname.patch |
41 |
- waiting a release to the core, it is now a contrib for sme9 |
42 |
|
43 |
* Wed Jun 18 2014 stephane de Labrusse <stephdl@de-labrusse.fr> 1.1.2-1 |
44 |
- correction of file 65dhcpARecords |
45 |
|
46 |
* Sun May 18 2014 stephane de Labrusse <stephdl@de-labrusse.fr> 1.1.0-12 |
47 |
- add a tinydns expand-template on event dhcp-dns |
48 |
- add a restart dhcp-dns to signal-event dhcp-dns |
49 |
- minor correction on event->action name |
50 |
|
51 |
* Tue May 13 2014 stephane de Labrusse <stephdl@de-labrusse.fr> 1.1.0-8 |
52 |
- First release for SME Server 9.0 |
53 |
- Thanks to John Crisp, Stefano Zamboni and Rick Jones |
54 |
- This contribs is made from the solution of Stefano Zamboni [SME:2388] |
55 |
- and the original idea of Rick Jones. |
56 |
|
57 |
* Sun Mar 20 2005 Rick Jones <rick@activeservice.co.uk> |
58 |
- [1.0-1] |
59 |
- First complete release, includes resolution of client name clashes |
60 |
- (thanks to Placido Sanchez for suggestions and load-testing) |
61 |
- also ignores expired entries in the leases file |
62 |
|
63 |
* Fri Apr 30 2004 Rick Jones <rick@activeservice.co.uk> |
64 |
- [0.9-rc1] |
65 |
- First provisional release, added GPL & README |
66 |
|
67 |
* Fri Apr 30 2004 Rick Jones <rick@activeservice.co.uk> |
68 |
- [0.2-2] |
69 |
- Patch hostentries web-panel to allow non-IP entry of remote host, |
70 |
- allows Cname support to be used (un-patch when RPM removed) |
71 |
|
72 |
* Fri Apr 23 2004 Rick Jones <rick@activeservice.co.uk> |
73 |
- [0.2-1] |
74 |
- Handle static IPs, replaces 50domainARecords with 60hostARecords |
75 |
|
76 |
* Thu Apr 22 2004 Rick Jones <rick@activeservice.co.uk> |
77 |
- [0.1-3] |
78 |
- Regenerate old DNS data after RPM removal |
79 |
- Minor tidying |
80 |
|
81 |
* Thu Apr 22 2004 Rick Jones <rick@activeservice.co.uk> |
82 |
- [0.1-2] |
83 |
- Moved actual daemon code into dhcp-dnsd, run just execs (better for ps) |
84 |
- Add missing "run" file for log directory, and create /var/log directory |
85 |
- Add some logging output |
86 |
- Remove rc files (service is up by default, no startup needed) |
87 |
- Re-arrange initialisation & cleanup |
88 |
|
89 |
* Sun Apr 18 2004 Rick Jones <rick@activeservice.co.uk> |
90 |
- [0.1-1] |
91 |
- Initial beta release |
92 |
|
93 |
|
94 |
|
95 |
%prep |
96 |
%setup |
97 |
%patch0 -p1 |
98 |
|
99 |
|
100 |
%build |
101 |
perl createlinks |
102 |
|
103 |
|
104 |
%install |
105 |
rm -rf $RPM_BUILD_ROOT |
106 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
107 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
108 |
--file /var/service/dhcp-dns/dhcp-dns 'attr(0750,root,root)' \ |
109 |
--file /var/service/dhcp-dns/run 'attr(0750,root,root)' \ |
110 |
> %{name}-%{version}-%{release}-filelist |
111 |
echo "%doc COPYING" >> %{name}-%{version}-%{release}-filelist |
112 |
%clean |
113 |
cd .. |
114 |
rm -rf %{name}-%{version} |
115 |
|
116 |
%pre |
117 |
%preun |
118 |
|
119 |
%post |
120 |
|
121 |
%postun |
122 |
|
123 |
%files -f %{name}-%{version}-%{release}-filelist |
124 |
%defattr(-,root,root) |