1 |
jcrisp |
1.1 |
%define name smeserver-docker |
2 |
|
|
%define version 0.4 |
3 |
jcrisp |
1.2 |
%define release 2%{?dist} |
4 |
jcrisp |
1.1 |
Summary: Contrib to manage basic docker setup |
5 |
|
|
Name: %{name} |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release} |
8 |
|
|
License: GNU GPL version 2 |
9 |
|
|
URL: http://www.docker.com/ |
10 |
|
|
Group: SMEserver/addon |
11 |
|
|
Source: %{name}-%{version}.tar.gz |
12 |
jcrisp |
1.2 |
Patch1: smeserver-docker-0.4-containerd-db-entry.patch |
13 |
jcrisp |
1.1 |
|
14 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
15 |
|
|
BuildArchitectures: noarch |
16 |
|
|
BuildRequires: e-smith-devtools |
17 |
|
|
Requires: e-smith-release >= 10.0 |
18 |
|
|
Requires: docker-ce >= 20.10 |
19 |
|
|
AutoReqProv: no |
20 |
|
|
|
21 |
|
|
%description |
22 |
|
|
Docker is an open-source project that automates the deployment of applications inside software containers |
23 |
|
|
|
24 |
|
|
%changelog |
25 |
jcrisp |
1.2 |
* Thu Mar 10 2022 John Crisp <jcrisp@safeandsoundit.co.uk> 0.4-2.sme |
26 |
|
|
- Add containerd db entries |
27 |
|
|
|
28 |
jcrisp |
1.1 |
* Thu Mar 10 2022 John Crisp <jcrisp@safeandsoundit.co.uk> 0.4-1.sme |
29 |
|
|
- First import to Koozali SME Server v10 [SME: 11892] |
30 |
|
|
- Add basic templates |
31 |
|
|
|
32 |
|
|
* Fri Aug 17 2018 John Crisp <jcrisp@safeandsoundit.co.uk> 0.2-1 |
33 |
|
|
- Add template directory for docker-compose.yml |
34 |
|
|
- You can then add gragments from your own contrib. |
35 |
|
|
|
36 |
|
|
* Sun Apr 08 2018 John Crisp <jcrisp@safeandsoundit.co.uk> 0.1-5 |
37 |
|
|
- Missed a # in /etc/sysconfig/docker |
38 |
|
|
|
39 |
|
|
* Tue Mar 27 2018 John Crisp <jcrisp@safeandsoundit.co.uk> 0.1-4 |
40 |
|
|
- Missed a # in the spec file |
41 |
|
|
|
42 |
|
|
* Thu Mar 15 2018 John Crisp <jcrisp@safeandsoundit.co.uk> 0.1-3 |
43 |
|
|
- add rc.7 service links for docker and mongod |
44 |
|
|
- Fix prelink error on docker-compose see https://github.com/docker/compose/issues/ |
45 |
|
|
- fix errant semi colon in createlinks |
46 |
|
|
- move demo docker file out of configs so it doesn't overwrite originals |
47 |
|
|
|
48 |
|
|
* Sun Mar 11 2018 John Crisp <jcrisp@safeandsoundit.co.uk> 0.1-2 |
49 |
|
|
- update spec file to set props on docker-compose |
50 |
|
|
- mover docker-compose to /usr/bin |
51 |
|
|
|
52 |
|
|
* Sun Mar 4 2018 John Crisp <jcrisp@safeandsoundit.co.uk> 0.1-1 |
53 |
|
|
- initial release |
54 |
|
|
- basic file layout |
55 |
|
|
- removed httpd templates - need to create your own |
56 |
|
|
|
57 |
|
|
%prep |
58 |
|
|
%setup |
59 |
|
|
|
60 |
jcrisp |
1.2 |
%patch1 -p1 |
61 |
jcrisp |
1.1 |
|
62 |
|
|
%build |
63 |
|
|
perl createlinks |
64 |
|
|
|
65 |
|
|
%install |
66 |
|
|
rm -rf $RPM_BUILD_ROOT |
67 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
68 |
|
|
rm -f %{name}-%{version}-filelist |
69 |
|
|
|
70 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
71 |
|
|
echo "%doc COPYING LICENSE" >> %{name}-%{version}-filelist |
72 |
|
|
|
73 |
|
|
|
74 |
|
|
%clean |
75 |
|
|
cd .. |
76 |
|
|
rm -rf %{name}-%{version} |
77 |
|
|
|
78 |
|
|
%files -f %{name}-%{version}-filelist |
79 |
|
|
%defattr(-,root,root) |
80 |
|
|
|
81 |
|
|
%pre |
82 |
|
|
%preun |
83 |
|
|
%post |
84 |
|
|
|
85 |
|
|
# Add configs directory if it doesn't exist |
86 |
|
|
if [[ ! -d /home/e-smith/files/docker/configs ]]; then |
87 |
|
|
mkdir -p /home/e-smith/files/docker/configs; |
88 |
|
|
fi |
89 |
|
|
|
90 |
|
|
echo "see https://wiki.contribs.org/Docker" |
91 |
|
|
|
92 |
|
|
%postun |
93 |
|
|
#/sbin/e-smith/expand-template /etc/rc.d/init.d/masq |
94 |
|
|
#/sbin/e-smith/expand-template /etc/inittab |
95 |
|
|
#/sbin/init q |