1 |
jcrisp |
1.1 |
%define name smeserver-docker |
2 |
|
|
%define version 0.2 |
3 |
|
|
%define release 1 |
4 |
|
|
Summary: Contrib to manage basic docker setup |
5 |
|
|
Name: %{name} |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release} |
8 |
|
|
License: GNU GPL version 2 |
9 |
|
|
URL: http://www.docker.com/ |
10 |
|
|
Group: SMEserver/addon |
11 |
|
|
Source: %{name}-%{version}.tar.gz |
12 |
|
|
# Patch1: smeserver-docker-xxxx.patch |
13 |
|
|
|
14 |
|
|
|
15 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
16 |
|
|
BuildArchitectures: noarch |
17 |
|
|
BuildRequires: e-smith-devtools |
18 |
|
|
Requires: e-smith-release >= 9.2 |
19 |
|
|
Requires: docker-io >= 1.7.1 |
20 |
|
|
AutoReqProv: no |
21 |
|
|
|
22 |
|
|
%description |
23 |
|
|
Docker is an open-source project that automates the deployment of applications inside software containers |
24 |
|
|
|
25 |
|
|
%changelog |
26 |
|
|
* Fri Aug 17 2018 John Crisp <jcrisp@safeandsoundit.co.uk> 0.2-1 |
27 |
|
|
- Add template directory for docker-compose.yml |
28 |
|
|
- You can then add gragments from your own contrib. |
29 |
|
|
|
30 |
|
|
* Sun Apr 08 2018 John Crisp <jcrisp@safeandsoundit.co.uk> 0.1-5 |
31 |
|
|
- Missed a # in /etc/sysconfig/docker |
32 |
|
|
|
33 |
|
|
* Tue Mar 27 2018 John Crisp <jcrisp@safeandsoundit.co.uk> 0.1-4 |
34 |
|
|
- Missed a # in the spec file |
35 |
|
|
|
36 |
|
|
* Thu Mar 15 2018 John Crisp <jcrisp@safeandsoundit.co.uk> 0.1-3 |
37 |
|
|
- add rc.7 service links for docker and mongod |
38 |
|
|
- Fix prelink error on docker-compose see https://github.com/docker/compose/issues/ |
39 |
|
|
- fix errant semi colon in createlinks |
40 |
|
|
- move demo docker file out of configs so it doesn't overwrite originals |
41 |
|
|
|
42 |
|
|
* Sun Mar 11 2018 John Crisp <jcrisp@safeandsoundit.co.uk> 0.1-2 |
43 |
|
|
- update spec file to set props on docker-compose |
44 |
|
|
- mover docker-compose to /usr/bin |
45 |
|
|
|
46 |
|
|
* Sun Mar 4 2018 John Crisp <jcrisp@safeandsoundit.co.uk> 0.1-1 |
47 |
|
|
- initial release |
48 |
|
|
- basic file layout |
49 |
|
|
- removed httpd templates - need to create your own |
50 |
|
|
|
51 |
|
|
%prep |
52 |
|
|
%setup |
53 |
|
|
|
54 |
|
|
# %patch1 -p1 |
55 |
|
|
|
56 |
|
|
%build |
57 |
|
|
perl createlinks |
58 |
|
|
|
59 |
|
|
%install |
60 |
|
|
rm -rf $RPM_BUILD_ROOT |
61 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
62 |
|
|
rm -f %{name}-%{version}-filelist |
63 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
64 |
|
|
--file /usr/bin/docker-compose 'attr(4750,root,root)' \ |
65 |
|
|
> %{name}-%{version}-filelist |
66 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
67 |
|
|
|
68 |
|
|
|
69 |
|
|
%clean |
70 |
|
|
cd .. |
71 |
|
|
rm -rf %{name}-%{version} |
72 |
|
|
|
73 |
|
|
%files -f %{name}-%{version}-filelist |
74 |
|
|
%defattr(-,root,root) |
75 |
|
|
|
76 |
|
|
%pre |
77 |
|
|
%preun |
78 |
|
|
%post |
79 |
|
|
|
80 |
|
|
# Add configs directory if it doesn't exist |
81 |
|
|
if [[ ! -d /home/e-smith/files/docker/configs ]]; then |
82 |
|
|
mkdir -p /home/e-smith/files/docker/configs; |
83 |
|
|
fi |
84 |
|
|
|
85 |
|
|
|
86 |
|
|
#/sbin/e-smith/expand-template /etc/rc.d/init.d/masq |
87 |
|
|
#/sbin/e-smith/expand-template /etc/inittab |
88 |
|
|
#/sbin/init q |
89 |
|
|
|
90 |
|
|
|
91 |
|
|
echo "see https://wiki.contribs.org/Docker" |
92 |
|
|
|
93 |
|
|
%postun |
94 |
|
|
#/sbin/e-smith/expand-template /etc/rc.d/init.d/masq |
95 |
|
|
#/sbin/e-smith/expand-template /etc/inittab |
96 |
|
|
#/sbin/init q |