1 |
jcrisp |
1.1 |
%define phpversion 74 |
2 |
|
|
|
3 |
|
|
Summary: sme server integration of dokuwiki |
4 |
|
|
Name: smeserver-dokuwiki |
5 |
|
|
Version: 0.3.0 |
6 |
|
|
Release: 1%{?dist} |
7 |
|
|
License: GNU GPL |
8 |
|
|
URL: http://www.splitbrain.org/projects/dokuwiki |
9 |
|
|
Group: SMEserver/addon |
10 |
|
|
Source: %{name}-%{version}.tar.gz |
11 |
|
|
|
12 |
|
|
BuildArchitectures: noarch |
13 |
|
|
BuildRequires: e-smith-devtools |
14 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
15 |
|
|
Requires: e-smith-base >= 5.8.0 |
16 |
|
|
Requires: dokuwiki |
17 |
|
|
Requires: smeserver-webapps-common |
18 |
|
|
AutoReqProv: no |
19 |
|
|
|
20 |
|
|
%description |
21 |
|
|
smserver integration of dokuwiki |
22 |
|
|
DokuWiki is a simple to use Wiki aimed at the documentation needs of a small company |
23 |
|
|
|
24 |
|
|
%changelog |
25 |
|
|
* Mon Oct 04 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 0.3.0-1 |
26 |
|
|
- First import to SME Contribs [SME: 11703] |
27 |
|
|
- Update to PHP 74 |
28 |
|
|
|
29 |
|
|
* Mon Jan 22 2018 Daniel Berteaud <daniel@firewall-services.com> 0.2.2-1 |
30 |
|
|
- Fix permissions on plugin dir (daniel@firewall-services.com) |
31 |
|
|
|
32 |
|
|
* Sun Nov 19 2017 Daniel Berteaud <daniel@firewall-services.com> 0.2.1-1 |
33 |
|
|
- new package built with tito |
34 |
|
|
|
35 |
|
|
* Fri Jul 14 2017 Daniel Berteaud <daniel@firewall-services.com> 0.2.0-1 |
36 |
|
|
- Switch to php 71 using FastCGI and FPM is available |
37 |
|
|
|
38 |
|
|
* Wed Mar 15 2017 Daniel Berteaud <daniel@firewall-services.com> 0.1.7-1 |
39 |
|
|
- Add /dev/urandom to open_basedir, needed since 2017-02-19 |
40 |
|
|
|
41 |
|
|
* Wed Oct 29 2014 Daniel B. <daniel@firewall-services.com> 0.1.6-1 |
42 |
|
|
- Fix SSL redirection |
43 |
|
|
|
44 |
|
|
* Sat Jul 5 2014 Daniel B. <daniel@firewall-services.com> 0.1.5-1 |
45 |
|
|
- Small fixes in authhttpldap plugin |
46 |
|
|
|
47 |
|
|
* Tue May 6 2014 Daniel B. <daniel@firewall-services.com> 0.1.4-1 |
48 |
|
|
- Add missing plugin.info.txt file for the authhttpldap plugin |
49 |
|
|
|
50 |
|
|
* Thu Dec 5 2013 Daniel B. <daniel@firewall-services.com> 0.1.3-1 |
51 |
|
|
- Push php memory limit to 128M |
52 |
|
|
|
53 |
|
|
* Fri Nov 22 2013 Daniel B. <daniel@firewall-services.com> 0.1.2-1 |
54 |
|
|
- Fix a typo which prevent transparent SSL redirection |
55 |
|
|
|
56 |
|
|
* Wed May 15 2013 Daniel B. <daniel@firewall-services.com> 0.1.1-1 |
57 |
|
|
- Use the new auth plugins to be compatible with dokuwiki 2013-05-10 |
58 |
|
|
|
59 |
|
|
* Wed May 15 2013 Daniel B. <daniel@firewall-services.com> 0.1.0-1 |
60 |
|
|
- Import in GIT |
61 |
|
|
|
62 |
|
|
* Mon Dec 19 2011 Daniel B. <daniel@firewall-services.com> 0.1-2 |
63 |
|
|
- Follow symlinks so fck media browser works |
64 |
|
|
|
65 |
|
|
* Fri Jul 08 2011 Daniel B. <daniel@firewall-services.com> 0.1-1 |
66 |
|
|
- initial release |
67 |
|
|
|
68 |
|
|
%prep |
69 |
|
|
%setup |
70 |
|
|
|
71 |
|
|
%build |
72 |
|
|
perl ./createlinks |
73 |
|
|
find root/ -type f | xargs grep -l __PHP_VERSION__ | xargs sed -i -e "s/__PHP_VERSION__/%{phpversion}/g" |
74 |
|
|
%{__mkdir_p} root/var/log/php/dokuwiki |
75 |
|
|
%{__mkdir_p} root/var/lib/php/dokuwiki/{tmp,session,opcache} |
76 |
|
|
|
77 |
|
|
%install |
78 |
|
|
rm -rf $RPM_BUILD_ROOT |
79 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
80 |
|
|
rm -f %{name}-%{version}-filelist |
81 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
82 |
|
|
--dir /var/log/php/dokuwiki 'attr(0770,root,www)' \ |
83 |
|
|
--dir /var/lib/php/dokuwiki 'attr(0770,root,www)' \ |
84 |
|
|
--dir /var/lib/php/dokuwiki/tmp 'attr(0770,root,www)' \ |
85 |
|
|
--dir /var/lib/php/dokuwiki/opcache 'attr(0770,root,www)' \ |
86 |
|
|
--dir /var/lib/php/dokuwiki/session 'attr(0770,root,www)' \ |
87 |
|
|
--dir /usr/share/dokuwiki/lib/plugins 'attr(0755,www,www)' \ |
88 |
|
|
> %{name}-%{version}-filelist |
89 |
|
|
|
90 |
|
|
%files -f %{name}-%{version}-filelist |
91 |
|
|
%defattr(-,root,root) |
92 |
|
|
|
93 |
|
|
%clean |
94 |
|
|
rm -rf $RPM_BUILD_ROOT |
95 |
|
|
|
96 |
|
|
|
97 |
|
|
%postun |
98 |
|
|
|