1 |
%define phpversion 74 |
2 |
|
3 |
Summary: sme server integration of dokuwiki |
4 |
Name: smeserver-dokuwiki |
5 |
Version: 0.3.0 |
6 |
Release: 5%{?dist} |
7 |
License: GNU GPL |
8 |
URL: http://www.splitbrain.org/projects/dokuwiki |
9 |
Group: SMEserver/addon |
10 |
Source: %{name}-%{version}.tar.gz |
11 |
|
12 |
BuildArchitectures: noarch |
13 |
BuildRequires: e-smith-devtools |
14 |
BuildRoot: /var/tmp/%{name}-%{version} |
15 |
Requires: e-smith-base >= 5.8.0 |
16 |
Requires: dokuwiki |
17 |
Requires: smeserver-webapps-common |
18 |
Requires: e-smith-apache >= 2.6.0-19 |
19 |
Requires: smeserver-php >= 3.0.0-43 |
20 |
|
21 |
Patch0: smeserver-dokuwiki-0.3.0-Add-Update-Event.patch |
22 |
Patch1: smeserver-dokuwiki-0.3.0-fix-httpd-syntax.patch |
23 |
Patch2: smeserver-dokuwiki-0.3.0-bz12043_httpd_conf-bz12005_backup.patch |
24 |
|
25 |
AutoReqProv: no |
26 |
|
27 |
%description |
28 |
smserver integration of dokuwiki |
29 |
DokuWiki is a simple to use Wiki aimed at the documentation needs of a small company |
30 |
|
31 |
%changelog |
32 |
* Fri Jun 24 2022 Michel Begue <mab974@misouk.com> 0.3.0-5.sme |
33 |
- update to httpd 2.4 syntax [SME: 12043] |
34 |
- add dokuwiki to backup list [SME: 12005] |
35 |
|
36 |
* Sat Oct 16 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 0.3.0-4.sme |
37 |
- Fix spec file patch issue |
38 |
|
39 |
* Thu Oct 14 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 0.3.0-3.sme |
40 |
- remove directory permissions for plugin directory [SME: 11703] |
41 |
- Fix httpd FilesMatch |
42 |
|
43 |
* Tue Oct 05 2021 Brian Read <brianr@bjsystems.co.uk> 0.3.0-2.sme |
44 |
- Add update event [SME: 11703] |
45 |
|
46 |
* Mon Oct 04 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 0.3.0-1 |
47 |
- First import to SME Contribs [SME: 11703] |
48 |
- Update to PHP 74 |
49 |
|
50 |
* Mon Jan 22 2018 Daniel Berteaud <daniel@firewall-services.com> 0.2.2-1 |
51 |
- Fix permissions on plugin dir (daniel@firewall-services.com) |
52 |
|
53 |
* Sun Nov 19 2017 Daniel Berteaud <daniel@firewall-services.com> 0.2.1-1 |
54 |
- new package built with tito |
55 |
|
56 |
* Fri Jul 14 2017 Daniel Berteaud <daniel@firewall-services.com> 0.2.0-1 |
57 |
- Switch to php 71 using FastCGI and FPM is available |
58 |
|
59 |
* Wed Mar 15 2017 Daniel Berteaud <daniel@firewall-services.com> 0.1.7-1 |
60 |
- Add /dev/urandom to open_basedir, needed since 2017-02-19 |
61 |
|
62 |
* Wed Oct 29 2014 Daniel B. <daniel@firewall-services.com> 0.1.6-1 |
63 |
- Fix SSL redirection |
64 |
|
65 |
* Sat Jul 5 2014 Daniel B. <daniel@firewall-services.com> 0.1.5-1 |
66 |
- Small fixes in authhttpldap plugin |
67 |
|
68 |
* Tue May 6 2014 Daniel B. <daniel@firewall-services.com> 0.1.4-1 |
69 |
- Add missing plugin.info.txt file for the authhttpldap plugin |
70 |
|
71 |
* Thu Dec 5 2013 Daniel B. <daniel@firewall-services.com> 0.1.3-1 |
72 |
- Push php memory limit to 128M |
73 |
|
74 |
* Fri Nov 22 2013 Daniel B. <daniel@firewall-services.com> 0.1.2-1 |
75 |
- Fix a typo which prevent transparent SSL redirection |
76 |
|
77 |
* Wed May 15 2013 Daniel B. <daniel@firewall-services.com> 0.1.1-1 |
78 |
- Use the new auth plugins to be compatible with dokuwiki 2013-05-10 |
79 |
|
80 |
* Wed May 15 2013 Daniel B. <daniel@firewall-services.com> 0.1.0-1 |
81 |
- Import in GIT |
82 |
|
83 |
* Mon Dec 19 2011 Daniel B. <daniel@firewall-services.com> 0.1-2 |
84 |
- Follow symlinks so fck media browser works |
85 |
|
86 |
* Fri Jul 08 2011 Daniel B. <daniel@firewall-services.com> 0.1-1 |
87 |
- initial release |
88 |
|
89 |
%prep |
90 |
%setup |
91 |
%patch0 -p1 |
92 |
%patch1 -p1 |
93 |
%patch2 -p1 |
94 |
|
95 |
%build |
96 |
perl ./createlinks |
97 |
find root/ -type f | xargs grep -l __PHP_VERSION__ | xargs sed -i -e "s/__PHP_VERSION__/%{phpversion}/g" |
98 |
%{__mkdir_p} root/var/log/php/dokuwiki |
99 |
%{__mkdir_p} root/var/lib/php/dokuwiki/{tmp,session,opcache} |
100 |
|
101 |
%install |
102 |
rm -rf $RPM_BUILD_ROOT |
103 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
104 |
rm -f %{name}-%{version}-filelist |
105 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
106 |
--dir /var/log/php/dokuwiki 'attr(0770,root,www)' \ |
107 |
--dir /var/lib/php/dokuwiki 'attr(0770,root,www)' \ |
108 |
--dir /var/lib/php/dokuwiki/tmp 'attr(0770,root,www)' \ |
109 |
--dir /var/lib/php/dokuwiki/opcache 'attr(0770,root,www)' \ |
110 |
--dir /var/lib/php/dokuwiki/session 'attr(0770,root,www)' \ |
111 |
--ignoredir /usr/share/dokuwiki/lib/plugins \ |
112 |
> %{name}-%{version}-filelist |
113 |
|
114 |
%files -f %{name}-%{version}-filelist |
115 |
%defattr(-,root,root) |
116 |
|
117 |
%clean |
118 |
rm -rf $RPM_BUILD_ROOT |
119 |
|
120 |
%postun |