1 |
stephdl |
1.1 |
%define version 0.1.1 |
2 |
|
|
%define release 2 |
3 |
|
|
%define name smeserver-dovecot-extras |
4 |
|
|
|
5 |
|
|
|
6 |
|
|
Summary: Additional features for dovecot on SME Server |
7 |
|
|
Name: %{name} |
8 |
|
|
Version: %{version} |
9 |
|
|
Release: %{release}%{?dist} |
10 |
|
|
License: GPL |
11 |
|
|
Group: Networking/Daemons |
12 |
|
|
Source: %{name}-%{version}.tar.gz |
13 |
|
|
|
14 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
15 |
|
|
BuildArchitectures: noarch |
16 |
|
|
BuildRequires: e-smith-devtools |
17 |
|
|
|
18 |
|
|
Requires: smeserver-dovecot |
19 |
|
|
Requires: dovecot-pigeonhole |
20 |
|
|
Requires: acl |
21 |
|
|
|
22 |
|
|
%description |
23 |
|
|
Add IMAP acl (sharedmailbox) and sieve capabilities to the IMAP server |
24 |
|
|
|
25 |
|
|
%changelog |
26 |
|
|
* Wed Sep 02 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 0.1.1-2.sme |
27 |
|
|
- Initial release to contribs9 |
28 |
|
|
|
29 |
|
|
* Mon Jun 23 2014 Daniel Berteaud <daniel@firewall-services.com> - 0.1.1-1 |
30 |
|
|
- Add midding /home/e-smith/db/dovecot dir |
31 |
|
|
- Remove submission_host for sieve |
32 |
|
|
|
33 |
|
|
* Tue Oct 29 2013 Daniel Berteaud <daniel@firewall-services.com> - 0.0.2-1 |
34 |
|
|
- Use SMTP for sieve notifications |
35 |
|
|
|
36 |
|
|
* Tue Nov 29 2011 Daniel Berteaud <daniel@firewall-services.com> - 0.0.1-1 |
37 |
|
|
- initial release |
38 |
|
|
|
39 |
|
|
%prep |
40 |
|
|
%setup -q -n %{name}-%{version} |
41 |
|
|
|
42 |
|
|
%build |
43 |
|
|
perl createlinks |
44 |
|
|
mkdir -p root/home/e-smith/db/dovecot |
45 |
|
|
|
46 |
|
|
%install |
47 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
48 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
49 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
50 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
51 |
|
|
--dir /home/e-smith/db/dovecot 'attr(2770,root,sharedmailbox)' \ |
52 |
|
|
--file /home/e-smith/db/dovecot/sharedmailbox.db 'attr(0660,root,sharedmailbox) %config(noreplace)' \ |
53 |
|
|
--file /usr/bin/imap-postlogin 'attr(0755,root,root)' \ |
54 |
|
|
> %{name}-%{version}-filelist |
55 |
|
|
|
56 |
|
|
%files -f %{name}-%{version}-filelist |
57 |
|
|
%defattr(-,root,root) |
58 |
|
|
|
59 |
|
|
%clean |
60 |
|
|
rm -rf $RPM_BUILD_ROOT |
61 |
|
|
|
62 |
|
|
%pre |
63 |
|
|
/usr/sbin/groupadd -g 439 sharedmailbox 2> /dev/null || : |
64 |
|
|
|
65 |
|
|
%post |
66 |
|
|
# Migrate the sharedmailbox dict to its new location |
67 |
|
|
if [ -e /etc/dovecot/sharedmailbox/dict.db ]; then |
68 |
|
|
mv -f /etc/dovecot/sharedmailbox/dict.db /home/e-smith/db/dovecot/sharedmailbox.db |
69 |
|
|
rm -rf /etc/dovecot/sharedmailbox |
70 |
|
|
fi |
71 |
|
|
|
72 |
|
|
%preun |
73 |
|
|
|