1 |
brianr |
1.1 |
# $Id: smeserver-durep.spec,v 1.5 2019/12/28 19:10:45 jpp Exp $ |
2 |
|
|
# Authority: unnilennnium |
3 |
|
|
# Name: JP Pialasse |
4 |
|
|
|
5 |
|
|
%define name smeserver-durep |
6 |
|
|
Name: %{name} |
7 |
|
|
%define version 1.5.0 |
8 |
|
|
Version: %{version} |
9 |
|
|
%define release 4 |
10 |
|
|
Release: %{release}%{?dist} |
11 |
|
|
License: GPL |
12 |
|
|
Source: %{name}-%{version}.tar.gz |
13 |
|
|
Patch0: smeserver-durep-1.5.0-bz10118-more_paths.patch |
14 |
|
|
Patch1: smeserver-durep-1.5.0-dfposix.patch |
15 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-buildroot |
16 |
|
|
BuildRequires: e-smith-devtools |
17 |
|
|
BuildArch: noarch |
18 |
|
|
Group: Networking/Daemons |
19 |
|
|
Summary: DUREP - Graphic Report for Disk Usage |
20 |
|
|
Requires: perl(Data::Dumper) |
21 |
|
|
Requires: perl(MLDBM) >= 1.21-4 |
22 |
|
|
Obsoletes: smeserver-durep-saco |
23 |
|
|
Obsoletes: e-smith-durep |
24 |
|
|
|
25 |
|
|
|
26 |
|
|
%changelog |
27 |
|
|
* Sat Dec 28 2019 Jean-Philipe Pialasse <tests@pialasse.com> 1.5.0-4.sme |
28 |
|
|
- output all mounted points with df on one line using Posix |
29 |
|
|
|
30 |
|
|
* Sat Feb 10 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.5.0-3.sme |
31 |
|
|
- add hability to stat more directories [SME: 10118] |
32 |
|
|
- add status enabled or disabled |
33 |
|
|
|
34 |
|
|
* Sat Aug 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 1.5.0-2.sme |
35 |
|
|
- Initial release to contribs9 |
36 |
|
|
|
37 |
|
|
* Sat Jun 21 2014 stephane de Labrusse <stephdl@de-labrusse.fr> 1.5.0-1.sme |
38 |
|
|
- Initial release to sme9 |
39 |
|
|
|
40 |
|
|
* Thu Sep 13 2012 JP Pialasse <test@pialasse.com> 1.3.0-6.sme |
41 |
|
|
- add Obsoletes smeserver-durep-saco e-smith-durep [SME 7108] |
42 |
|
|
- TODO cleaning spec file post and filelist chmod |
43 |
|
|
|
44 |
|
|
* Mon Sep 10 2012 JP Pialasse <test@pialasse.com> 1.3.0-5.sme |
45 |
|
|
- fix do not copy files and filelist [SME 7098] |
46 |
|
|
- patch df of plugged disk |
47 |
|
|
|
48 |
|
|
* Sun Sep 09 2012 JP Pialasse <test@pialasse.com> 1.3.0-4.sme |
49 |
|
|
- dependencies resolution |
50 |
|
|
|
51 |
|
|
* Fri Aug 31 2012 JP Pialasse <test@pialasse.com> 1.3.0-3.sme |
52 |
|
|
- build error fix : prep setup |
53 |
|
|
|
54 |
|
|
* Wed Aug 15 2012 JP Pialasse <test@pialasse.com> 1.3.0-1.sme |
55 |
|
|
- update from 1.03-02sn to comply with SME8 and SME7 |
56 |
|
|
- moved archives to /var/lib/durep |
57 |
|
|
- moved web files to manager/html |
58 |
|
|
- cleaned spec |
59 |
|
|
|
60 |
|
|
%description |
61 |
|
|
DUREP is a Report Generator that creates graphical Output for the "du" command |
62 |
|
|
|
63 |
|
|
%prep |
64 |
|
|
%setup |
65 |
|
|
%patch0 -p1 |
66 |
|
|
%patch1 -p1 |
67 |
|
|
|
68 |
|
|
%install |
69 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
70 |
|
|
(cd root; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
71 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
72 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
73 |
|
|
|
74 |
|
|
|
75 |
|
|
%clean |
76 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
77 |
|
|
|
78 |
|
|
%files -f %{name}-%{version}-filelist |
79 |
|
|
%defattr(-,root,root) |
80 |
|
|
|
81 |
|
|
#%attr(0644 root root) "/etc/e-smith/templates/etc/crontab/durep" |
82 |
|
|
#%attr(4750 root admin) "/etc/e-smith/web/functions/durep" |
83 |
|
|
#%attr(0777 root root) "/etc/e-smith/web/panels/manager/cgi-bin/durep" |
84 |
|
|
#%attr(0644 root root) "/usr/local/bin/durep" |
85 |
|
|
#%dir %attr(0755 root root) "/usr/local/man" |
86 |
|
|
#%dir %attr(0755 root root) "/usr/local/man/man1" |
87 |
|
|
#%attr(0644 root root) "/usr/local/man/man1/durep.1" |
88 |
|
|
#%dir %attr(0755 root root) "/usr/sbin" |
89 |
|
|
#%attr(0644 root root) "/usr/sbin/durep.daily" |
90 |
|
|
#%dir %attr(0755 root root) "/var/lib/durep" |
91 |
|
|
#%dir %attr(0755 root root) "/etc/e-smith/web/panels/manager/html/durep" |
92 |
|
|
#%attr(0644 root root) "/etc/e-smith/web/panels/manager/html/durep/bar.png" |
93 |
|
|
#%attr(0644 root root) "/etc/e-smith/web/panels/manager/html/durep/durep.cgi" |
94 |
|
|
#%attr(0644 root root) "/etc/e-smith/web/panels/manager/html/durep/style.css" |
95 |
|
|
|
96 |
|
|
%pre -p /bin/sh |
97 |
|
|
|
98 |
|
|
%post -p /bin/sh |
99 |
|
|
chmod 755 /usr/local/bin/durep |
100 |
|
|
chmod 755 /usr/sbin/durep.daily |
101 |
|
|
/sbin/e-smith/expand-template /etc/crontab |
102 |
|
|
echo "Initial run of durep ... please wait." |
103 |
|
|
/usr/sbin/durep.daily >/dev/null |
104 |
|
|
/etc/e-smith/events/actions/navigation-conf >/dev/null 2>&1 |
105 |
|
|
|
106 |
|
|
%preun -p /bin/sh |
107 |
|
|
|
108 |
|
|
%postun -p /bin/sh |
109 |
|
|
if [ "$1" = 0 ]; then |
110 |
|
|
/sbin/e-smith/expand-template /etc/crontab |
111 |
|
|
/etc/e-smith/events/actions/navigation-conf 2>/dev/null |
112 |
|
|
fi |
113 |
|
|
|