1 |
slords |
1.1 |
# $Id: smeserver-durep.spec,v 1.3 2012/08/15 22:15:30 unnilennium Exp $ |
2 |
|
|
# Authority: unnilennnium |
3 |
|
|
# Name: JP Pialasse |
4 |
|
|
|
5 |
|
|
%define name smeserver-durep |
6 |
|
|
Name: %{name} |
7 |
|
|
%define version 1.3.0 |
8 |
|
|
Version: %{version} |
9 |
|
|
%define release 1 |
10 |
|
|
Release: %{release}%{?dist} |
11 |
|
|
License: GPL |
12 |
|
|
Source: %{name}-%{version}.tgz |
13 |
|
|
BuildRoot: /var/tmp/e-smith-buildroot |
14 |
|
|
BuildRequires: e-smith-devtools |
15 |
|
|
BuildArch: noarch |
16 |
|
|
Group: Networking/Daemons |
17 |
|
|
Summary: DUREP - Grphic Report for Disk Usage |
18 |
|
|
Requires: Perl(Dumper) |
19 |
|
|
Requires: Perl(MLDBM) >= 1.21-4 |
20 |
|
|
|
21 |
|
|
%changelog |
22 |
|
|
* Wed Aug 15 2012 JP Pialasse <test@pialasse.com> 1.3.0-1.sme |
23 |
|
|
- update from 1.03-02sn to comply with SME8 and SME7 |
24 |
|
|
- moved archives to /var/lib/durep |
25 |
|
|
- moved web files to manager/html |
26 |
|
|
- cleaned spec |
27 |
|
|
|
28 |
|
|
%description |
29 |
|
|
DUREP is a Report Generator that creates graphical Output for the "du" command |
30 |
|
|
|
31 |
|
|
|
32 |
|
|
%install |
33 |
|
|
rm -rf $RPM_BUILD_ROOT |
34 |
|
|
( find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
35 |
|
|
rm -f %{name}-%{version}-filelist |
36 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
37 |
|
|
%clean |
38 |
|
|
rm -rf $RPM_BUILD_ROOT |
39 |
|
|
|
40 |
|
|
%files -f %{name}-%{version}-filelist |
41 |
|
|
%defattr(-,root,root) |
42 |
|
|
|
43 |
|
|
#%attr(0644 root root) "/etc/e-smith/templates/etc/crontab/durep" |
44 |
|
|
#%attr(4750 root admin) "/etc/e-smith/web/functions/durep" |
45 |
|
|
#%attr(0777 root root) "/etc/e-smith/web/panels/manager/cgi-bin/durep" |
46 |
|
|
#%attr(0644 root root) "/usr/local/bin/durep" |
47 |
|
|
#%dir %attr(0755 root root) "/usr/local/man" |
48 |
|
|
#%dir %attr(0755 root root) "/usr/local/man/man1" |
49 |
|
|
#%attr(0644 root root) "/usr/local/man/man1/durep.1" |
50 |
|
|
#%dir %attr(0755 root root) "/usr/sbin" |
51 |
|
|
#%attr(0644 root root) "/usr/sbin/durep.daily" |
52 |
|
|
#%dir %attr(0755 root root) "/var/lib/durep" |
53 |
|
|
#%dir %attr(0755 root root) "/etc/e-smith/web/panels/manager/html/durep" |
54 |
|
|
#%attr(0644 root root) "/etc/e-smith/web/panels/manager/html/durep/bar.png" |
55 |
|
|
#%attr(0644 root root) "/etc/e-smith/web/panels/manager/html/durep/durep.cgi" |
56 |
|
|
#%attr(0644 root root) "/etc/e-smith/web/panels/manager/html/durep/style.css" |
57 |
|
|
%pre -p /bin/sh |
58 |
|
|
%post -p /bin/sh |
59 |
|
|
chmod 755 /usr/local/bin/durep |
60 |
|
|
chmod 755 /usr/sbin/durep.daily |
61 |
|
|
/sbin/e-smith/expand-template /etc/crontab |
62 |
|
|
echo "Initial run of durep ... please wait." |
63 |
|
|
/usr/sbin/durep.daily >/dev/null |
64 |
|
|
/etc/e-smith/events/actions/navigation-conf >/dev/null 2>&1 |
65 |
|
|
%preun -p /bin/sh |
66 |
|
|
%postun -p /bin/sh |
67 |
|
|
if [ "$1" = 0 ]; then |
68 |
|
|
/sbin/e-smith/expand-template /etc/crontab |
69 |
|
|
/etc/e-smith/events/actions/navigation-conf 2>/dev/null |
70 |
|
|
fi |
71 |
|
|
|