1 |
slords |
1.1 |
# $Id: smeserver-durep.spec,v 1.3 2012/08/15 22:15:30 unnilennium Exp $ |
2 |
|
|
# Authority: unnilennnium |
3 |
|
|
# Name: JP Pialasse |
4 |
|
|
|
5 |
|
|
%define name smeserver-durep |
6 |
|
|
Name: %{name} |
7 |
|
|
%define version 1.3.0 |
8 |
|
|
Version: %{version} |
9 |
unnilennium |
1.3 |
%define release 3 |
10 |
slords |
1.1 |
Release: %{release}%{?dist} |
11 |
|
|
License: GPL |
12 |
|
|
Source: %{name}-%{version}.tgz |
13 |
unnilennium |
1.2 |
BuildRoot: /var/tmp/%{name}-%{version}-buildroot |
14 |
slords |
1.1 |
BuildRequires: e-smith-devtools |
15 |
|
|
BuildArch: noarch |
16 |
|
|
Group: Networking/Daemons |
17 |
unnilennium |
1.2 |
Summary: DUREP - Graphic Report for Disk Usage |
18 |
slords |
1.1 |
Requires: Perl(Dumper) |
19 |
|
|
Requires: Perl(MLDBM) >= 1.21-4 |
20 |
|
|
|
21 |
|
|
%changelog |
22 |
unnilennium |
1.3 |
* Fri Aug 31 2012 JP Pialasse <test@pialasse.com> 1.3.0-3.sme |
23 |
|
|
- build error fix : prep setup |
24 |
unnilennium |
1.2 |
|
25 |
slords |
1.1 |
* Wed Aug 15 2012 JP Pialasse <test@pialasse.com> 1.3.0-1.sme |
26 |
|
|
- update from 1.03-02sn to comply with SME8 and SME7 |
27 |
|
|
- moved archives to /var/lib/durep |
28 |
|
|
- moved web files to manager/html |
29 |
|
|
- cleaned spec |
30 |
|
|
|
31 |
|
|
%description |
32 |
|
|
DUREP is a Report Generator that creates graphical Output for the "du" command |
33 |
|
|
|
34 |
unnilennium |
1.3 |
%prep |
35 |
|
|
|
36 |
|
|
%setup |
37 |
slords |
1.1 |
|
38 |
|
|
%install |
39 |
|
|
rm -rf $RPM_BUILD_ROOT |
40 |
|
|
( find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
41 |
|
|
rm -f %{name}-%{version}-filelist |
42 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
43 |
|
|
%clean |
44 |
|
|
rm -rf $RPM_BUILD_ROOT |
45 |
|
|
|
46 |
|
|
%files -f %{name}-%{version}-filelist |
47 |
|
|
%defattr(-,root,root) |
48 |
|
|
|
49 |
|
|
#%attr(0644 root root) "/etc/e-smith/templates/etc/crontab/durep" |
50 |
|
|
#%attr(4750 root admin) "/etc/e-smith/web/functions/durep" |
51 |
|
|
#%attr(0777 root root) "/etc/e-smith/web/panels/manager/cgi-bin/durep" |
52 |
|
|
#%attr(0644 root root) "/usr/local/bin/durep" |
53 |
|
|
#%dir %attr(0755 root root) "/usr/local/man" |
54 |
|
|
#%dir %attr(0755 root root) "/usr/local/man/man1" |
55 |
|
|
#%attr(0644 root root) "/usr/local/man/man1/durep.1" |
56 |
|
|
#%dir %attr(0755 root root) "/usr/sbin" |
57 |
|
|
#%attr(0644 root root) "/usr/sbin/durep.daily" |
58 |
|
|
#%dir %attr(0755 root root) "/var/lib/durep" |
59 |
|
|
#%dir %attr(0755 root root) "/etc/e-smith/web/panels/manager/html/durep" |
60 |
|
|
#%attr(0644 root root) "/etc/e-smith/web/panels/manager/html/durep/bar.png" |
61 |
|
|
#%attr(0644 root root) "/etc/e-smith/web/panels/manager/html/durep/durep.cgi" |
62 |
|
|
#%attr(0644 root root) "/etc/e-smith/web/panels/manager/html/durep/style.css" |
63 |
|
|
%pre -p /bin/sh |
64 |
|
|
%post -p /bin/sh |
65 |
|
|
chmod 755 /usr/local/bin/durep |
66 |
|
|
chmod 755 /usr/sbin/durep.daily |
67 |
|
|
/sbin/e-smith/expand-template /etc/crontab |
68 |
|
|
echo "Initial run of durep ... please wait." |
69 |
|
|
/usr/sbin/durep.daily >/dev/null |
70 |
|
|
/etc/e-smith/events/actions/navigation-conf >/dev/null 2>&1 |
71 |
|
|
%preun -p /bin/sh |
72 |
|
|
%postun -p /bin/sh |
73 |
|
|
if [ "$1" = 0 ]; then |
74 |
|
|
/sbin/e-smith/expand-template /etc/crontab |
75 |
|
|
/etc/e-smith/events/actions/navigation-conf 2>/dev/null |
76 |
|
|
fi |
77 |
|
|
|