1 |
slords |
1.1 |
# $Id: smeserver-durep.spec,v 1.3 2012/08/15 22:15:30 unnilennium Exp $ |
2 |
|
|
# Authority: unnilennnium |
3 |
|
|
# Name: JP Pialasse |
4 |
|
|
|
5 |
|
|
%define name smeserver-durep |
6 |
|
|
Name: %{name} |
7 |
|
|
%define version 1.3.0 |
8 |
|
|
Version: %{version} |
9 |
unnilennium |
1.4 |
%define release 4 |
10 |
slords |
1.1 |
Release: %{release}%{?dist} |
11 |
|
|
License: GPL |
12 |
|
|
Source: %{name}-%{version}.tgz |
13 |
unnilennium |
1.2 |
BuildRoot: /var/tmp/%{name}-%{version}-buildroot |
14 |
slords |
1.1 |
BuildRequires: e-smith-devtools |
15 |
|
|
BuildArch: noarch |
16 |
|
|
Group: Networking/Daemons |
17 |
unnilennium |
1.2 |
Summary: DUREP - Graphic Report for Disk Usage |
18 |
unnilennium |
1.4 |
Requires: perl(Data::Dumper) |
19 |
|
|
Requires: perl(MLDBM) >= 1.21-4 |
20 |
slords |
1.1 |
|
21 |
|
|
%changelog |
22 |
unnilennium |
1.4 |
* Sun Sep 09 2012 JP Pialasse <test@pialasse.com> 1.3.0-4.sme |
23 |
|
|
- dependencies resolution |
24 |
|
|
|
25 |
unnilennium |
1.3 |
* Fri Aug 31 2012 JP Pialasse <test@pialasse.com> 1.3.0-3.sme |
26 |
|
|
- build error fix : prep setup |
27 |
unnilennium |
1.2 |
|
28 |
slords |
1.1 |
* Wed Aug 15 2012 JP Pialasse <test@pialasse.com> 1.3.0-1.sme |
29 |
|
|
- update from 1.03-02sn to comply with SME8 and SME7 |
30 |
|
|
- moved archives to /var/lib/durep |
31 |
|
|
- moved web files to manager/html |
32 |
|
|
- cleaned spec |
33 |
|
|
|
34 |
|
|
%description |
35 |
|
|
DUREP is a Report Generator that creates graphical Output for the "du" command |
36 |
|
|
|
37 |
unnilennium |
1.3 |
%prep |
38 |
|
|
|
39 |
|
|
%setup |
40 |
slords |
1.1 |
|
41 |
|
|
%install |
42 |
|
|
rm -rf $RPM_BUILD_ROOT |
43 |
|
|
( find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
44 |
|
|
rm -f %{name}-%{version}-filelist |
45 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
46 |
|
|
%clean |
47 |
|
|
rm -rf $RPM_BUILD_ROOT |
48 |
|
|
|
49 |
|
|
%files -f %{name}-%{version}-filelist |
50 |
|
|
%defattr(-,root,root) |
51 |
|
|
|
52 |
|
|
#%attr(0644 root root) "/etc/e-smith/templates/etc/crontab/durep" |
53 |
|
|
#%attr(4750 root admin) "/etc/e-smith/web/functions/durep" |
54 |
|
|
#%attr(0777 root root) "/etc/e-smith/web/panels/manager/cgi-bin/durep" |
55 |
|
|
#%attr(0644 root root) "/usr/local/bin/durep" |
56 |
|
|
#%dir %attr(0755 root root) "/usr/local/man" |
57 |
|
|
#%dir %attr(0755 root root) "/usr/local/man/man1" |
58 |
|
|
#%attr(0644 root root) "/usr/local/man/man1/durep.1" |
59 |
|
|
#%dir %attr(0755 root root) "/usr/sbin" |
60 |
|
|
#%attr(0644 root root) "/usr/sbin/durep.daily" |
61 |
|
|
#%dir %attr(0755 root root) "/var/lib/durep" |
62 |
|
|
#%dir %attr(0755 root root) "/etc/e-smith/web/panels/manager/html/durep" |
63 |
|
|
#%attr(0644 root root) "/etc/e-smith/web/panels/manager/html/durep/bar.png" |
64 |
|
|
#%attr(0644 root root) "/etc/e-smith/web/panels/manager/html/durep/durep.cgi" |
65 |
|
|
#%attr(0644 root root) "/etc/e-smith/web/panels/manager/html/durep/style.css" |
66 |
|
|
%pre -p /bin/sh |
67 |
|
|
%post -p /bin/sh |
68 |
|
|
chmod 755 /usr/local/bin/durep |
69 |
|
|
chmod 755 /usr/sbin/durep.daily |
70 |
|
|
/sbin/e-smith/expand-template /etc/crontab |
71 |
|
|
echo "Initial run of durep ... please wait." |
72 |
|
|
/usr/sbin/durep.daily >/dev/null |
73 |
|
|
/etc/e-smith/events/actions/navigation-conf >/dev/null 2>&1 |
74 |
|
|
%preun -p /bin/sh |
75 |
|
|
%postun -p /bin/sh |
76 |
|
|
if [ "$1" = 0 ]; then |
77 |
|
|
/sbin/e-smith/expand-template /etc/crontab |
78 |
|
|
/etc/e-smith/events/actions/navigation-conf 2>/dev/null |
79 |
|
|
fi |
80 |
|
|
|