1 |
# $Id: smeserver-durep.spec,v 1.3 2012/08/15 22:15:30 unnilennium Exp $ |
2 |
# Authority: unnilennnium |
3 |
# Name: JP Pialasse |
4 |
|
5 |
%define name smeserver-durep |
6 |
Name: %{name} |
7 |
%define version 1.3.0 |
8 |
Version: %{version} |
9 |
%define release 6 |
10 |
Release: %{release}%{?dist} |
11 |
License: GPL |
12 |
Source: %{name}-%{version}.tgz |
13 |
Patch1: smeserver-durep-1.3.0-df.patch |
14 |
BuildRoot: /var/tmp/%{name}-%{version}-buildroot |
15 |
BuildRequires: e-smith-devtools |
16 |
BuildArch: noarch |
17 |
Group: Networking/Daemons |
18 |
Summary: DUREP - Graphic Report for Disk Usage |
19 |
Requires: perl(Data::Dumper) |
20 |
Requires: perl(MLDBM) >= 1.21-4 |
21 |
Obsoletes: smeserver-durep-saco |
22 |
Obsoletes: e-smith-durep |
23 |
|
24 |
|
25 |
%changelog |
26 |
* Thu Sep 13 2012 JP Pialasse <test@pialasse.com> 1.3.0-6.sme |
27 |
- add Obsoletes smeserver-durep-saco e-smith-durep [SME 7108] |
28 |
- TODO cleaning spec file post and filelist chmod |
29 |
|
30 |
* Mon Sep 10 2012 JP Pialasse <test@pialasse.com> 1.3.0-5.sme |
31 |
- fix do not copy files and filelist [SME 7098] |
32 |
- patch df of plugged disk |
33 |
|
34 |
* Sun Sep 09 2012 JP Pialasse <test@pialasse.com> 1.3.0-4.sme |
35 |
- dependencies resolution |
36 |
|
37 |
* Fri Aug 31 2012 JP Pialasse <test@pialasse.com> 1.3.0-3.sme |
38 |
- build error fix : prep setup |
39 |
|
40 |
* Wed Aug 15 2012 JP Pialasse <test@pialasse.com> 1.3.0-1.sme |
41 |
- update from 1.03-02sn to comply with SME8 and SME7 |
42 |
- moved archives to /var/lib/durep |
43 |
- moved web files to manager/html |
44 |
- cleaned spec |
45 |
|
46 |
%description |
47 |
DUREP is a Report Generator that creates graphical Output for the "du" command |
48 |
|
49 |
%prep |
50 |
%setup |
51 |
%patch1 -p1 |
52 |
|
53 |
%install |
54 |
/bin/rm -rf $RPM_BUILD_ROOT |
55 |
(cd root; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
56 |
/bin/rm -f %{name}-%{version}-filelist |
57 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
58 |
|
59 |
|
60 |
%clean |
61 |
/bin/rm -rf $RPM_BUILD_ROOT |
62 |
|
63 |
%files -f %{name}-%{version}-filelist |
64 |
%defattr(-,root,root) |
65 |
|
66 |
#%attr(0644 root root) "/etc/e-smith/templates/etc/crontab/durep" |
67 |
#%attr(4750 root admin) "/etc/e-smith/web/functions/durep" |
68 |
#%attr(0777 root root) "/etc/e-smith/web/panels/manager/cgi-bin/durep" |
69 |
#%attr(0644 root root) "/usr/local/bin/durep" |
70 |
#%dir %attr(0755 root root) "/usr/local/man" |
71 |
#%dir %attr(0755 root root) "/usr/local/man/man1" |
72 |
#%attr(0644 root root) "/usr/local/man/man1/durep.1" |
73 |
#%dir %attr(0755 root root) "/usr/sbin" |
74 |
#%attr(0644 root root) "/usr/sbin/durep.daily" |
75 |
#%dir %attr(0755 root root) "/var/lib/durep" |
76 |
#%dir %attr(0755 root root) "/etc/e-smith/web/panels/manager/html/durep" |
77 |
#%attr(0644 root root) "/etc/e-smith/web/panels/manager/html/durep/bar.png" |
78 |
#%attr(0644 root root) "/etc/e-smith/web/panels/manager/html/durep/durep.cgi" |
79 |
#%attr(0644 root root) "/etc/e-smith/web/panels/manager/html/durep/style.css" |
80 |
|
81 |
%pre -p /bin/sh |
82 |
|
83 |
%post -p /bin/sh |
84 |
chmod 755 /usr/local/bin/durep |
85 |
chmod 755 /usr/sbin/durep.daily |
86 |
/sbin/e-smith/expand-template /etc/crontab |
87 |
echo "Initial run of durep ... please wait." |
88 |
/usr/sbin/durep.daily >/dev/null |
89 |
/etc/e-smith/events/actions/navigation-conf >/dev/null 2>&1 |
90 |
|
91 |
%preun -p /bin/sh |
92 |
|
93 |
%postun -p /bin/sh |
94 |
if [ "$1" = 0 ]; then |
95 |
/sbin/e-smith/expand-template /etc/crontab |
96 |
/etc/e-smith/events/actions/navigation-conf 2>/dev/null |
97 |
fi |
98 |
|