/[smecontribs]/rpms/smeserver-durep/contribs9/smeserver-durep.spec
ViewVC logotype

Annotation of /rpms/smeserver-durep/contribs9/smeserver-durep.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.4 - (hide annotations) (download)
Sun Feb 11 03:13:58 2018 UTC (6 years, 3 months ago) by jpp
Branch: MAIN
CVS Tags: smeserver-durep-1_5_0-3_el6_sme
Changes since 1.3: +8 -2 lines
* Sat Feb 10 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.5.0-3.sme
- add hability to stat more directories [SME: 10118]
- add status enabled or disabled

1 jpp 1.4 # $Id: smeserver-durep.spec,v 1.3 2015/08/22 19:35:51 stephdl Exp $
2 stephdl 1.1 # Authority: unnilennnium
3     # Name: JP Pialasse
4    
5     %define name smeserver-durep
6     Name: %{name}
7     %define version 1.5.0
8     Version: %{version}
9 jpp 1.4 %define release 3
10 stephdl 1.1 Release: %{release}%{?dist}
11     License: GPL
12     Source: %{name}-%{version}.tar.gz
13 jpp 1.4 Patch0: smeserver-durep-1.5.0-bz10118-more_paths.patch
14 stephdl 1.1 BuildRoot: /var/tmp/%{name}-%{version}-buildroot
15     BuildRequires: e-smith-devtools
16     BuildArch: noarch
17     Group: Networking/Daemons
18     Summary: DUREP - Graphic Report for Disk Usage
19     Requires: perl(Data::Dumper)
20     Requires: perl(MLDBM) >= 1.21-4
21     Obsoletes: smeserver-durep-saco
22     Obsoletes: e-smith-durep
23    
24    
25     %changelog
26 jpp 1.4 * Sat Feb 10 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.5.0-3.sme
27     - add hability to stat more directories [SME: 10118]
28     - add status enabled or disabled
29    
30 stephdl 1.3 * Sat Aug 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 1.5.0-2.sme
31     - Initial release to contribs9
32 stephdl 1.1
33     * Sat Jun 21 2014 stephane de Labrusse <stephdl@de-labrusse.fr> 1.5.0-1.sme
34     - Initial release to sme9
35    
36     * Thu Sep 13 2012 JP Pialasse <test@pialasse.com> 1.3.0-6.sme
37     - add Obsoletes smeserver-durep-saco e-smith-durep [SME 7108]
38     - TODO cleaning spec file post and filelist chmod
39    
40     * Mon Sep 10 2012 JP Pialasse <test@pialasse.com> 1.3.0-5.sme
41     - fix do not copy files and filelist [SME 7098]
42     - patch df of plugged disk
43    
44     * Sun Sep 09 2012 JP Pialasse <test@pialasse.com> 1.3.0-4.sme
45     - dependencies resolution
46    
47     * Fri Aug 31 2012 JP Pialasse <test@pialasse.com> 1.3.0-3.sme
48     - build error fix : prep setup
49    
50     * Wed Aug 15 2012 JP Pialasse <test@pialasse.com> 1.3.0-1.sme
51     - update from 1.03-02sn to comply with SME8 and SME7
52     - moved archives to /var/lib/durep
53     - moved web files to manager/html
54     - cleaned spec
55    
56     %description
57     DUREP is a Report Generator that creates graphical Output for the "du" command
58    
59     %prep
60     %setup
61 jpp 1.4 %patch0 -p1
62 stephdl 1.1
63     %install
64     /bin/rm -rf $RPM_BUILD_ROOT
65     (cd root; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT)
66     /bin/rm -f %{name}-%{version}-filelist
67     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist
68    
69    
70     %clean
71     /bin/rm -rf $RPM_BUILD_ROOT
72    
73     %files -f %{name}-%{version}-filelist
74     %defattr(-,root,root)
75    
76     #%attr(0644 root root) "/etc/e-smith/templates/etc/crontab/durep"
77     #%attr(4750 root admin) "/etc/e-smith/web/functions/durep"
78     #%attr(0777 root root) "/etc/e-smith/web/panels/manager/cgi-bin/durep"
79     #%attr(0644 root root) "/usr/local/bin/durep"
80     #%dir %attr(0755 root root) "/usr/local/man"
81     #%dir %attr(0755 root root) "/usr/local/man/man1"
82     #%attr(0644 root root) "/usr/local/man/man1/durep.1"
83     #%dir %attr(0755 root root) "/usr/sbin"
84     #%attr(0644 root root) "/usr/sbin/durep.daily"
85     #%dir %attr(0755 root root) "/var/lib/durep"
86     #%dir %attr(0755 root root) "/etc/e-smith/web/panels/manager/html/durep"
87     #%attr(0644 root root) "/etc/e-smith/web/panels/manager/html/durep/bar.png"
88     #%attr(0644 root root) "/etc/e-smith/web/panels/manager/html/durep/durep.cgi"
89     #%attr(0644 root root) "/etc/e-smith/web/panels/manager/html/durep/style.css"
90    
91     %pre -p /bin/sh
92    
93     %post -p /bin/sh
94     chmod 755 /usr/local/bin/durep
95     chmod 755 /usr/sbin/durep.daily
96     /sbin/e-smith/expand-template /etc/crontab
97     echo "Initial run of durep ... please wait."
98     /usr/sbin/durep.daily >/dev/null
99     /etc/e-smith/events/actions/navigation-conf >/dev/null 2>&1
100    
101     %preun -p /bin/sh
102    
103     %postun -p /bin/sh
104     if [ "$1" = 0 ]; then
105     /sbin/e-smith/expand-template /etc/crontab
106     /etc/e-smith/events/actions/navigation-conf 2>/dev/null
107     fi
108    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed