1 |
brianr |
1.2 |
# $Id: smeserver-email-management.spec,v 1.1 2020/06/10 08:56:03 brianr Exp $ |
2 |
brianr |
1.1 |
# Authority: dungog |
3 |
|
|
# Name: Stephen Noble |
4 |
|
|
|
5 |
|
|
Summary: modify and monitor maildelivery for all users |
6 |
|
|
%define name smeserver-email-management |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 1.3 |
9 |
brianr |
1.2 |
%define release 4 |
10 |
brianr |
1.1 |
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GPL |
13 |
|
|
URL: http://www.dungog.net/sme |
14 |
|
|
Group: SMEserver/addon |
15 |
|
|
Source: %{name}-%{version}.tgz |
16 |
|
|
Patch0: smeserver-email-management-1.3.bz9737.handleAdmin.patch |
17 |
|
|
Patch1: smeserver-email-management-1.3.bz10731.user-log-display.patch |
18 |
|
|
BuildArchitectures: noarch |
19 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
20 |
|
|
Provides: dungog-email = %{version}-%{release} |
21 |
|
|
Requires: e-smith-release >= 9.0, |
22 |
|
|
Requires: smeserver-vacation |
23 |
|
|
Requires: smeserver-mailsorting |
24 |
|
|
#Requires: smeserver-userpanel, userpanel causes endless problems |
25 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
26 |
|
|
AutoReqProv: no |
27 |
|
|
|
28 |
|
|
%description |
29 |
|
|
SME Server panel to allow admin to enable and configure procmail, |
30 |
|
|
maildrop, vacation or forwarding for users, |
31 |
|
|
see all users mail delivery methods in a table. |
32 |
|
|
Admin can add global rules and apply them to all users, |
33 |
|
|
set advanced mail properties. |
34 |
|
|
Original work of Stephen Noble dungog.net. |
35 |
|
|
|
36 |
|
|
%prep |
37 |
|
|
%setup |
38 |
|
|
%patch0 -p1 |
39 |
|
|
%patch1 -p1 |
40 |
|
|
|
41 |
|
|
%build |
42 |
|
|
perl createlinks |
43 |
|
|
|
44 |
|
|
#LEXICONS=$(find root/etc/e-smith/{locale/,web/functions/} -type f ) |
45 |
|
|
#for lexicon in $LEXICONS |
46 |
|
|
#do |
47 |
|
|
# /sbin/e-smith/validate-lexicon $lexicon |
48 |
|
|
#done |
49 |
|
|
|
50 |
|
|
%install |
51 |
|
|
rm -rf $RPM_BUILD_ROOT |
52 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
53 |
|
|
rm -f %{name}-%{version}-filelist |
54 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
55 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
56 |
|
|
|
57 |
|
|
%clean |
58 |
|
|
%pre |
59 |
|
|
%preun |
60 |
|
|
%post |
61 |
|
|
%postun |
62 |
|
|
|
63 |
|
|
%files -f %{name}-%{version}-filelist |
64 |
|
|
%defattr(-,root,root) |
65 |
|
|
|
66 |
|
|
%changelog |
67 |
brianr |
1.2 |
* Fri Oct 23 2020 Brian Read <brianr@bjsystems.co.uk> 1.3-4.sme |
68 |
|
|
- Initial import to SME10 tree [SME: 10951] |
69 |
|
|
|
70 |
brianr |
1.1 |
* Sat Feb 02 2019 Jean-Philipe Pialasse <tests@pialasse.com> 1.3-3.sme |
71 |
|
|
- fix not able to display log and config files for users [SME: 10731] |
72 |
|
|
|
73 |
|
|
* Mon May 29 2017 Jean-Philipe Pialasse <tests@pialasse.com> 1.3-2.sme |
74 |
|
|
- add support for admin account [SME: 9737] |
75 |
|
|
|
76 |
|
|
* Mon Aug 08 2016 Jean-Philipe Pialasse <tests@pialasse.com> 1.3-1.sme |
77 |
|
|
- initial import to SME 9 |
78 |
|
|
|
79 |
|
|
* Wed Jul 21 2010 Stephen Noble <support@dungog.net> 1.2-12 |
80 |
|
|
- fix remember destination when modifying |
81 |
|
|
|
82 |
|
|
* Tue Jun 09 2009 Stephen Noble <support@dungog.net> 1.2-11 |
83 |
|
|
- fix path for ssl template expansion |
84 |
|
|
|
85 |
|
|
* Sat Mar 07 2009 Stephen Noble <support@dungog.net> 1.2-10 |
86 |
|
|
- Configure user settings for zarafa |
87 |
|
|
|
88 |
|
|
* Tue Oct 31 2006 Stephen Noble <support@dungog.net> 1.2-9 |
89 |
|
|
- MaxScannerSize added |
90 |
|
|
|
91 |
|
|
* Tue Oct 31 2006 Stephen Noble <support@dungog.net> 1.2-8 |
92 |
|
|
- qmail settings added |
93 |
|
|
|
94 |
|
|
* Mon Oct 30 2006 Stephen Noble <support@dungog.net> |
95 |
|
|
- qpsmtpd settings available in globals page |
96 |
|
|
- [1.2-7] |
97 |
|
|
|
98 |
|
|
* Sat Oct 28 2006 Stephen Noble <support@dungog.net> |
99 |
|
|
- review domain mailserver delegation |
100 |
|
|
- review group Visible property |
101 |
|
|
- set qpsmtpd Bcc setting for mail archiving |
102 |
|
|
- [1.2-6] |
103 |
|
|
|
104 |
|
|
* Wed Aug 23 2006 Stephen Noble <support@dungog.net> |
105 |
|
|
- remove strict check on mailrule criterion |
106 |
|
|
- [1.2-5] |
107 |
|
|
|
108 |
|
|
* Thu May 04 2006 Stephen Noble <support@dungog.net> |
109 |
|
|
- TMDA support added |
110 |
|
|
- [1.2-4] |
111 |
|
|
|
112 |
|
|
* Wed Apr 05 2006 Stephen Noble <support@dungog.net> |
113 |
|
|
- cosmetic, comment fixed |
114 |
|
|
- [1.2-3] |
115 |
|
|
|
116 |
|
|
* Fri Mar 24 2006 Stephen Noble <support@dungog.net> |
117 |
|
|
- maildrop forwarding note added |
118 |
|
|
- vacation system call changed to actions/qmail-update-user |
119 |
|
|
- spamboss note added |
120 |
|
|
- [1.2-2] |
121 |
|
|
|
122 |
|
|
* Thu Sep 22 2005 Stephen Noble <support@dungog.net> |
123 |
|
|
- simplified and updated for sme7 |
124 |
|
|
- [1.2-1] |
125 |
|
|
|
126 |
|
|
* Fri Jul 01 2005 Stephen Noble <support@dungog.net> |
127 |
|
|
- removed requirement for perl-Unicode-IMAPUtf7 |
128 |
|
|
- [1.0-6] |
129 |
|
|
|
130 |
|
|
* Tue Apr 26 2005 Stephen Noble <support@dungog.net> |
131 |
|
|
- removed junkfilter option for simplification |
132 |
|
|
- corrected messages due to changes in other rpms |
133 |
|
|
- mailblocking and pattern matching msg removed |
134 |
|
|
- [1.0-5] |
135 |
|
|
|
136 |
|
|
* Sat Jan 29 2005 Stephen Noble <support@dungog.net> |
137 |
|
|
- supports spamassassin ver.3 / sme-spamfilter |
138 |
|
|
- fixed global systemdefault spam sorting |
139 |
|
|
- modify user TMDA usage |
140 |
|
|
- [1.0-4] |
141 |
|
|
|
142 |
|
|
* Tue Dec 07 2004 Stephen Noble <support@dungog.net> |
143 |
|
|
- shows TMDA usage |
144 |
|
|
- [1.0-3] |
145 |
|
|
|
146 |
|
|
* Mon Oct 18 2004 Stephen Noble <support@dungog.net> |
147 |
|
|
- cosmetic changes, refreshes correctly, log filter rblsd changed to rbls |
148 |
|
|
- [1.0-2] |
149 |
|
|
|
150 |
|
|
* Thu Aug 12 2004 Stephen Noble <support@dungog.net> |
151 |
|
|
- rpm renamed dungog-email |
152 |
|
|
- function processmail renamed dungog-email, will affect any userpanel delegations |
153 |
|
|
- display users MailDomains & MailLocal settings from dungog-mailblocking |
154 |
|
|
- display each users pseudonyms, option to hide . and _ versions |
155 |
|
|
- display 'virtual domain' pseudonyms and domain delegations from dungog-vdomain |
156 |
|
|
- display admin in user table |
157 |
|
|
- antivirus and filtering status consolidated into one sub panel |
158 |
|
|
- make admin aware of the pattern matching rpms |
159 |
|
|
- junkfilter userpanel removed |
160 |
|
|
- [1.0-1] |
161 |
|
|
|
162 |
|
|
* Wed Jul 28 2004 Stephen Noble <support@dungog.net> |
163 |
|
|
- removed tmda |
164 |
|
|
- you now modify junkfilter rules from the command line |
165 |
|
|
- [0.2-11] |
166 |
|
|
|
167 |
|
|
* Wed Jul 28 2004 Stephen Noble <support@dungog.net> |
168 |
|
|
- cosmetic, altered comment about spamassassin |
169 |
|
|
- [0.2-10] |
170 |
|
|
|
171 |
|
|
* Wed Apr 07 2004 Stephen Noble <support@dungog.net> |
172 |
|
|
- smtp/rbls settings saved correctly |
173 |
|
|
- individual email forwarding address shown on summary page |
174 |
|
|
- [0.2-9] |
175 |
|
|
|
176 |
|
|
* Sun Mar 28 2004 Stephen Noble <support@dungog.net> |
177 |
|
|
- requires sme 6.0 |
178 |
|
|
- smtp settings added |
179 |
|
|
rbls, max message size |
180 |
|
|
- updates userpanel panel links on install and uninstall |
181 |
|
|
- [0.2-8] |
182 |
|
|
|
183 |
|
|
* Fri Mar 05 2004 Stephen Noble <support@dungog.net> |
184 |
|
|
- procmail forward to user fixed |
185 |
|
|
- procmail says folder not in correct format fixed |
186 |
|
|
- userpanel-procmail-pro moved to GPL userpanel |
187 |
|
|
- [0.2-7] |
188 |
|
|
|
189 |
|
|
* Thu Dec 04 2003 Stephen Noble <support@dungog.net> |
190 |
|
|
- individual setting = systemdefault unless set otherwise |
191 |
|
|
- dovecoat imap folders fixed in procmail dropdown lists |
192 |
|
|
- rbls only works on 5.6, custom fragments added |
193 |
|
|
requires e-smith-mailfront-1.0.0-02rbl.noarch.rpm |
194 |
|
|
- spamassasin sme5/sme6 differences added |
195 |
|
|
|
196 |
|
|
- [0.2-7] |
197 |
|
|
|
198 |
|
|
* Thu Dec 04 2003 Stephen Noble <support@dungog.net> |
199 |
|
|
- individual setting = systemdefault unless set otherwise |
200 |
|
|
- dovecoat imap folders fixed in procmail dropdown lists |
201 |
|
|
- rbls only works on 5.6, custom fragments added |
202 |
|
|
requires e-smith-mailfront-1.0.0-02rbl.noarch.rpm |
203 |
|
|
- spamassasin sme5/sme6 differences added |
204 |
|
|
- [0.2-6] |
205 |
|
|
|
206 |
|
|
* Mon Sep 08 2003 Stephen Noble <support@dungog.net> |
207 |
|
|
- larger text field for rbls entry |
208 |
|
|
- logic improved deciding between individual and global delivery |
209 |
|
|
will use individual setting until individual setting is systemdefault |
210 |
|
|
- logic improved in creating .procmailrc |
211 |
|
|
if you have both junkfilter and spamassassin installed |
212 |
|
|
- [0.2-5] |
213 |
|
|
|
214 |
|
|
* Thu Aug 21 2003 Stephen Noble <support@dungog.net> |
215 |
|
|
- SME 6.0 support, servermanager navigation & shows tables correctly |
216 |
|
|
- minor bug fixes |
217 |
|
|
- [0.2-4] |
218 |
|
|
|
219 |
|
|
* Sun Aug 03 2003 Stephen Noble <support@dungog.net> |
220 |
|
|
- mail sent with offline dialup server with rbls installed but off is not delayed |
221 |
|
|
- new delivery action option, tag spam but leave for mail client to sort |
222 |
|
|
- [0.2-3] |
223 |
|
|
|
224 |
|
|
* Mon Jun 02 2003 Stephen Noble <support@dungog.net> |
225 |
|
|
- added notes, where to get spamassassin, contibs.org |
226 |
|
|
- a filtering spamboss needs this procmail rule 'custom headers' "spamboss@" > 'spamfolder' |
227 |
|
|
- [0.2-2] |
228 |
|
|
|
229 |
|
|
* Thu May 29 2003 Stephen Noble <support@dungog.net> |
230 |
|
|
- lots of changes, test before using on production machine |
231 |
|
|
- improved display on dungog > emailfiltering panel |
232 |
|
|
shows individual override on spamfilter |
233 |
|
|
shows which global spamfilter and the sort/delete/fwd action |
234 |
|
|
- uses tmda-0.78, |
235 |
|
|
and tmda-cgi-0.9 for user interface, NB tmda-cgi-0.9 is later than 0.71 |
236 |
|
|
www.servername/tmda, authenticates against users system password |
237 |
|
|
admin or user still has to enable tmda with panels |
238 |
|
|
- adds userpanel-procmail-pro, |
239 |
|
|
adds second test for procmail, if x & if y then... |
240 |
|
|
restricts characters in criterion to avoid broken rules, it may be too strict |
241 |
|
|
email characters you want added to the allowed list |
242 |
|
|
- incorporates better notification and seperate control of spamassassin |
243 |
|
|
deliver tagged spamassassin spam to folder/spammboss/delete it |
244 |
|
|
junkfilter spam folder changed to junkmail to be consistant with spamassassin |
245 |
|
|
- server-manager > emailfiltering > global > filters |
246 |
|
|
choose between junkfilter or spammassassin or use both |
247 |
|
|
tmda runs before/without procmail and stops 99.9%% |
248 |
|
|
function added to reset individual overrides to null |
249 |
|
|
the default in now 'null' but was 'disabled' |
250 |
|
|
this was a bug as the individual setting overrides the global setting |
251 |
|
|
userpanel-procmail-pro is fixed, userpanel-procmail will be in userpanel.v12 |
252 |
|
|
- [0.2-1] |
253 |
|
|
|
254 |
|
|
* Tue Jul 23 2002 Stephen Noble <support@dungog.net> |
255 |
|
|
- initial release |
256 |
|
|
- [0.1-1] |
257 |
|
|
|