1 |
unnilennium |
1.1 |
# $Id: smeserver-email-management.spec,v 1.2 2016/03/09 08:52:32 unnilennium Exp $ |
2 |
|
|
# Authority: dungog |
3 |
|
|
# Name: Stephen Noble |
4 |
|
|
|
5 |
|
|
Summary: modify and monitor maildelivery for all users |
6 |
|
|
%define name smeserver-email-management |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 1.3 |
9 |
|
|
%define release 1 |
10 |
|
|
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GPL |
13 |
|
|
URL: http://www.dungog.net/sme |
14 |
|
|
Group: SMEserver/addon |
15 |
|
|
Source: %{name}-%{version}.tgz |
16 |
|
|
#Patch0: |
17 |
|
|
BuildArchitectures: noarch |
18 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
19 |
|
|
Provides: dungog-email = %{version}-%{release} |
20 |
|
|
Requires: e-smith-release >= 9.0, |
21 |
|
|
Requires: smeserver-vacation |
22 |
|
|
Requires: smeserver-mailsorting |
23 |
|
|
#Requires: smeserver-userpanel, userpanel causes endless problems |
24 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
25 |
|
|
AutoReqProv: no |
26 |
|
|
|
27 |
|
|
%description |
28 |
|
|
SME Server panel to allow admin to enable and configure procmail, |
29 |
|
|
maildrop, vacation or forwarding for users, |
30 |
|
|
see all users mail delivery methods in a table. |
31 |
|
|
Admin can add global rules and apply them to all users, |
32 |
|
|
set advanced mail properties. |
33 |
|
|
Original work of Stephen Noble dungog.net. |
34 |
|
|
|
35 |
|
|
%prep |
36 |
|
|
%setup |
37 |
|
|
#%patch0 -p1 |
38 |
|
|
|
39 |
|
|
%build |
40 |
|
|
perl createlinks |
41 |
|
|
|
42 |
|
|
#LEXICONS=$(find root/etc/e-smith/{locale/,web/functions/} -type f ) |
43 |
|
|
#for lexicon in $LEXICONS |
44 |
|
|
#do |
45 |
|
|
# /sbin/e-smith/validate-lexicon $lexicon |
46 |
|
|
#done |
47 |
|
|
|
48 |
|
|
%install |
49 |
|
|
rm -rf $RPM_BUILD_ROOT |
50 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
51 |
|
|
rm -f %{name}-%{version}-filelist |
52 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
53 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
54 |
|
|
|
55 |
|
|
%clean |
56 |
|
|
%pre |
57 |
|
|
%preun |
58 |
|
|
%post |
59 |
|
|
%postun |
60 |
|
|
|
61 |
|
|
%files -f %{name}-%{version}-filelist |
62 |
|
|
%defattr(-,root,root) |
63 |
|
|
|
64 |
|
|
%changelog |
65 |
|
|
* Mon Aug 08 2016 Jean-Philipe Pialasse <tests@pialasse.com> 1.3-1.sme |
66 |
|
|
- initial import to SME 9 |
67 |
|
|
|
68 |
|
|
* Wed Jul 21 2010 Stephen Noble <support@dungog.net> 1.2-12 |
69 |
|
|
- fix remember destination when modifying |
70 |
|
|
|
71 |
|
|
* Tue Jun 09 2009 Stephen Noble <support@dungog.net> 1.2-11 |
72 |
|
|
- fix path for ssl template expansion |
73 |
|
|
|
74 |
|
|
* Sat Mar 07 2009 Stephen Noble <support@dungog.net> 1.2-10 |
75 |
|
|
- Configure user settings for zarafa |
76 |
|
|
|
77 |
|
|
* Tue Oct 31 2006 Stephen Noble <support@dungog.net> 1.2-9 |
78 |
|
|
- MaxScannerSize added |
79 |
|
|
|
80 |
|
|
* Tue Oct 31 2006 Stephen Noble <support@dungog.net> 1.2-8 |
81 |
|
|
- qmail settings added |
82 |
|
|
|
83 |
|
|
* Mon Oct 30 2006 Stephen Noble <support@dungog.net> |
84 |
|
|
- qpsmtpd settings available in globals page |
85 |
|
|
- [1.2-7] |
86 |
|
|
|
87 |
|
|
* Sat Oct 28 2006 Stephen Noble <support@dungog.net> |
88 |
|
|
- review domain mailserver delegation |
89 |
|
|
- review group Visible property |
90 |
|
|
- set qpsmtpd Bcc setting for mail archiving |
91 |
|
|
- [1.2-6] |
92 |
|
|
|
93 |
|
|
* Wed Aug 23 2006 Stephen Noble <support@dungog.net> |
94 |
|
|
- remove strict check on mailrule criterion |
95 |
|
|
- [1.2-5] |
96 |
|
|
|
97 |
|
|
* Thu May 04 2006 Stephen Noble <support@dungog.net> |
98 |
|
|
- TMDA support added |
99 |
|
|
- [1.2-4] |
100 |
|
|
|
101 |
|
|
* Wed Apr 05 2006 Stephen Noble <support@dungog.net> |
102 |
|
|
- cosmetic, comment fixed |
103 |
|
|
- [1.2-3] |
104 |
|
|
|
105 |
|
|
* Fri Mar 24 2006 Stephen Noble <support@dungog.net> |
106 |
|
|
- maildrop forwarding note added |
107 |
|
|
- vacation system call changed to actions/qmail-update-user |
108 |
|
|
- spamboss note added |
109 |
|
|
- [1.2-2] |
110 |
|
|
|
111 |
|
|
* Thu Sep 22 2005 Stephen Noble <support@dungog.net> |
112 |
|
|
- simplified and updated for sme7 |
113 |
|
|
- [1.2-1] |
114 |
|
|
|
115 |
|
|
* Fri Jul 01 2005 Stephen Noble <support@dungog.net> |
116 |
|
|
- removed requirement for perl-Unicode-IMAPUtf7 |
117 |
|
|
- [1.0-6] |
118 |
|
|
|
119 |
|
|
* Tue Apr 26 2005 Stephen Noble <support@dungog.net> |
120 |
|
|
- removed junkfilter option for simplification |
121 |
|
|
- corrected messages due to changes in other rpms |
122 |
|
|
- mailblocking and pattern matching msg removed |
123 |
|
|
- [1.0-5] |
124 |
|
|
|
125 |
|
|
* Sat Jan 29 2005 Stephen Noble <support@dungog.net> |
126 |
|
|
- supports spamassassin ver.3 / sme-spamfilter |
127 |
|
|
- fixed global systemdefault spam sorting |
128 |
|
|
- modify user TMDA usage |
129 |
|
|
- [1.0-4] |
130 |
|
|
|
131 |
|
|
* Tue Dec 07 2004 Stephen Noble <support@dungog.net> |
132 |
|
|
- shows TMDA usage |
133 |
|
|
- [1.0-3] |
134 |
|
|
|
135 |
|
|
* Mon Oct 18 2004 Stephen Noble <support@dungog.net> |
136 |
|
|
- cosmetic changes, refreshes correctly, log filter rblsd changed to rbls |
137 |
|
|
- [1.0-2] |
138 |
|
|
|
139 |
|
|
* Thu Aug 12 2004 Stephen Noble <support@dungog.net> |
140 |
|
|
- rpm renamed dungog-email |
141 |
|
|
- function processmail renamed dungog-email, will affect any userpanel delegations |
142 |
|
|
- display users MailDomains & MailLocal settings from dungog-mailblocking |
143 |
|
|
- display each users pseudonyms, option to hide . and _ versions |
144 |
|
|
- display 'virtual domain' pseudonyms and domain delegations from dungog-vdomain |
145 |
|
|
- display admin in user table |
146 |
|
|
- antivirus and filtering status consolidated into one sub panel |
147 |
|
|
- make admin aware of the pattern matching rpms |
148 |
|
|
- junkfilter userpanel removed |
149 |
|
|
- [1.0-1] |
150 |
|
|
|
151 |
|
|
* Wed Jul 28 2004 Stephen Noble <support@dungog.net> |
152 |
|
|
- removed tmda |
153 |
|
|
- you now modify junkfilter rules from the command line |
154 |
|
|
- [0.2-11] |
155 |
|
|
|
156 |
|
|
* Wed Jul 28 2004 Stephen Noble <support@dungog.net> |
157 |
|
|
- cosmetic, altered comment about spamassassin |
158 |
|
|
- [0.2-10] |
159 |
|
|
|
160 |
|
|
* Wed Apr 07 2004 Stephen Noble <support@dungog.net> |
161 |
|
|
- smtp/rbls settings saved correctly |
162 |
|
|
- individual email forwarding address shown on summary page |
163 |
|
|
- [0.2-9] |
164 |
|
|
|
165 |
|
|
* Sun Mar 28 2004 Stephen Noble <support@dungog.net> |
166 |
|
|
- requires sme 6.0 |
167 |
|
|
- smtp settings added |
168 |
|
|
rbls, max message size |
169 |
|
|
- updates userpanel panel links on install and uninstall |
170 |
|
|
- [0.2-8] |
171 |
|
|
|
172 |
|
|
* Fri Mar 05 2004 Stephen Noble <support@dungog.net> |
173 |
|
|
- procmail forward to user fixed |
174 |
|
|
- procmail says folder not in correct format fixed |
175 |
|
|
- userpanel-procmail-pro moved to GPL userpanel |
176 |
|
|
- [0.2-7] |
177 |
|
|
|
178 |
|
|
* Thu Dec 04 2003 Stephen Noble <support@dungog.net> |
179 |
|
|
- individual setting = systemdefault unless set otherwise |
180 |
|
|
- dovecoat imap folders fixed in procmail dropdown lists |
181 |
|
|
- rbls only works on 5.6, custom fragments added |
182 |
|
|
requires e-smith-mailfront-1.0.0-02rbl.noarch.rpm |
183 |
|
|
- spamassasin sme5/sme6 differences added |
184 |
|
|
|
185 |
|
|
- [0.2-7] |
186 |
|
|
|
187 |
|
|
* Thu Dec 04 2003 Stephen Noble <support@dungog.net> |
188 |
|
|
- individual setting = systemdefault unless set otherwise |
189 |
|
|
- dovecoat imap folders fixed in procmail dropdown lists |
190 |
|
|
- rbls only works on 5.6, custom fragments added |
191 |
|
|
requires e-smith-mailfront-1.0.0-02rbl.noarch.rpm |
192 |
|
|
- spamassasin sme5/sme6 differences added |
193 |
|
|
- [0.2-6] |
194 |
|
|
|
195 |
|
|
* Mon Sep 08 2003 Stephen Noble <support@dungog.net> |
196 |
|
|
- larger text field for rbls entry |
197 |
|
|
- logic improved deciding between individual and global delivery |
198 |
|
|
will use individual setting until individual setting is systemdefault |
199 |
|
|
- logic improved in creating .procmailrc |
200 |
|
|
if you have both junkfilter and spamassassin installed |
201 |
|
|
- [0.2-5] |
202 |
|
|
|
203 |
|
|
* Thu Aug 21 2003 Stephen Noble <support@dungog.net> |
204 |
|
|
- SME 6.0 support, servermanager navigation & shows tables correctly |
205 |
|
|
- minor bug fixes |
206 |
|
|
- [0.2-4] |
207 |
|
|
|
208 |
|
|
* Sun Aug 03 2003 Stephen Noble <support@dungog.net> |
209 |
|
|
- mail sent with offline dialup server with rbls installed but off is not delayed |
210 |
|
|
- new delivery action option, tag spam but leave for mail client to sort |
211 |
|
|
- [0.2-3] |
212 |
|
|
|
213 |
|
|
* Mon Jun 02 2003 Stephen Noble <support@dungog.net> |
214 |
|
|
- added notes, where to get spamassassin, contibs.org |
215 |
|
|
- a filtering spamboss needs this procmail rule 'custom headers' "spamboss@" > 'spamfolder' |
216 |
|
|
- [0.2-2] |
217 |
|
|
|
218 |
|
|
* Thu May 29 2003 Stephen Noble <support@dungog.net> |
219 |
|
|
- lots of changes, test before using on production machine |
220 |
|
|
- improved display on dungog > emailfiltering panel |
221 |
|
|
shows individual override on spamfilter |
222 |
|
|
shows which global spamfilter and the sort/delete/fwd action |
223 |
|
|
- uses tmda-0.78, |
224 |
|
|
and tmda-cgi-0.9 for user interface, NB tmda-cgi-0.9 is later than 0.71 |
225 |
|
|
www.servername/tmda, authenticates against users system password |
226 |
|
|
admin or user still has to enable tmda with panels |
227 |
|
|
- adds userpanel-procmail-pro, |
228 |
|
|
adds second test for procmail, if x & if y then... |
229 |
|
|
restricts characters in criterion to avoid broken rules, it may be too strict |
230 |
|
|
email characters you want added to the allowed list |
231 |
|
|
- incorporates better notification and seperate control of spamassassin |
232 |
|
|
deliver tagged spamassassin spam to folder/spammboss/delete it |
233 |
|
|
junkfilter spam folder changed to junkmail to be consistant with spamassassin |
234 |
|
|
- server-manager > emailfiltering > global > filters |
235 |
|
|
choose between junkfilter or spammassassin or use both |
236 |
|
|
tmda runs before/without procmail and stops 99.9%% |
237 |
|
|
function added to reset individual overrides to null |
238 |
|
|
the default in now 'null' but was 'disabled' |
239 |
|
|
this was a bug as the individual setting overrides the global setting |
240 |
|
|
userpanel-procmail-pro is fixed, userpanel-procmail will be in userpanel.v12 |
241 |
|
|
- [0.2-1] |
242 |
|
|
|
243 |
|
|
* Tue Jul 23 2002 Stephen Noble <support@dungog.net> |
244 |
|
|
- initial release |
245 |
|
|
- [0.1-1] |
246 |
|
|
|