1 |
jpp |
1.1 |
%define name smeserver-extrarepositories |
2 |
|
|
%define version 0.1 |
3 |
|
|
%define release 1 |
4 |
|
|
Summary: easy configuration of extra yum repo |
5 |
|
|
Name: %{name} |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release} |
8 |
|
|
License: GNU GPL version 2 |
9 |
|
|
URL: https://wiki.koozali.org |
10 |
|
|
Group: SMEserver/addon |
11 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
12 |
|
|
BuildArchitectures: noarch |
13 |
|
|
BuildRequires: e-smith-devtools |
14 |
|
|
Requires: e-smith-release >= 9.0 |
15 |
|
|
AutoReqProv: no |
16 |
|
|
|
17 |
|
|
%description |
18 |
|
|
Provides configuration for external yum repository comaptible with Koozali SME Server. |
19 |
|
|
|
20 |
|
|
%changelog |
21 |
|
|
* Mon May 01 2017 Jean-Philipe Pialasse <tests@pialasse.com> 0.1-1.sme |
22 |
|
|
- initial release |
23 |
|
|
|
24 |
|
|
%prep |
25 |
|
|
|
26 |
|
|
%build |
27 |
|
|
|
28 |
|
|
%install |
29 |
|
|
rm -rf $RPM_BUILD_ROOT |
30 |
|
|
# if needing to add a gpg key |
31 |
|
|
mkdir -p $RPM_BUILD_ROOT/usr/share/rpm-gpg-keys/ |
32 |
|
|
|
33 |
|
|
# if needing to add a gpg key |
34 |
|
|
#cp %source0 $RPM_BUILD_ROOT/usr/share/rpm-gpg-keys/ |
35 |
|
|
#/usr/share/rpm-gpg-keys/RPM-GPG-KEY-${REPO['reponame']} |
36 |
|
|
|
37 |
|
|
# if needing to migrate something : |
38 |
|
|
#mkdir -p $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/migrate |
39 |
|
|
#echo "" >$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/migrate/00REPONAMEmigrate |
40 |
|
|
|
41 |
|
|
# if needed to force something |
42 |
|
|
#mkdir -p $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/force/${REPO['reponame']} |
43 |
|
|
#echo "${REPO['Exclude']}" >\ |
44 |
|
|
# $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/force/${REPO['reponame']}/Exclude |
45 |
|
|
|
46 |
|
|
|
47 |
|
|
|
48 |
|
|
declare -A REPO |
49 |
|
|
#remi-safe |
50 |
|
|
REPO['reponame']='remi-safe' |
51 |
|
|
REPO['fullreponame']='Remi - safe' |
52 |
|
|
REPO['EnableGroups']='no' |
53 |
|
|
REPO['GPGCheck']='yes' |
54 |
|
|
REPO['Visible']='yes' |
55 |
|
|
REPO['status']='enabled' |
56 |
|
|
REPO['BaseURL']='http://rpms.famillecollet.com/enterprise/\\\$releasever/safe/\\\$basearch/' |
57 |
|
|
REPO['MirrorList']='' |
58 |
|
|
REPO['GPGKey']='http://rpms.famillecollet.com/RPM-GPG-KEY-remi' |
59 |
|
|
REPO['Exclude']='' |
60 |
|
|
REPO['Include']='' |
61 |
|
|
|
62 |
|
|
mkdir -p $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']} |
63 |
|
|
echo "${REPO['EnableGroups']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/EnableGroups |
64 |
|
|
echo "${REPO['GPGCheck']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/GPGCheck |
65 |
|
|
echo "${REPO['fullreponame']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Name |
66 |
|
|
echo "${REPO['Visible']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Visible |
67 |
|
|
echo "${REPO['status']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/status |
68 |
|
|
echo "repository" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/type |
69 |
|
|
[[ "${REPO['BaseURL']}" != '' ]] && echo "${REPO['BaseURL']}" >\ |
70 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/BaseURL |
71 |
|
|
[[ "${REPO['GPGKey']}" != '' ]] && echo "${REPO['GPGKey']}" >\ |
72 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/GPGKey |
73 |
|
|
[[ "${REPO['MirrorList']}" != '' ]] && echo "${REPO['MirrorList']}" >\ |
74 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/MirrorList |
75 |
|
|
[[ "${REPO['Exclude']}" != '' ]] && echo "${REPO['Exclude']}" >\ |
76 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Exclude |
77 |
|
|
[[ "${REPO['Include']}" != '' ]] && echo "${REPO['Include']}" >\ |
78 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Include |
79 |
|
|
|
80 |
|
|
###################### |
81 |
|
|
##################### |
82 |
|
|
# asterisk 13 LTS |
83 |
|
|
##################### |
84 |
|
|
##################### |
85 |
|
|
REPO['reponame']='asterisk-13' |
86 |
|
|
REPO['fullreponame']='Asterisk-13 - EL' |
87 |
|
|
REPO['EnableGroups']='yes' |
88 |
|
|
REPO['GPGCheck']='no' |
89 |
|
|
REPO['Visible']='no' |
90 |
|
|
REPO['status']='disabled' |
91 |
|
|
REPO['BaseURL']='http://packages.asterisk.org/centos/$releasever/asterisk-13/\\\$basearch/' |
92 |
|
|
REPO['MirrorList']='' |
93 |
|
|
REPO['GPGKey']='' |
94 |
|
|
REPO['Exclude']='' |
95 |
|
|
REPO['Include']='' |
96 |
|
|
|
97 |
|
|
mkdir -p $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']} |
98 |
|
|
echo "${REPO['EnableGroups']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/EnableGroups |
99 |
|
|
echo "${REPO['GPGCheck']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/GPGCheck |
100 |
|
|
echo "${REPO['fullreponame']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Name |
101 |
|
|
echo "${REPO['Visible']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Visible |
102 |
|
|
echo "${REPO['status']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/status |
103 |
|
|
echo "repository" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/type |
104 |
|
|
[[ "${REPO['BaseURL']}" != '' ]] && echo "${REPO['BaseURL']}" >\ |
105 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/BaseURL |
106 |
|
|
[[ "${REPO['GPGKey']}" != '' ]] && echo "${REPO['GPGKey']}" >\ |
107 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/GPGKey |
108 |
|
|
[[ "${REPO['MirrorList']}" != '' ]] && echo "${REPO['MirrorList']}" >\ |
109 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/MirrorList |
110 |
|
|
[[ "${REPO['Exclude']}" != '' ]] && echo "${REPO['Exclude']}" >\ |
111 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Exclude |
112 |
|
|
[[ "${REPO['Include']}" != '' ]] && echo "${REPO['Include']}" >\ |
113 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Include |
114 |
|
|
|
115 |
|
|
###################### |
116 |
|
|
##################### |
117 |
|
|
# asterisk current |
118 |
|
|
##################### |
119 |
|
|
##################### |
120 |
|
|
REPO['reponame']='asterisk-current' |
121 |
|
|
REPO['fullreponame']='Asterisk-current - EL' |
122 |
|
|
REPO['EnableGroups']='yes' |
123 |
|
|
REPO['GPGCheck']='no' |
124 |
|
|
REPO['Visible']='no' |
125 |
|
|
REPO['status']='disabled' |
126 |
|
|
REPO['BaseURL']='http://packages.asterisk.org/centos/$releasever/current/\\\$basearch/' |
127 |
|
|
REPO['MirrorList']='' |
128 |
|
|
REPO['GPGKey']='' |
129 |
|
|
REPO['Exclude']='' |
130 |
|
|
REPO['Include']='' |
131 |
|
|
|
132 |
|
|
mkdir -p $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']} |
133 |
|
|
echo "${REPO['EnableGroups']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/EnableGroups |
134 |
|
|
echo "${REPO['GPGCheck']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/GPGCheck |
135 |
|
|
echo "${REPO['fullreponame']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Name |
136 |
|
|
echo "${REPO['Visible']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Visible |
137 |
|
|
echo "${REPO['status']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/status |
138 |
|
|
echo "repository" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/type |
139 |
|
|
[[ "${REPO['BaseURL']}" != '' ]] && echo "${REPO['BaseURL']}" >\ |
140 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/BaseURL |
141 |
|
|
[[ "${REPO['GPGKey']}" != '' ]] && echo "${REPO['GPGKey']}" >\ |
142 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/GPGKey |
143 |
|
|
[[ "${REPO['MirrorList']}" != '' ]] && echo "${REPO['MirrorList']}" >\ |
144 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/MirrorList |
145 |
|
|
[[ "${REPO['Exclude']}" != '' ]] && echo "${REPO['Exclude']}" >\ |
146 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Exclude |
147 |
|
|
[[ "${REPO['Include']}" != '' ]] && echo "${REPO['Include']}" >\ |
148 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Include |
149 |
|
|
|
150 |
|
|
##################### |
151 |
|
|
##################### |
152 |
|
|
# Digium Repo |
153 |
|
|
##################### |
154 |
|
|
##################### |
155 |
|
|
REPO['reponame']='digium' |
156 |
|
|
REPO['fullreponame']='Digium packages - EL' |
157 |
|
|
REPO['EnableGroups']='no' |
158 |
|
|
REPO['Visible']='no' |
159 |
|
|
REPO['status']='disabled' |
160 |
|
|
REPO['BaseURL']='http://packages.digium.com/centos/\\\$releasever/current/\\\$basearch/' |
161 |
|
|
REPO['MirrorList']='' |
162 |
|
|
REPO['GPGCheck']='no' |
163 |
|
|
REPO['GPGKey']='' |
164 |
|
|
REPO['Exclude']='' |
165 |
|
|
REPO['Include']='' |
166 |
|
|
|
167 |
|
|
mkdir -p $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']} |
168 |
|
|
echo "${REPO['EnableGroups']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/EnableGroups |
169 |
|
|
echo "${REPO['GPGCheck']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/GPGCheck |
170 |
|
|
echo "${REPO['fullreponame']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Name |
171 |
|
|
echo "${REPO['Visible']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Visible |
172 |
|
|
echo "${REPO['status']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/status |
173 |
|
|
echo "repository" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/type |
174 |
|
|
[[ "${REPO['BaseURL']}" != '' ]] && echo "${REPO['BaseURL']}" >\ |
175 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/BaseURL |
176 |
|
|
[[ "${REPO['GPGKey']}" != '' ]] && echo "${REPO['GPGKey']}" >\ |
177 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/GPGKey |
178 |
|
|
[[ "${REPO['MirrorList']}" != '' ]] && echo "${REPO['MirrorList']}" >\ |
179 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/MirrorList |
180 |
|
|
[[ "${REPO['Exclude']}" != '' ]] && echo "${REPO['Exclude']}" >\ |
181 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Exclude |
182 |
|
|
[[ "${REPO['Include']}" != '' ]] && echo "${REPO['Include']}" >\ |
183 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Include |
184 |
|
|
|
185 |
|
|
##################### |
186 |
|
|
##################### |
187 |
|
|
# Digium 13 |
188 |
|
|
##################### |
189 |
|
|
##################### |
190 |
|
|
REPO['reponame']='digium-13' |
191 |
|
|
REPO['fullreponame']='Digium-13 packages - EL' |
192 |
|
|
REPO['EnableGroups']='no' |
193 |
|
|
REPO['Visible']='no' |
194 |
|
|
REPO['status']='disabled' |
195 |
|
|
REPO['BaseURL']='http://packages.digium.com/centos/\\\$releasever/digium-13/\\\$basearch/' |
196 |
|
|
REPO['MirrorList']='' |
197 |
|
|
REPO['GPGCheck']='no' |
198 |
|
|
REPO['GPGKey']='' |
199 |
|
|
REPO['Exclude']='' |
200 |
|
|
REPO['Include']='' |
201 |
|
|
|
202 |
|
|
mkdir -p $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']} |
203 |
|
|
echo "${REPO['EnableGroups']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/EnableGroups |
204 |
|
|
echo "${REPO['GPGCheck']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/GPGCheck |
205 |
|
|
echo "${REPO['fullreponame']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Name |
206 |
|
|
echo "${REPO['Visible']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Visible |
207 |
|
|
echo "${REPO['status']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/status |
208 |
|
|
echo "repository" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/type |
209 |
|
|
[[ "${REPO['BaseURL']}" != '' ]] && echo "${REPO['BaseURL']}" >\ |
210 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/BaseURL |
211 |
|
|
[[ "${REPO['GPGKey']}" != '' ]] && echo "${REPO['GPGKey']}" >\ |
212 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/GPGKey |
213 |
|
|
[[ "${REPO['MirrorList']}" != '' ]] && echo "${REPO['MirrorList']}" >\ |
214 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/MirrorList |
215 |
|
|
[[ "${REPO['Exclude']}" != '' ]] && echo "${REPO['Exclude']}" >\ |
216 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Exclude |
217 |
|
|
[[ "${REPO['Include']}" != '' ]] && echo "${REPO['Include']}" >\ |
218 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Include |
219 |
|
|
|
220 |
|
|
##################### |
221 |
|
|
##################### |
222 |
|
|
#atomic |
223 |
|
|
##################### |
224 |
|
|
##################### |
225 |
|
|
REPO['reponame']='atomic' |
226 |
|
|
REPO['fullreponame']='Atomic' |
227 |
|
|
REPO['EnableGroups']='no' |
228 |
|
|
REPO['Visible']='no' |
229 |
|
|
REPO['status']='disabled' |
230 |
|
|
REPO['BaseURL']='' |
231 |
|
|
REPO['MirrorList']='http://www.atomicorp.com/mirrorlist/atomic/centos-\\\$releasever-\\\$basearch' |
232 |
|
|
REPO['GPGCheck']='yes' |
233 |
|
|
REPO['GPGKey']='https://www.atomicorp.com/RPM-GPG-KEY.art.txt' |
234 |
|
|
REPO['Exclude']='' |
235 |
|
|
REPO['Include']='' |
236 |
|
|
|
237 |
|
|
mkdir -p $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']} |
238 |
|
|
echo "${REPO['EnableGroups']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/EnableGroups |
239 |
|
|
echo "${REPO['GPGCheck']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/GPGCheck |
240 |
|
|
echo "${REPO['fullreponame']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Name |
241 |
|
|
echo "${REPO['Visible']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Visible |
242 |
|
|
echo "${REPO['status']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/status |
243 |
|
|
echo "repository" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/type |
244 |
|
|
[[ "${REPO['BaseURL']}" != '' ]] && echo "${REPO['BaseURL']}" >\ |
245 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/BaseURL |
246 |
|
|
[[ "${REPO['GPGKey']}" != '' ]] && echo "${REPO['GPGKey']}" >\ |
247 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/GPGKey |
248 |
|
|
[[ "${REPO['MirrorList']}" != '' ]] && echo "${REPO['MirrorList']}" >\ |
249 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/MirrorList |
250 |
|
|
[[ "${REPO['Exclude']}" != '' ]] && echo "${REPO['Exclude']}" >\ |
251 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Exclude |
252 |
|
|
[[ "${REPO['Include']}" != '' ]] && echo "${REPO['Include']}" >\ |
253 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Include |
254 |
|
|
|
255 |
|
|
##################### |
256 |
|
|
##################### |
257 |
|
|
#centos-sclo-rh |
258 |
|
|
##################### |
259 |
|
|
##################### |
260 |
|
|
REPO['reponame']='centos-sclo-rh' |
261 |
|
|
REPO['fullreponame']='Centos-RH Software collections' |
262 |
|
|
REPO['EnableGroups']='no' |
263 |
|
|
REPO['Visible']='yes' |
264 |
|
|
REPO['status']='disabled' |
265 |
|
|
REPO['BaseURL']='http://mirror.centos.org/centos/\\\$releasever/sclo/\\\$basearch/rh' |
266 |
|
|
REPO['MirrorList']='' |
267 |
|
|
REPO['GPGCheck']='yes' |
268 |
|
|
REPO['GPGKey']='https://www.centos.org/keys/RPM-GPG-KEY-CentOS-SIG-SCLo' |
269 |
|
|
REPO['Exclude']='' |
270 |
|
|
REPO['Include']='' |
271 |
|
|
|
272 |
|
|
mkdir -p $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']} |
273 |
|
|
echo "${REPO['EnableGroups']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/EnableGroups |
274 |
|
|
echo "${REPO['GPGCheck']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/GPGCheck |
275 |
|
|
echo "${REPO['fullreponame']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Name |
276 |
|
|
echo "${REPO['Visible']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Visible |
277 |
|
|
echo "${REPO['status']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/status |
278 |
|
|
echo "repository" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/type |
279 |
|
|
[[ "${REPO['BaseURL']}" != '' ]] && echo "${REPO['BaseURL']}" >\ |
280 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/BaseURL |
281 |
|
|
[[ "${REPO['GPGKey']}" != '' ]] && echo "${REPO['GPGKey']}" >\ |
282 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/GPGKey |
283 |
|
|
[[ "${REPO['MirrorList']}" != '' ]] && echo "${REPO['MirrorList']}" >\ |
284 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/MirrorList |
285 |
|
|
[[ "${REPO['Exclude']}" != '' ]] && echo "${REPO['Exclude']}" >\ |
286 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Exclude |
287 |
|
|
[[ "${REPO['Include']}" != '' ]] && echo "${REPO['Include']}" >\ |
288 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Include |
289 |
|
|
|
290 |
|
|
##################### |
291 |
|
|
##################### |
292 |
|
|
#egroupware |
293 |
|
|
##################### |
294 |
|
|
##################### |
295 |
|
|
REPO['reponame']='egroupware' |
296 |
|
|
REPO['fullreponame']='server_eGroupWare' |
297 |
|
|
REPO['EnableGroups']='no' |
298 |
|
|
REPO['Visible']='yes' |
299 |
|
|
REPO['status']='disabled' |
300 |
|
|
REPO['BaseURL']='http://download.opensuse.org/repositories/server:/eGroupWare/CentOS_\\\$releasever/' |
301 |
|
|
REPO['MirrorList']='' |
302 |
|
|
REPO['GPGCheck']='yes' |
303 |
|
|
REPO['GPGKey']='http://download.opensuse.org/repositories/server:/eGroupWare/CentOS_\\\$releasever/repodata/repomd.xml.key' |
304 |
|
|
REPO['Exclude']='' |
305 |
|
|
REPO['Include']='' |
306 |
|
|
|
307 |
|
|
mkdir -p $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']} |
308 |
|
|
echo "${REPO['EnableGroups']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/EnableGroups |
309 |
|
|
echo "${REPO['GPGCheck']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/GPGCheck |
310 |
|
|
echo "${REPO['fullreponame']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Name |
311 |
|
|
echo "${REPO['Visible']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Visible |
312 |
|
|
echo "${REPO['status']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/status |
313 |
|
|
echo "repository" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/type |
314 |
|
|
[[ "${REPO['BaseURL']}" != '' ]] && echo "${REPO['BaseURL']}" >\ |
315 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/BaseURL |
316 |
|
|
[[ "${REPO['GPGKey']}" != '' ]] && echo "${REPO['GPGKey']}" >\ |
317 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/GPGKey |
318 |
|
|
[[ "${REPO['MirrorList']}" != '' ]] && echo "${REPO['MirrorList']}" >\ |
319 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/MirrorList |
320 |
|
|
[[ "${REPO['Exclude']}" != '' ]] && echo "${REPO['Exclude']}" >\ |
321 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Exclude |
322 |
|
|
[[ "${REPO['Include']}" != '' ]] && echo "${REPO['Include']}" >\ |
323 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Include |
324 |
|
|
|
325 |
|
|
|
326 |
jpp |
1.2 |
##################### |
327 |
|
|
##################### |
328 |
|
|
#elastic |
329 |
|
|
##################### |
330 |
|
|
##################### |
331 |
|
|
declare -A elashort=( ['6.x']='6.x' ['5.x']='5.x' ['1.6']='1' ) |
332 |
|
|
for elasver in "6.x" "5.x" "1.6"; do |
333 |
|
|
REPO['reponame']="elastic${elashort[$elasver]}" |
334 |
|
|
REPO['fullreponame']="Elasticsearch repository for $elasver packages" |
335 |
|
|
REPO['EnableGroups']='yes' |
336 |
|
|
REPO['Visible']='yes' |
337 |
|
|
REPO['status']='disabled' |
338 |
|
|
REPO['BaseURL']="https://artifacts.elastic.co/packages/$elasver/yum" |
339 |
|
|
REPO['MirrorList']='' |
340 |
|
|
REPO['GPGCheck']='yes' |
341 |
|
|
REPO['GPGKey']='https://artifacts.elastic.co/GPG-KEY-elasticsearch' |
342 |
|
|
REPO['Exclude']='' |
343 |
|
|
REPO['Include']='' |
344 |
|
|
|
345 |
|
|
mkdir -p $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']} |
346 |
|
|
echo "${REPO['EnableGroups']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/EnableGroups |
347 |
|
|
echo "${REPO['GPGCheck']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/GPGCheck |
348 |
|
|
echo "${REPO['fullreponame']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Name |
349 |
|
|
echo "${REPO['Visible']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Visible |
350 |
|
|
echo "${REPO['status']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/status |
351 |
|
|
echo "repository" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/type |
352 |
|
|
[[ "${REPO['BaseURL']}" != '' ]] && echo "${REPO['BaseURL']}" >\ |
353 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/BaseURL |
354 |
|
|
[[ "${REPO['GPGKey']}" != '' ]] && echo "${REPO['GPGKey']}" >\ |
355 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/GPGKey |
356 |
|
|
[[ "${REPO['MirrorList']}" != '' ]] && echo "${REPO['MirrorList']}" >\ |
357 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/MirrorList |
358 |
|
|
[[ "${REPO['Exclude']}" != '' ]] && echo "${REPO['Exclude']}" >\ |
359 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Exclude |
360 |
|
|
[[ "${REPO['Include']}" != '' ]] && echo "${REPO['Include']}" >\ |
361 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Include |
362 |
|
|
done |
363 |
|
|
|
364 |
|
|
##################### |
365 |
|
|
##################### |
366 |
|
|
#ELRepo |
367 |
|
|
##################### |
368 |
|
|
##################### |
369 |
|
|
REPO['reponame']='elrepo' |
370 |
|
|
REPO['fullreponame']='ELRepo.org Community Enterprise Linux Repository' |
371 |
|
|
REPO['EnableGroups']='no' |
372 |
|
|
REPO['Visible']='no' |
373 |
|
|
REPO['status']='disabled' |
374 |
|
|
REPO['BaseURL']='http://elrepo.org/linux/elrepo/el\\\$releasever/\\\$basearch' |
375 |
|
|
REPO['MirrorList']='http://elrepo.org/mirrors-elrepo.\\\$releasever' |
376 |
|
|
REPO['GPGCheck']='yes' |
377 |
|
|
REPO['GPGKey']='http://elrepo.org/RPM-GPG-KEY-elrepo.org' |
378 |
|
|
REPO['Exclude']='clamav,spamassassin,libselinux,perl-HTML-Parser,lm_sensors,perl-IO-stringy,perl-XML-Parser,razor-agents,libgcrypt,rpm-python,libxml2,zlib,gnupg,libxml2-python,yum,module-init-tools,rpm,gettext,librpm4,glib2,perl-libwww-perl,perl-Convert-ASN1,beecrypt,fetchmail,libacl,libtool-ltdl,popt,libgpg-error,freetype,perl-MIME-tools,mutt,gd,perl-TimeDate,librpm4.4' |
379 |
|
|
REPO['Include']='' |
380 |
|
|
|
381 |
|
|
mkdir -p $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']} |
382 |
|
|
echo "${REPO['EnableGroups']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/EnableGroups |
383 |
|
|
echo "${REPO['GPGCheck']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/GPGCheck |
384 |
|
|
echo "${REPO['fullreponame']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Name |
385 |
|
|
echo "${REPO['Visible']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Visible |
386 |
|
|
echo "${REPO['status']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/status |
387 |
|
|
echo "repository" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/type |
388 |
|
|
[[ "${REPO['BaseURL']}" != '' ]] && echo "${REPO['BaseURL']}" >\ |
389 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/BaseURL |
390 |
|
|
[[ "${REPO['GPGKey']}" != '' ]] && echo "${REPO['GPGKey']}" >\ |
391 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/GPGKey |
392 |
|
|
[[ "${REPO['MirrorList']}" != '' ]] && echo "${REPO['MirrorList']}" >\ |
393 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/MirrorList |
394 |
|
|
[[ "${REPO['Exclude']}" != '' ]] && echo "${REPO['Exclude']}" >\ |
395 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Exclude |
396 |
|
|
[[ "${REPO['Include']}" != '' ]] && echo "${REPO['Include']}" >\ |
397 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Include |
398 |
|
|
|
399 |
|
|
##################### |
400 |
|
|
##################### |
401 |
|
|
#EPEL |
402 |
|
|
##################### |
403 |
|
|
##################### |
404 |
|
|
REPO['reponame']='epel' |
405 |
|
|
REPO['fullreponame']='EPEL' |
406 |
|
|
REPO['EnableGroups']='no' |
407 |
|
|
REPO['Visible']='no' |
408 |
|
|
REPO['status']='disabled' |
409 |
|
|
REPO['BaseURL']='http://download.fedoraproject.org/pub/epel/\\\$releasever/\\\$basearch' |
410 |
|
|
REPO['MirrorList']='http://mirrors.fedoraproject.org/mirrorlist?repo=epel-\\\$releasever&arch=\\\$basearch' |
411 |
|
|
REPO['GPGCheck']='yes' |
412 |
|
|
REPO['GPGKey']='http://dl.fedoraproject.org/pub/epel/RPM-GPG-KEY-EPEL' |
413 |
|
|
REPO['Exclude']='perl-Razor-Agent' |
414 |
|
|
REPO['Include']='' |
415 |
|
|
|
416 |
|
|
mkdir -p $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']} |
417 |
|
|
echo "${REPO['EnableGroups']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/EnableGroups |
418 |
|
|
echo "${REPO['GPGCheck']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/GPGCheck |
419 |
|
|
echo "${REPO['fullreponame']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Name |
420 |
|
|
echo "${REPO['Visible']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Visible |
421 |
|
|
echo "${REPO['status']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/status |
422 |
|
|
echo "repository" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/type |
423 |
|
|
[[ "${REPO['BaseURL']}" != '' ]] && echo "${REPO['BaseURL']}" >\ |
424 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/BaseURL |
425 |
|
|
[[ "${REPO['GPGKey']}" != '' ]] && echo "${REPO['GPGKey']}" >\ |
426 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/GPGKey |
427 |
|
|
[[ "${REPO['MirrorList']}" != '' ]] && echo "${REPO['MirrorList']}" >\ |
428 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/MirrorList |
429 |
|
|
[[ "${REPO['Exclude']}" != '' ]] && echo "${REPO['Exclude']}" >\ |
430 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Exclude |
431 |
|
|
[[ "${REPO['Include']}" != '' ]] && echo "${REPO['Include']}" >\ |
432 |
|
|
$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Include |
433 |
|
|
|
434 |
|
|
|
435 |
|
|
|
436 |
|
|
## define filelists |
437 |
|
|
rm -f %{name}-%{version}-filelist* |
438 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
439 |
|
|
cat %{name}-%{version}-filelist|grep remi-safe > %{name}-%{version}-filelist-remi-safe |
440 |
|
|
cat %{name}-%{version}-filelist| egrep 'digium|asterisk' > %{name}-%{version}-filelist-asterisk |
441 |
|
|
cat %{name}-%{version}-filelist| grep egroupware > %{name}-%{version}-filelist-egroupware |
442 |
|
|
cat %{name}-%{version}-filelist| grep elastic > %{name}-%{version}-filelist-elastic |
443 |
|
|
cat %{name}-%{version}-filelist| grep elrepo > %{name}-%{version}-filelist-elrepo |
444 |
|
|
cat %{name}-%{version}-filelist| grep epel > %{name}-%{version}-filelist-epel |
445 |
jpp |
1.1 |
|
446 |
|
|
%clean |
447 |
|
|
cd .. |
448 |
|
|
rm -rf %{name}-%{version} |
449 |
|
|
|
450 |
|
|
%files -f %{name}-%{version}-filelist |
451 |
|
|
%defattr(-,root,root) |
452 |
|
|
|
453 |
|
|
%pre |
454 |
|
|
|
455 |
|
|
%preun |
456 |
|
|
|
457 |
|
|
%post |
458 |
|
|
|
459 |
|
|
%postun |
460 |
|
|
case "$1" in |
461 |
|
|
|
462 |
|
|
0) |
463 |
|
|
# this is an uninstallation |
464 |
|
|
;; |
465 |
|
|
|
466 |
|
|
1) |
467 |
|
|
# this is an upgrade |
468 |
|
|
;; |
469 |
|
|
esac |
470 |
jpp |
1.2 |
|
471 |
|
|
%package remi-safe |
472 |
|
|
Summary: Remi safe repository |
473 |
|
|
%description remi-safe |
474 |
|
|
Remi safe repository |
475 |
|
|
%files remi-safe -f %{name}-%{version}-filelist-remi-safe |
476 |
|
|
%defattr(-,root,root) |
477 |
|
|
|
478 |
|
|
%package asterisk |
479 |
|
|
Summary: All repositories you need for Asterisk and FreePBX |
480 |
|
|
%description asterisk |
481 |
|
|
All repositories you need for Asterisk and FreePBX |
482 |
|
|
%files asterisk -f %{name}-%{version}-filelist-asterisk |
483 |
|
|
%defattr(-,root,root) |
484 |
|
|
|
485 |
|
|
%package egroupware |
486 |
|
|
Summary: Repository for eGroupWare |
487 |
|
|
%description egroupware |
488 |
|
|
Repository for eGroupWare |
489 |
|
|
%files egroupware -f %{name}-%{version}-filelist-egroupware |
490 |
|
|
%defattr(-,root,root) |
491 |
|
|
|
492 |
|
|
%package elastic |
493 |
|
|
Summary: Repositories for elastic search |
494 |
|
|
%description elastic |
495 |
|
|
Repositories for elastic search |
496 |
|
|
%files elastic -f %{name}-%{version}-filelist-elastic |
497 |
|
|
%defattr(-,root,root) |
498 |
|
|
|
499 |
|
|
%package elrepo |
500 |
|
|
Summary: ElRepo.org Community Enterprise Linux Repository |
501 |
|
|
%description elrepo |
502 |
|
|
ElRepo.org Community Enterprise Linux Repository |
503 |
|
|
%files elrepo -f %{name}-%{version}-filelist-elrepo |
504 |
|
|
%defattr(-,root,root) |
505 |
|
|
|
506 |
|
|
%package epel |
507 |
|
|
Summary: Fedora EPEL Repository |
508 |
|
|
%description epel |
509 |
|
|
Fedora EPEL Repository |
510 |
|
|
%files epel -f %{name}-%{version}-filelist-epel |
511 |
|
|
%defattr(-,root,root) |
512 |
|
|
|
513 |
|
|
|