/[smecontribs]/rpms/smeserver-extrarepositories/contribs9/smeserver-extrarepositories.spec
ViewVC logotype

Annotation of /rpms/smeserver-extrarepositories/contribs9/smeserver-extrarepositories.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.4 - (hide annotations) (download)
Thu Feb 15 20:18:44 2018 UTC (6 years, 7 months ago) by jpp
Branch: MAIN
Changes since 1.3: +398 -256 lines
* Mon May 01 2017 Jean-Philipe Pialasse <tests@pialasse.com> 0.1-1.sme
- initial release

1 jpp 1.1 %define name smeserver-extrarepositories
2     %define version 0.1
3     %define release 1
4     Summary: easy configuration of extra yum repo
5     Name: %{name}
6     Version: %{version}
7     Release: %{release}
8     License: GNU GPL version 2
9     URL: https://wiki.koozali.org
10     Group: SMEserver/addon
11     BuildRoot: /var/tmp/%{name}-%{version}
12     BuildArchitectures: noarch
13     BuildRequires: e-smith-devtools
14     Requires: e-smith-release >= 9.0
15     AutoReqProv: no
16    
17     %description
18     Provides configuration for external yum repository comaptible with Koozali SME Server.
19    
20     %changelog
21     * Mon May 01 2017 Jean-Philipe Pialasse <tests@pialasse.com> 0.1-1.sme
22     - initial release
23    
24     %prep
25    
26     %build
27    
28     %install
29     rm -rf $RPM_BUILD_ROOT
30     # if needing to add a gpg key
31     mkdir -p $RPM_BUILD_ROOT/usr/share/rpm-gpg-keys/
32    
33     # if needing to add a gpg key
34     #cp %source0 $RPM_BUILD_ROOT/usr/share/rpm-gpg-keys/
35     #/usr/share/rpm-gpg-keys/RPM-GPG-KEY-${REPO['reponame']}
36    
37     # if needing to migrate something :
38     #mkdir -p $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/migrate
39     #echo "" >$RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/migrate/00REPONAMEmigrate
40    
41     # if needed to force something
42     #mkdir -p $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/force/${REPO['reponame']}
43     #echo "${REPO['Exclude']}" >\
44     # $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/force/${REPO['reponame']}/Exclude
45    
46    
47    
48     declare -A REPO
49    
50 jpp 1.4 function createrepo {
51 jpp 1.1 mkdir -p $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}
52     echo "${REPO['EnableGroups']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/EnableGroups
53     echo "${REPO['GPGCheck']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/GPGCheck
54     echo "${REPO['fullreponame']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Name
55     echo "${REPO['Visible']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Visible
56     echo "${REPO['status']}" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/status
57     echo "repository" > $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/type
58     [[ "${REPO['BaseURL']}" != '' ]] && echo "${REPO['BaseURL']}" >\
59     $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/BaseURL
60     [[ "${REPO['GPGKey']}" != '' ]] && echo "${REPO['GPGKey']}" >\
61 jpp 1.4 $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/GPGKey
62     [[ "${REPO['MirrorList']}" != '' ]] && echo "${REPO['MirrorList']}" >\
63     $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/MirrorList
64 jpp 1.1 [[ "${REPO['Exclude']}" != '' ]] && echo "${REPO['Exclude']}" >\
65 jpp 1.4 $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/Exclude
66     [[ "${REPO['IncludePkgs']}" != '' ]] && echo "${REPO['IncludePkgs']}" >\
67     $RPM_BUILD_ROOT/etc/e-smith/db/yum_repositories/defaults/${REPO['reponame']}/IncludePkgs
68     return 0
69     }
70    
71    
72    
73     #remi-safe
74     REPO['reponame']='remi-safe'
75     REPO['fullreponame']='Remi - safe'
76     REPO['EnableGroups']='no'
77     REPO['GPGCheck']='yes'
78     REPO['Visible']='yes'
79     REPO['status']='enabled'
80     REPO['BaseURL']='http://rpms.famillecollet.com/enterprise/\\\$releasever/safe/\\\$basearch/'
81     REPO['MirrorList']=''
82     REPO['GPGKey']='http://rpms.famillecollet.com/RPM-GPG-KEY-remi'
83     REPO['Exclude']=''
84     REPO['IncludePkgs']=''
85     createrepo
86 jpp 1.1
87     ######################
88     #####################
89     # asterisk 13 LTS
90     #####################
91     #####################
92     REPO['reponame']='asterisk-13'
93     REPO['fullreponame']='Asterisk-13 - EL'
94     REPO['EnableGroups']='yes'
95     REPO['GPGCheck']='no'
96     REPO['Visible']='no'
97     REPO['status']='disabled'
98     REPO['BaseURL']='http://packages.asterisk.org/centos/$releasever/asterisk-13/\\\$basearch/'
99     REPO['MirrorList']=''
100     REPO['GPGKey']=''
101     REPO['Exclude']=''
102 jpp 1.4 REPO['IncludePkgs']=''
103     createrepo
104 jpp 1.1
105     ######################
106     #####################
107     # asterisk current
108     #####################
109     #####################
110     REPO['reponame']='asterisk-current'
111     REPO['fullreponame']='Asterisk-current - EL'
112     REPO['EnableGroups']='yes'
113     REPO['GPGCheck']='no'
114     REPO['Visible']='no'
115     REPO['status']='disabled'
116     REPO['BaseURL']='http://packages.asterisk.org/centos/$releasever/current/\\\$basearch/'
117     REPO['MirrorList']=''
118     REPO['GPGKey']=''
119     REPO['Exclude']=''
120 jpp 1.4 REPO['IncludePkgs']=''
121     createrepo
122 jpp 1.1
123     #####################
124     #####################
125     # Digium Repo
126     #####################
127     #####################
128     REPO['reponame']='digium'
129     REPO['fullreponame']='Digium packages - EL'
130     REPO['EnableGroups']='no'
131     REPO['Visible']='no'
132     REPO['status']='disabled'
133     REPO['BaseURL']='http://packages.digium.com/centos/\\\$releasever/current/\\\$basearch/'
134     REPO['MirrorList']=''
135     REPO['GPGCheck']='no'
136     REPO['GPGKey']=''
137     REPO['Exclude']=''
138 jpp 1.4 REPO['IncludePkgs']=''
139     createrepo
140 jpp 1.1
141     #####################
142     #####################
143     # Digium 13
144     #####################
145     #####################
146     REPO['reponame']='digium-13'
147     REPO['fullreponame']='Digium-13 packages - EL'
148     REPO['EnableGroups']='no'
149     REPO['Visible']='no'
150     REPO['status']='disabled'
151     REPO['BaseURL']='http://packages.digium.com/centos/\\\$releasever/digium-13/\\\$basearch/'
152     REPO['MirrorList']=''
153     REPO['GPGCheck']='no'
154     REPO['GPGKey']=''
155     REPO['Exclude']=''
156 jpp 1.4 REPO['IncludePkgs']=''
157     createrepo
158 jpp 1.1
159     #####################
160     #####################
161     #atomic
162     #####################
163     #####################
164     REPO['reponame']='atomic'
165     REPO['fullreponame']='Atomic'
166     REPO['EnableGroups']='no'
167     REPO['Visible']='no'
168     REPO['status']='disabled'
169     REPO['BaseURL']=''
170     REPO['MirrorList']='http://www.atomicorp.com/mirrorlist/atomic/centos-\\\$releasever-\\\$basearch'
171     REPO['GPGCheck']='yes'
172     REPO['GPGKey']='https://www.atomicorp.com/RPM-GPG-KEY.art.txt'
173     REPO['Exclude']=''
174 jpp 1.4 REPO['IncludePkgs']=''
175     createrepo
176 jpp 1.1
177     #####################
178     #####################
179     #centos-sclo-rh
180     #####################
181     #####################
182     REPO['reponame']='centos-sclo-rh'
183     REPO['fullreponame']='Centos-RH Software collections'
184     REPO['EnableGroups']='no'
185     REPO['Visible']='yes'
186     REPO['status']='disabled'
187     REPO['BaseURL']='http://mirror.centos.org/centos/\\\$releasever/sclo/\\\$basearch/rh'
188     REPO['MirrorList']=''
189     REPO['GPGCheck']='yes'
190     REPO['GPGKey']='https://www.centos.org/keys/RPM-GPG-KEY-CentOS-SIG-SCLo'
191     REPO['Exclude']=''
192 jpp 1.4 REPO['IncludePkgs']=''
193     createrepo
194 jpp 1.1
195     #####################
196     #####################
197     #egroupware
198     #####################
199     #####################
200     REPO['reponame']='egroupware'
201     REPO['fullreponame']='server_eGroupWare'
202     REPO['EnableGroups']='no'
203     REPO['Visible']='yes'
204     REPO['status']='disabled'
205     REPO['BaseURL']='http://download.opensuse.org/repositories/server:/eGroupWare/CentOS_\\\$releasever/'
206     REPO['MirrorList']=''
207     REPO['GPGCheck']='yes'
208     REPO['GPGKey']='http://download.opensuse.org/repositories/server:/eGroupWare/CentOS_\\\$releasever/repodata/repomd.xml.key'
209     REPO['Exclude']=''
210 jpp 1.4 REPO['IncludePkgs']=''
211     createrepo
212 jpp 1.1
213 jpp 1.2 #####################
214     #####################
215     #elastic
216     #####################
217     #####################
218     declare -A elashort=( ['6.x']='6.x' ['5.x']='5.x' ['1.6']='1' )
219     for elasver in "6.x" "5.x" "1.6"; do
220     REPO['reponame']="elastic${elashort[$elasver]}"
221     REPO['fullreponame']="Elasticsearch repository for $elasver packages"
222     REPO['EnableGroups']='yes'
223     REPO['Visible']='yes'
224     REPO['status']='disabled'
225     REPO['BaseURL']="https://artifacts.elastic.co/packages/$elasver/yum"
226     REPO['MirrorList']=''
227     REPO['GPGCheck']='yes'
228     REPO['GPGKey']='https://artifacts.elastic.co/GPG-KEY-elasticsearch'
229     REPO['Exclude']=''
230 jpp 1.4 REPO['IncludePkgs']=''
231     createrepo
232 jpp 1.2 done
233    
234     #####################
235     #####################
236     #ELRepo
237     #####################
238     #####################
239     REPO['reponame']='elrepo'
240     REPO['fullreponame']='ELRepo.org Community Enterprise Linux Repository'
241     REPO['EnableGroups']='no'
242     REPO['Visible']='no'
243     REPO['status']='disabled'
244     REPO['BaseURL']='http://elrepo.org/linux/elrepo/el\\\$releasever/\\\$basearch'
245     REPO['MirrorList']='http://elrepo.org/mirrors-elrepo.\\\$releasever'
246     REPO['GPGCheck']='yes'
247     REPO['GPGKey']='http://elrepo.org/RPM-GPG-KEY-elrepo.org'
248     REPO['Exclude']='clamav,spamassassin,libselinux,perl-HTML-Parser,lm_sensors,perl-IO-stringy,perl-XML-Parser,razor-agents,libgcrypt,rpm-python,libxml2,zlib,gnupg,libxml2-python,yum,module-init-tools,rpm,gettext,librpm4,glib2,perl-libwww-perl,perl-Convert-ASN1,beecrypt,fetchmail,libacl,libtool-ltdl,popt,libgpg-error,freetype,perl-MIME-tools,mutt,gd,perl-TimeDate,librpm4.4'
249 jpp 1.4 REPO['IncludePkgs']=''
250     createrepo
251 jpp 1.2
252     #####################
253     #####################
254     #EPEL
255     #####################
256     #####################
257     REPO['reponame']='epel'
258     REPO['fullreponame']='EPEL'
259     REPO['EnableGroups']='no'
260     REPO['Visible']='no'
261     REPO['status']='disabled'
262     REPO['BaseURL']='http://download.fedoraproject.org/pub/epel/\\\$releasever/\\\$basearch'
263     REPO['MirrorList']='http://mirrors.fedoraproject.org/mirrorlist?repo=epel-\\\$releasever&arch=\\\$basearch'
264     REPO['GPGCheck']='yes'
265     REPO['GPGKey']='http://dl.fedoraproject.org/pub/epel/RPM-GPG-KEY-EPEL'
266     REPO['Exclude']='perl-Razor-Agent'
267 jpp 1.4 REPO['IncludePkgs']=''
268     createrepo
269 jpp 1.2
270 jpp 1.3 #####################
271     #####################
272     #erlang
273     #####################
274     #####################
275     REPO['reponame']='erlang'
276     REPO['fullreponame']='erlang programming language'
277     REPO['EnableGroups']='no'
278     REPO['Visible']='yes'
279     REPO['status']='disabled'
280     REPO['BaseURL']='http://packages.erlang-solutions.com/rpm/centos/\\\$releasever/\\\$basearch'
281     REPO['MirrorList']=''
282     REPO['GPGCheck']='yes'
283     REPO['GPGKey']='http://packages.erlang-solutions.com/rpm/erlang_solutions.asc'
284     REPO['Exclude']=''
285 jpp 1.4 REPO['IncludePkgs']=''
286     createrepo
287 jpp 1.3
288     #####################
289     #####################
290     #freeswitch
291     #####################
292     #####################
293     REPO['reponame']='freeswitch'
294     REPO['fullreponame']='Freeswitch'
295     REPO['EnableGroups']='no'
296     REPO['Visible']='yes'
297     REPO['status']='disabled'
298     REPO['BaseURL']='http://files.freeswitch.org/yum/\\\$releasever/\\\$basearch'
299     REPO['MirrorList']=''
300     REPO['GPGCheck']='yes'
301     REPO['GPGKey']='file:///etc/pki/rpm-gpg/RPM-GPG-KEY-FREESWITCH'
302     REPO['Exclude']=''
303 jpp 1.4 REPO['IncludePkgs']=''
304     createrepo
305    
306     #####################
307     #####################
308     #firewall Service
309     #####################
310     #####################
311     REPO['reponame']='fws'
312     REPO['fullreponame']='Firewall Services'
313     REPO['EnableGroups']='no'
314     REPO['Visible']='no'
315     REPO['status']='disabled'
316     REPO['BaseURL']='http://repo.firewall-services.com/centos/\\\$releasever'
317     REPO['MirrorList']=''
318     REPO['GPGCheck']='yes'
319     REPO['GPGKey']='http://repo.firewall-services.com/RPM-GPG-KEY'
320     REPO['Exclude']=''
321     REPO['IncludePkgs']=''
322     createrepo
323    
324     #####################
325     #####################
326     #firewall Service testing
327     #####################
328     #####################
329     REPO['reponame']='fws-testing'
330     REPO['fullreponame']='Firewall Services testing'
331     REPO['EnableGroups']='no'
332     REPO['Visible']='no'
333     REPO['status']='disabled'
334     REPO['BaseURL']='http://repo.firewall-services.com/centos-testing/\\\$releasever'
335     REPO['MirrorList']=''
336     REPO['GPGCheck']='yes'
337     REPO['GPGKey']='http://repo.firewall-services.com/RPM-GPG-KEY'
338     REPO['Exclude']=''
339     REPO['IncludePkgs']=''
340     createrepo
341    
342     #####################
343     #####################
344     # Geekery (last update 2016-09-25)
345     #####################
346     #####################
347     REPO['reponame']='geekery'
348     REPO['fullreponame']='geekery repository'
349     REPO['EnableGroups']='no'
350     REPO['Visible']='no'
351     REPO['status']='disabled'
352     REPO['BaseURL']=''
353     REPO['MirrorList']='http://geekery.epac.to/geekery/el\\\$releasever-mirrors'
354     REPO['GPGCheck']='yes'
355     REPO['GPGKey']='http://geekery.altervista.org/download.php?filename=GEEKERY-GPG-KEY'
356     REPO['Exclude']=''
357     REPO['IncludePkgs']=''
358     createrepo
359    
360     if ( "%{?dist}" == "el7" ); then
361     #####################
362     #####################
363     # Odoo10-nightly
364     #####################
365     #####################
366     REPO['reponame']='odoo10-nightly'
367     REPO['fullreponame']='Odoo 10 Nightly - EL7'
368     REPO['EnableGroups']='no'
369     REPO['Visible']='no'
370     REPO['status']='disabled'
371     REPO['BaseURL']='http://nightly.odoo.com/10.0/nightly/rpm/'
372     REPO['MirrorList']=''
373     REPO['GPGCheck']='yes'
374     REPO['GPGKey']='https://nightly.odoo.com/odoo.key'
375     REPO['Exclude']=''
376     REPO['IncludePkgs']=''
377     createrepo
378    
379     #####################
380     #####################
381     # Odoo9-nightly
382     #####################
383     #####################
384     REPO['reponame']='odoo9-nightly'
385     REPO['fullreponame']='Odoo 9 Nightly - EL7'
386     REPO['EnableGroups']='no'
387     REPO['Visible']='no'
388     REPO['status']='disabled'
389     REPO['BaseURL']='http://nightly.odoo.com/9.0/nightly/rpm/'
390     REPO['MirrorList']=''
391     REPO['GPGCheck']='yes'
392     REPO['GPGKey']='https://nightly.odoo.com/odoo.key'
393     REPO['Exclude']=''
394     REPO['IncludePkgs']=''
395     createrepo
396     fi
397    
398     #####################
399     #####################
400     # Okay
401     #####################
402     #####################
403     REPO['reponame']='okay'
404     REPO['fullreponame']='Extra OKay Packages for Enterprise Linux - Freeswitch and FusionPBX'
405     REPO['EnableGroups']='no'
406     REPO['Visible']='no'
407     REPO['status']='disabled'
408     REPO['BaseURL']='http://repo.okay.com.mx/centos/\\\$releasever/\\\$basearch/release'
409     REPO['MirrorList']=''
410     REPO['GPGCheck']='no'
411     REPO['GPGKey']=''
412     REPO['Exclude']=''
413     REPO['IncludePkgs']=''
414     createrepo
415    
416     #####################
417     #####################
418     # Openfusion
419     #####################
420     #####################
421     REPO['reponame']='openfusion'
422     REPO['fullreponame']='Openfusion'
423     REPO['EnableGroups']='no'
424     REPO['Visible']='yes'
425     REPO['status']='disabled'
426     REPO['BaseURL']='http://repo.openfusion.net/centos\\\$releasever-\\\$basearch'
427     REPO['MirrorList']=''
428     REPO['GPGCheck']='yes'
429     REPO['GPGKey']='http://repo.openfusion.net/RPM-GPG-KEY-openfusion'
430     REPO['Exclude']=''
431     REPO['IncludePkgs']=''
432     createrepo
433    
434     #####################
435     #####################
436     # Reetspetit
437     #####################
438     #####################
439     REPO['reponame']='reetp'
440     REPO['fullreponame']='Mirror John Crisp reetspetit.com'
441     REPO['EnableGroups']='no'
442     REPO['Visible']='yes'
443     REPO['status']='disabled'
444     REPO['BaseURL']='https://reetspetit.com/smeserver/\\\$releasever'
445     REPO['MirrorList']=''
446     REPO['GPGCheck']='no'
447     REPO['GPGKey']='https://reetspetit.com/RPM-GPG-KEY'
448     REPO['Exclude']=''
449     REPO['IncludePkgs']=''
450     createrepo
451    
452     #remi-safe
453     REPO['reponame']='remi-safe'
454     REPO['fullreponame']='Remi - safe'
455     REPO['EnableGroups']='no'
456     REPO['GPGCheck']='yes'
457     REPO['Visible']='yes'
458     REPO['status']='enabled'
459     REPO['BaseURL']='http://rpms.famillecollet.com/enterprise/\\\$releasever/safe/\\\$basearch/'
460     REPO['MirrorList']=''
461     REPO['GPGKey']='http://rpms.famillecollet.com/RPM-GPG-KEY-remi'
462     REPO['Exclude']=''
463     REPO['IncludePkgs']=''
464     createrepo
465    
466     #####################
467     #####################
468     #remi
469     #####################
470     #####################
471     REPO['reponame']='remi'
472     REPO['fullreponame']='Remi - EL unsafe, will conflict with your base rpms'
473     REPO['EnableGroups']='no'
474     REPO['GPGCheck']='yes'
475     REPO['Visible']='no'
476     REPO['status']='enabled'
477     REPO['BaseURL']='http://rpms.famillecollet.com/enterprise/\\\$releasever/remi/\\\$basearch/'
478     REPO['MirrorList']=''
479     REPO['GPGKey']='http://rpms.famillecollet.com/RPM-GPG-KEY-remi'
480     REPO['Exclude']='mysql*,php-*,phpMyAdmin'
481     REPO['IncludePkgs']=''
482     createrepo
483    
484     #####################
485     #####################
486     #remi-ocsinventory
487     #####################
488     #####################
489     REPO['reponame']='remi-ocsinventory'
490     REPO['fullreponame']='Remi ocsinventory - EL'
491     REPO['EnableGroups']='no'
492     REPO['GPGCheck']='yes'
493     REPO['Visible']='yes'
494     REPO['status']='enabled'
495     REPO['BaseURL']='http://rpms.famillecollet.com/enterprise/\\\$releasever/remi/\\\$basearch/'
496     REPO['MirrorList']=''
497     REPO['GPGKey']='http://rpms.famillecollet.com/RPM-GPG-KEY-remi'
498     REPO['Exclude']=''
499     REPO['IncludePkgs']='ocsinventory* perl-Ocsinventory-Agent'
500     createrepo
501    
502     #####################
503     #####################
504     #remi-ocsinventory
505     #####################
506     #####################
507     REPO['reponame']='remi-roundcube'
508     REPO['fullreponame']='Remi Roundcube - EL'
509     REPO['EnableGroups']='no'
510     REPO['GPGCheck']='yes'
511     REPO['Visible']='yes'
512     REPO['status']='enabled'
513     REPO['BaseURL']='http://rpms.famillecollet.com/enterprise/\\\$releasever/remi/\\\$basearch/'
514     REPO['MirrorList']=''
515     REPO['GPGKey']='http://rpms.famillecollet.com/RPM-GPG-KEY-remi'
516     REPO['Exclude']=''
517     REPO['IncludePkgs']='php-kolab-net-ldap3,php-pear-Mail-mimeDecode,php-pear-Net-IDNA2,php-pear-Net-LDAP2,roundcubemail'
518     createrepo
519    
520    
521     #####################
522     #####################
523     #rpmfusion
524     #####################
525     #####################
526     REPO['reponame']='rpmfusion'
527     REPO['fullreponame']='rpmfusion free EL'
528     REPO['EnableGroups']='no'
529     REPO['Visible']='yes'
530     REPO['status']='disabled'
531     REPO['BaseURL']='http://download1.rpmfusion.org/free/el/updates/\\\$releasever/\\\$basearch/'
532     REPO['MirrorList']='http://mirrors.rpmfusion.org/mirrorlist?repo=free-el-updates-released-\\\$releasever&arch=\\\$basearch'
533     REPO['GPGCheck']='yes'
534     REPO['GPGKey']='https://rpmfusion.org/keys?action=AttachFile&do=get&target=RPM-GPG-KEY-rpmfusion-free-el-\\\$releasever'
535     REPO['Exclude']=''
536     REPO['IncludePkgs']=''
537     createrepo
538    
539     #####################
540     #####################
541     #rpmfusion
542     #####################
543     #####################
544     REPO['reponame']='rpmfusion-nonfree'
545     REPO['fullreponame']='rpmfusion nonfree EL'
546     REPO['EnableGroups']='no'
547     REPO['Visible']='yes'
548     REPO['status']='disabled'
549     REPO['BaseURL']='http://download1.rpmfusion.org/nonfree/el/updates/\\\$releasever/\\\$basearch/'
550     REPO['MirrorList']='http://mirrors.rpmfusion.org/mirrorlist?repo=nonfree-el-updates-released-\\\$releasever&arch=\\\$basearch'
551     REPO['GPGCheck']='yes'
552     REPO['GPGKey']='https://rpmfusion.org/keys?action=AttachFile&do=get&target=RPM-GPG-KEY-rpmfusion-nonfree-el-\\\$releasever'
553     REPO['Exclude']=''
554     REPO['IncludePkgs']=''
555     createrepo
556 jpp 1.3
557    
558 jpp 1.2
559    
560     rm -f %{name}-%{version}-filelist*
561     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist
562 jpp 1.4 cat %{name}-%{version}-filelist| grep centos-sclo-rh > %{name}-%{version}-filelist-centos-sclo-rh
563 jpp 1.2 cat %{name}-%{version}-filelist| egrep 'digium|asterisk' > %{name}-%{version}-filelist-asterisk
564     cat %{name}-%{version}-filelist| grep egroupware > %{name}-%{version}-filelist-egroupware
565     cat %{name}-%{version}-filelist| grep elastic > %{name}-%{version}-filelist-elastic
566     cat %{name}-%{version}-filelist| grep elrepo > %{name}-%{version}-filelist-elrepo
567     cat %{name}-%{version}-filelist| grep epel > %{name}-%{version}-filelist-epel
568 jpp 1.3 cat %{name}-%{version}-filelist| grep erlang > %{name}-%{version}-filelist-erlang
569 jpp 1.4 cat %{name}-%{version}-filelist| grep freeswitch > %{name}-%{version}-filelist-freeswitch
570     cat %{name}-%{version}-filelist| grep fws > %{name}-%{version}-filelist-fws
571     cat %{name}-%{version}-filelist| grep geekery > %{name}-%{version}-filelist-geekery
572     if ( "%{?dist}" == "el7" ); then
573     cat %{name}-%{version}-filelist| grep odoo > %{name}-%{version}-filelist-odoo
574     fi
575     cat %{name}-%{version}-filelist| grep okay > %{name}-%{version}-filelist-okay
576     cat %{name}-%{version}-filelist| grep openfusion > %{name}-%{version}-filelist-openfusion
577     cat %{name}-%{version}-filelist| grep reetp > %{name}-%{version}-filelist-reetp
578     cat %{name}-%{version}-filelist| grep remi-safe > %{name}-%{version}-filelist-remi-safe
579     cat %{name}-%{version}-filelist| grep remi-ocsinventory > %{name}-%{version}-filelist-remi-ocsinventory
580     cat %{name}-%{version}-filelist| grep remi-roundcube > %{name}-%{version}-filelist-remi-roundcube
581     cat %{name}-%{version}-filelist| grep remi|egrep -v 'safe|ocsinventory|roundcube' > %{name}-%{version}-filelist-remi
582     cat %{name}-%{version}-filelist| grep rpmfusion > %{name}-%{version}-filelist-rpmfusion
583 jpp 1.1
584     %clean
585     cd ..
586     rm -rf %{name}-%{version}
587    
588     %files -f %{name}-%{version}-filelist
589     %defattr(-,root,root)
590    
591     %pre
592    
593     %preun
594    
595     %post
596    
597     %postun
598     case "$1" in
599    
600     0)
601     # this is an uninstallation
602     ;;
603    
604     1)
605     # this is an upgrade
606     ;;
607     esac
608 jpp 1.2
609 jpp 1.4 %package centos-sclo-rh
610     Summary: CentOS Red-Hat software collection repository
611     %description centos-sclo-rh
612     CentOS Red-Hat software collection repository
613     %files centos-sclo-rh -f %{name}-%{version}-filelist-centos-sclo-rh
614 jpp 1.2 %defattr(-,root,root)
615    
616     %package asterisk
617     Summary: All repositories you need for Asterisk and FreePBX
618     %description asterisk
619     All repositories you need for Asterisk and FreePBX
620     %files asterisk -f %{name}-%{version}-filelist-asterisk
621     %defattr(-,root,root)
622    
623     %package egroupware
624     Summary: Repository for eGroupWare
625     %description egroupware
626     Repository for eGroupWare
627     %files egroupware -f %{name}-%{version}-filelist-egroupware
628     %defattr(-,root,root)
629    
630     %package elastic
631     Summary: Repositories for elastic search
632     %description elastic
633     Repositories for elastic search
634     %files elastic -f %{name}-%{version}-filelist-elastic
635     %defattr(-,root,root)
636    
637     %package elrepo
638     Summary: ElRepo.org Community Enterprise Linux Repository
639     %description elrepo
640     ElRepo.org Community Enterprise Linux Repository
641     %files elrepo -f %{name}-%{version}-filelist-elrepo
642     %defattr(-,root,root)
643    
644     %package epel
645     Summary: Fedora EPEL Repository
646     %description epel
647     Fedora EPEL Repository
648     %files epel -f %{name}-%{version}-filelist-epel
649     %defattr(-,root,root)
650    
651 jpp 1.3 %package erlang
652     Summary: Erlang Repository
653     %description erlang
654     Erlang is a programming language. It is specifically used for ejabberd.
655     %files erlang -f %{name}-%{version}-filelist-erlang
656     %defattr(-,root,root)
657    
658     %package freeswitch
659     Summary: Freeswitch Repository
660     %description freeswitch
661     FreeSWITCH is a scalable open source cross-platform telephony platform designed to route and interconnect popular communication protocols using audio, video, text or any other form of media. It was created in 2006 to fill the void left by proprietary commercial solutions. FreeSWITCH also provides a stable telephony platform on which many applications can be developed using a wide range of free tools
662     %files freeswitch -f %{name}-%{version}-filelist-freeswitch
663     %defattr(-,root,root)
664    
665 jpp 1.4 %package fws
666     Summary: Firewall Services repository
667     %description fws
668     Firewall Services repository
669     %files fws -f %{name}-%{version}-filelist-fws
670     %defattr(-,root,root)
671    
672     %package geekery
673     Summary: Geekery Repository
674     %description geekery
675     Geekery Repository
676     %files geekery -f %{name}-%{version}-filelist-geekery
677     %defattr(-,root,root)
678    
679     %package odoo
680     Summary: Odoo 10 Nightly - EL7 Repository
681     Distribution: el7
682     %description odoo
683     Odoo 10 Nightly - EL7 Repository
684     # comment as not available for centos 6 SME9
685     #%files odoo -f %{name}-%{version}-filelist-odoo
686     #%defattr(-,root,root)
687    
688     %package okay
689     Summary: Extra OKay Packages for Enterprise Linux
690     %description okay
691     Extra OKay Packages for Enterprise Linux - Freeswitch and FusionPBX
692     %files okay -f %{name}-%{version}-filelist-okay
693     %defattr(-,root,root)
694    
695     %package openfusion
696     Summary: Openfusion Repository
697     %description openfusion
698     Openfusion Repository
699     %files openfusion -f %{name}-%{version}-filelist-openfusion
700     %defattr(-,root,root)
701    
702     %package reetp
703     Summary: Mirror John Crisp reetspetit.com
704     %description reetp
705     Mirror John Crisp reetspetit.com
706     %files reetp -f %{name}-%{version}-filelist-reetp
707     %defattr(-,root,root)
708    
709     %package remi-safe
710     Summary: Remi safe repository
711     %description remi-safe
712     Remi safe repository
713     %files remi-safe -f %{name}-%{version}-filelist-remi-safe
714     %defattr(-,root,root)
715    
716     %package remi-ocsinventory
717     Summary: Remi repository filtered to install OCSinventory
718     %description remi-ocsinventory
719     Remi repository filtered to install OCSinventory
720     %files remi-ocsinventory -f %{name}-%{version}-filelist-remi-ocsinventory
721     %defattr(-,root,root)
722    
723     %package remi-roundcube
724     Summary: Remi repository filtered to install Roundcube
725     %description remi-roundcube
726     Remi repository filtered to install Roundcube
727     %files remi-roundcube -f %{name}-%{version}-filelist-remi-roundcube
728     %defattr(-,root,root)
729    
730     %package remi-unsafe
731     Summary: Remi unsafe repository
732     %description remi-unsafe
733     Remi unsafe repository. We call it unsafe, not because of the work, but because it can conflict with base rpm of your favorite distro. Use it at your own risk if you are able to handle the situation.
734     %files remi-unsafe -f %{name}-%{version}-filelist-remi
735     %defattr(-,root,root)
736    
737     %package rpmfusion
738     Summary: RPMFusion repositories
739     %description rpmfusion
740     RPMFusion repositories
741     %files rpmfusion -f %{name}-%{version}-filelist-rpmfusion
742     %defattr(-,root,root)
743 jpp 1.2

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed