1 |
# $Id: smeserver-freepbx.spec,v 1.18 2022/12/07 17:15:59 jpp Exp $ |
2 |
# Authority: vip-ire |
3 |
# Name: Daniel Berteaud |
4 |
|
5 |
#%define fpbxversion 2.5.0 |
6 |
%define version 14 |
7 |
%define release 10 |
8 |
%define name smeserver-freepbx |
9 |
|
10 |
Summary: Asterisk web GUI |
11 |
Name: %{name} |
12 |
Version: %{version} |
13 |
Release: %{release}%{?dist} |
14 |
License: GPL |
15 |
Group: System/Servers |
16 |
Source: %{name}-%{version}.tar.gz |
17 |
Patch0: smeserver-freepbx-14-bz11940-bz9756-cron.patch |
18 |
Patch1: smeserver-freepbx-14-bz11924-sounds.patch |
19 |
Patch2: smeserver-freepbx-14-bz11986-service-fwconsole.patch |
20 |
Patch3: smeserver-freepbx-14-bz12009-backup.patch |
21 |
Patch4: smeserver-freepbx-14-bz12046-httpd24.patch |
22 |
Patch5: smeserver-freepbx-14-bz12226.patch |
23 |
Patch6: smeserver-freepbx-14-bz10703-backup.patch |
24 |
Patch7: smeserver-freepbx-14-bz11923-bz12256.patch |
25 |
|
26 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
27 |
URL: http://www.freepbx.org/ |
28 |
|
29 |
BuildRequires: e-smith-devtools |
30 |
BuildRequires: tar |
31 |
|
32 |
Requires: mariadb |
33 |
Requires: nodejs >= 10 |
34 |
# freepbx 14 requires php56 |
35 |
Requires: php56-php-pear php56-php-cgi php56-php-common php56-php-curl php56-php-mbstring php56-php-gd php56-php-mysql php56-php-gettext php56-php-bcmath php56-php-zip php56-php-xml php56-php-imap php56-php-json php56-php-process php56-php-snmp |
36 |
# freepbx 15 and 16 |
37 |
Requires: php74-php-pear php74-php-cgi php74-php-common php74-php-curl php74-php-mbstring php74-php-gd php74-php-mysql php74-php-gettext php74-php-bcmath php74-php-zip php74-php-xml php74-php-imap php74-php-json php74-php-process php74-php-snmp |
38 |
# freepbx 16 |
39 |
Requires: php80-php-pear php80-php-cgi php80-php-common php80-php-curl php80-php-mbstring php80-php-gd php80-php-mysql php80-php-gettext php80-php-bcmath php80-php-zip php80-php-xml php80-php-imap php80-php-json php80-php-process php80-php-snmp |
40 |
|
41 |
Requires: httpd |
42 |
Requires: php-pear |
43 |
Requires: /usr/sbin/asterisk |
44 |
#Requires: dahdi-tools |
45 |
#Requires: dahdi-linux |
46 |
Requires: sox |
47 |
Requires: mod_auth_tkt |
48 |
Requires: e-smith-base |
49 |
Requires: freepbx-src |
50 |
Requires: asterisk-sounds-core-en-ulaw |
51 |
Requires: asterisk-voicemail |
52 |
Requires: asterisk-configs |
53 |
#SME10 |
54 |
Requires: asterisk-mysql asterisk-odbc asterisk-pjsip asterisk-sip asterisk-festival asterisk-moh-opsound asterisk-snmp asterisk-mp3 asterisk-sounds-core-en asterisk-moh-opsound |
55 |
Requires: asterisk-voicemail-plain |
56 |
# conlicts with imap asterisk-voicemail-odbc asterisk-voicemail-plain |
57 |
Requires: ffmpeg |
58 |
Requires: mpg123 |
59 |
Requires: mysql-connector-odbc |
60 |
Requires: unixODBC |
61 |
Requires: asterisk-odbc |
62 |
Requires: lame |
63 |
Requires: xz |
64 |
Requires: asterisk-ael asterisk-iax2 asterisk-fax asterisk-ldap asterisk-misdn |
65 |
Requires: MySQL-python opus nmap icu vsftpd libicu-devel gcc-c++ |
66 |
Requires: asterisk-moh-opsound-alaw asterisk-moh-opsound-g722 asterisk-moh-opsound-g729 asterisk-moh-opsound-gsm asterisk-moh-opsound-siren14 asterisk-moh-opsound-siren7 asterisk-moh-opsound-sln16 asterisk-moh-opsound-ulaw asterisk-moh-opsound-wav |
67 |
Requires: asterisk-sounds-core-en-alaw asterisk-sounds-core-en-g722 asterisk-sounds-core-en-g729 asterisk-sounds-core-en-gsm asterisk-sounds-core-en-siren14 asterisk-sounds-core-en-siren7 asterisk-sounds-core-en-sln16 asterisk-sounds-core-en-ulaw asterisk-sounds-core-en-wav |
68 |
# Requires: asterisk-sounds-core-fr-alaw asterisk-sounds-core-fr-g722 asterisk-sounds-core-fr-g729 asterisk-sounds-core-fr-gsm asterisk-sounds-core-fr-siren14 asterisk-sounds-core-fr-siren7 asterisk-sounds-core-fr-sln16 asterisk-sounds-core-fr-ulaw asterisk-sounds-core-fr-wav |
69 |
# Requires: asterisk-sounds-core-it-alaw asterisk-sounds-core-it-g722 asterisk-sounds-core-it-g729 asterisk-sounds-core-it-gsm asterisk-sounds-core-it-siren14 asterisk-sounds-core-it-siren7 asterisk-sounds-core-it-sln16 asterisk-sounds-core-it-ulaw asterisk-sounds-core-it-wav |
70 |
# Requires: asterisk-sounds-core-es-alaw asterisk-sounds-core-es-g722 asterisk-sounds-core-es-g729 asterisk-sounds-core-es-gsm asterisk-sounds-core-es-siren14 asterisk-sounds-core-es-siren7 asterisk-sounds-core-es-sln16 asterisk-sounds-core-es-ulaw asterisk-sounds-core-es-wav |
71 |
Requires: e-smith-apache >= 2.6.0-19 |
72 |
Requires: smeserver-php >= 3.0.0-43 |
73 |
#Buildarch: noarch |
74 |
AutoReqProv: no |
75 |
|
76 |
|
77 |
%description |
78 |
FreePBX is a Standardised Implementation of Asterisk that gives you a GUI to manage your system. If you have looked into Asterisk, you would know that it does not come with any built in programming. You cannot plug a phone into it and make it work without editing configuration files, writing dialplans, and various messing about. FreePBX simplifies this by giving you a pre-written set of dialplans that allow you to have a fully functional PBX pretty much straight away. |
79 |
This package provide the integration of FreePBX on SME Server. |
80 |
|
81 |
|
82 |
%changelog |
83 |
* Tue Dec 13 2022 Jean-Philippe Pialasse <tests@pialasse.com> 14-10.sme |
84 |
- fix backup for FreePBX 15 and higher [SME: 12256] |
85 |
- make compatible up to FreePBX 16 [SME: 11923] |
86 |
|
87 |
* Wed Dec 07 2022 Jean-Philippe Pialasse <tests@pialasse.com> 14-9.sme |
88 |
- improve backup [SME: 10703] |
89 |
|
90 |
* Wed Dec 07 2022 Jean-Philippe Pialasse <tests@pialasse.com> 14-8.sme |
91 |
- fix patch for asterisk crontab [SME: 12227] |
92 |
|
93 |
* Wed Dec 07 2022 Jean-Philippe Pialasse <tests@pialasse.com> 14-7.sme |
94 |
- fix voicemail not visible in UCP [SME: 12254] |
95 |
force asterisk-voicemail-plain |
96 |
|
97 |
* Fri Nov 18 2022 Jean-Philippe Pialasse <tests@pialasse.com> 14-6.sme |
98 |
- fix creation of folder preventing migration [SME: 12226] |
99 |
|
100 |
* Sat Jul 30 2022 Brian Read <brianr@bjsystems.co.uk> 14-5.sme |
101 |
- Re-build and link to latest devtools [SME: 11997] |
102 |
|
103 |
* Fri Jul 22 2022 Jean-Philippe Pialasse <tests@pialasse.com> 14-4.sme |
104 |
- add to core backup [SME: 12009] |
105 |
- httpd 2.4 syntax [SME: 12046] |
106 |
|
107 |
* Tue May 31 2022 Jean-Philippe Pialasse <tests@pialasse.com> 14-3.sme |
108 |
- Re-build and link to latest devtools service file fwconsole path [SME: 11986] |
109 |
|
110 |
* Sat Apr 16 2022 Jean-Philippe Pialasse <tests@pialasse.com> 14-2.sme |
111 |
- Re-build and link to latest devtools huge amount of error if asterisk disabled [SME: 9756] |
112 |
- Re-build and link to latest devtools multiple email sent because of asterisk cron php path [SME: 11940] |
113 |
- on uninstall remove asterisk crontab to avoid noise [SME: 10131] |
114 |
- allow access to sounds folder for gui [SME: 11924] |
115 |
|
116 |
* Sun Mar 27 2022 Jean-Philippe Pialasse <tests@pialasse.com> 14-1.sme |
117 |
- first version 14 [SME: 11613] |
118 |
|
119 |
* Wed Nov 10 2021 Jean-Philippe Pialasse <tests@pialasse.com> 13-17.sme |
120 |
- first import to SME10 [SME: 11613] |
121 |
- make it Freepbx 14 compatible [SME: 10705] |
122 |
add dependencies for SME10 mariadb nodejs >= 10 php70* |
123 |
remove missing rpms asterisk-sounds-extra-en-ulaw asterisk-resample asterisk-addons |
124 |
remove double owned folders /etc/asterisk /var/lib/asterisk |
125 |
systemd ready for asterisk(disabled), freepbx, httpd-fpbx |
126 |
smeserver-freepbx-update event created NEED TEST |
127 |
php70-php-fpm fragment |
128 |
update httpd-fpbx template for php-fpm use |
129 |
update httpd-e-smith to use php-fpm for fpbx |
130 |
update install script for php74 |
131 |
add a copy of safe_asterisk |
132 |
create php folders and set rights |
133 |
improve logrotate |
134 |
|
135 |
* Mon Jan 20 2020 Jean-Philipe Pialasse <tests@pialasse.com> 13-16.sme |
136 |
- add required modules to enable cel and cdr logging and search [SME: 10620] |
137 |
- add requires lame [SME: 9859] |
138 |
- Re-build and link to latest devtools sounds ownership so they can be handled via gui [SME: 11924] |
139 |
|
140 |
* Mon Jan 29 2018 Jean-Philipe Pialasse <tests@pialasse.com> 13-15.sme |
141 |
- Re-build and link to latest devtools warning tampered files in GUI [SME: 10496] |
142 |
- remove DeviceAndUser property [SME: 10503] |
143 |
|
144 |
* Wed May 03 2017 Jean-Philipe Pialasse <tests@pialasse.com> 13-14.sme |
145 |
- update TKT auth parameter for SME 9.2 [SME: 10268] |
146 |
|
147 |
* Sat Feb 25 2017 Jean-Philipe Pialasse <tests@pialasse.com> 13-13.sme |
148 |
- Re-build and link to latest devtools noise rebooting and restarting freepbx [SME: 10120] |
149 |
|
150 |
* Wed Jan 25 2017 Jean-Philipe Pialasse <tests@pialasse.com> 13-11.sme |
151 |
- NFR: auto backup of whole FBX config during pre-backup event [SME: 9637] |
152 |
- both asdb and fpbx, asterisk config files, freepbx folders, voicemails are part of backup |
153 |
- 2 versions are kepts |
154 |
- weekly backup is also done. |
155 |
|
156 |
* Mon Jan 23 2017 Jean-Philipe Pialasse <tests@pialasse.com> 13-10.sme |
157 |
- Re-build and link to latest devtools Missing HTML5 format converters [SME: 9859] |
158 |
- added requirement for mpg123 and ffmpeg available in smecontribs |
159 |
|
160 |
* Mon Jan 23 2017 Jean-Philipe Pialasse <tests@pialasse.com> 13-9.sme |
161 |
- update framework before other modules [SME: 9860] |
162 |
|
163 |
* Mon Jan 09 2017 Jean-Philipe Pialasse <tests@pialasse.com> 13-8.sme |
164 |
- autoupgrade modules [SME: 9860] |
165 |
|
166 |
* Mon Jan 09 2017 Jean-Philipe Pialasse <tests@pialasse.com> 13-7.sme |
167 |
- Re-build and link to latest devtools wrong default UDPPorts on new install [SME: 9918] |
168 |
|
169 |
* Mon Oct 24 2016 Jean-Philipe Pialasse <tests@pialasse.com> 13-6.sme |
170 |
- Re-build and link to latest devtools error while backup with workstation [SME: 9760] |
171 |
|
172 |
* Mon Oct 24 2016 Jean-Philipe Pialasse <tests@pialasse.com> 13-5.sme |
173 |
-fix typo in smeserver-freepbx-13.bz9744.patch |
174 |
|
175 |
* Sun Oct 23 2016 Jean-Philipe Pialasse <tests@pialasse.com> 13-4.sme |
176 |
- Re-build and link to latest devtools [SME: 9702] |
177 |
- corrected syntax for port range |
178 |
|
179 |
* Sun Oct 23 2016 Jean-Philipe Pialasse <tests@pialasse.com> 13-3.sme |
180 |
- Re-build and link to latest devtools [SME: 9744] |
181 |
- Re-build and link to latest devtools wrong /tmp folder permission after update |
182 |
- Thank you Hsing-Foo Wang. |
183 |
|
184 |
* Tue Jul 26 2016 Jean-Philipe Pialasse <tests@pialasse.com> 13-2.sme |
185 |
- Re-build and link to latest devtools wrong UDP ports change 1000:2000 to 10000:20000 [SME: 9702] |
186 |
|
187 |
* Mon Jun 13 2016 Jean-Philipe Pialasse <tests@pialasse.com> 13-1.sme |
188 |
- bump version to current Freepbx version 13 |
189 |
|
190 |
* Mon Jun 13 2016 Jean-Philipe Pialasse <tests@pialasse.com> -47.sme |
191 |
- add all needed port for Freepbx sip pjsip and RTP [SME: 9495] |
192 |
|
193 |
* Sat Jun 11 2016 Jean-Philipe Pialasse <tests@pialasse.com> -46.sme |
194 |
- Re-build and link to latest devtools missing config files (requires asterisk-configs) [SME: 9577] |
195 |
- Re-build and link to latest devtools recuring reconfiguration error while installing digium phone module [SME: 9575] |
196 |
- added port 5061 for tls to TCP ports [SME: 9576] |
197 |
|
198 |
* Thu Jun 09 2016 Jean-Philipe Pialasse <tests@pialasse.com> -45.sme |
199 |
- Re-build and link to latest devtools wrong logrotate pattern [SME: 9516] |
200 |
- as the contrib is only in smedev, i do not fix existing log files badly rotated |
201 |
|
202 |
* Mon May 16 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.1-44.sme |
203 |
- remove fop db [SME: 9495] |
204 |
- add some mysql setting for freepbxdb (user, email) |
205 |
- smeserver-freepbx-0.1-Sme9Ast13Fpbx13-7.patch |
206 |
|
207 |
* Sun May 15 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.1-43.sme |
208 |
- add path to ucp module [SME: 9495] |
209 |
- add 256Mo as default for freepbx php Memory |
210 |
- add AllowOveride All for .htaccess |
211 |
- remove httpd config to old FOP panel |
212 |
- add port 5061 for freepbx |
213 |
- smeserver-freepbx-0.1-Sme9Ast13Fpbx13-5.patch |
214 |
- configuration of amportal.conf and its mysql equivalent |
215 |
- smeserver-freepbx-0.1-Sme9Ast13Fpbx13-6.patch |
216 |
|
217 |
* Sun May 15 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.1-42.sme |
218 |
- remove FOP patches [SME: 9495] |
219 |
- deleted link to expand amportal.conf |
220 |
- smeserver-freepbx-0.1-Sme9Ast13Fpbx13-4.patch |
221 |
|
222 |
* Sun May 15 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.1-41.sme |
223 |
- remove heading of /etc/asterisk/asterisk.conf [SME: 9495] |
224 |
- smeserver-freepbx-0.1-Sme9Ast13Fpbx13-3.patch |
225 |
- bump |
226 |
|
227 |
* Sun May 15 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.1-38.sme |
228 |
- remove expand template amportal.conf [SME: 9495] |
229 |
- chown /var/lib/asterisk |
230 |
- installation configuration options |
231 |
- smeserver-freepbx-0.1-Sme9Ast13Fpbx13-2.patch |
232 |
- Requires: asterisk-sounds-core-en-ulaw asterisk-sounds-extra-en-ulaw asterisk-voicemail |
233 |
|
234 |
* Sun May 15 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.1-37.sme |
235 |
- new path to sql files [SME: 9495] |
236 |
- smeserver-freepbx-0.1-Sme9Ast13Fpbx13-1.patch |
237 |
|
238 |
* Fri May 06 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.1-36.sme |
239 |
- adapt script to fpbx13 and asterisk 13 [SME: 9495] |
240 |
- change Requires Requires: %{_libdir}/asterisk/modules/app_addon_sql_mysql.so to |
241 |
- Requires: asterisk-addons as this is the paquet providing it, and it changed name to app_mysql.so |
242 |
|
243 |
* Fri May 06 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.1-35.sme |
244 |
- adapt script to fpbx13 and asterisk 13 [SME: 9495] |
245 |
- smeserver-freepbx-0.1-Sme9Ast13Fpbx13-0.patch |
246 |
|
247 |
* Fri May 06 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.1-34.sme |
248 |
- first import to SME9 [SME: 9495] |
249 |
|
250 |
* Sun May 12 2013 JP Pialasse <tests@pialasse.com> 0.1-33.sme |
251 |
- buildarch removed in order to find the correct %{_libdir}/asterisk/modules/app_addon_sql_mysql.so |
252 |
|
253 |
* Thu Oct 20 2011 Daniel B. <daniel@firewall-services.com> 0.1-32.sme |
254 |
- Protect by locations (so other alias can be defined to protect with LL::NG for example) |
255 |
|
256 |
* Mon Oct 17 2011 Daniel B. <daniel@firewall-services.com> 0.1-31.sme |
257 |
- Add misdn.log to logrotate |
258 |
|
259 |
* Thu Oct 13 2011 Daniel B. <daniel@firewall-services.com> 0.1-30.sme |
260 |
- Change session path [SME: 6661] |
261 |
|
262 |
* Wed Jan 05 2011 Daniel B. <daniel@firewall-services.com> 0.1-29.sme |
263 |
- astdatadir is /var/lib/asterisk |
264 |
- templates for /etc/logrotate.d/asterisk |
265 |
|
266 |
* Mon Sep 20 2010 Daniel B. <daniel@firewall-services.com> 0.1-28.sme |
267 |
- Create and populate the mysql databases in mysql.init |
268 |
- Templates for /etc/asterisk/asterisk.conf |
269 |
|
270 |
* Thu Jul 15 2010 Daniel B. <daniel@firewall-services.com> [0.1-27] |
271 |
- Read ARI password from the DB (and initialize a random one) |
272 |
|
273 |
* Mon Feb 22 2010 Daniel B. <daniel@firewall-services.com> [0.1-26] |
274 |
- Remove hard-coded dependencies on asterisk and asterisk-addons14 |
275 |
Depends now on asterisk binary and app_addon_sql_mysql.so files |
276 |
(so it can work with asterisk or asterisk14) |
277 |
|
278 |
* Mon Feb 15 2010 Daniel B. <daniel@firewall-services.com> [0.1-25] |
279 |
- Remove /etc/logrotate.d/asterisk which is now included in asterisk14 |
280 |
|
281 |
* Tue Feb 09 2010 Daniel B. <daniel@firewall-services.com> [0.1-24] |
282 |
- Depends now on asterisk14 and asterisk-addons14 |
283 |
|
284 |
* Wed Jan 06 2010 Daniel B. <daniel@firewall-services.com> [0.1-23] |
285 |
- disable dynamic hints |
286 |
|
287 |
* Tue Oct 06 2009 Daniel B. <daniel@firewall-services.com> [0.1-22] |
288 |
- include /opt/freepbx/admin/functions.inc.php in freepbx-dump-astdb |
289 |
action script for FreePBX 2.6 compatibility |
290 |
|
291 |
* Tue May 19 2009 Daniel B. <daniel@firewall-services.com> [0.1-21] |
292 |
- Add CHECKREFERER=FALSE in amportal.conf to repvent error message in some |
293 |
modules (due to the ProxyPass configuration) |
294 |
|
295 |
* Tue Apr 28 2009 Daniel B. <daniel@firewall-services.com> [0.1-20] |
296 |
- Fix CDR db password in cdr_mysql.conf template |
297 |
- Use a separate service in SME db for FOP |
298 |
|
299 |
* Thu Apr 16 2009 Daniel B. <daniel@firewall-services.com> [0.1-19] |
300 |
- remove scoreboard directive from httpd-fpbx config |
301 |
- remove some modules (mod_ssl, mod_proxy) |
302 |
|
303 |
* Sat Apr 11 2009 Daniel B. <daniel@firewall-services.com> [0.1-18] |
304 |
- templatize cdr_mysql.conf [SME: 5153] |
305 |
- templatize manager.conf |
306 |
- remove freepbx-cron-scheduler.php from root crontab so only |
307 |
asterisk user runs it (prevent email error sent from cron) |
308 |
|
309 |
* Fri Mar 27 2009 Daniel B. <daniel@firewall-services.com> [0.1-17] |
310 |
- Remove obsolete /admin Alias from apache |
311 |
- Run the security script on bootsrape-console-save event |
312 |
|
313 |
* Mon Mar 23 2009 Daniel B. <daniel@firewall-services.com> [0.1-16] |
314 |
- Security Fixe: put a random password for ARI admin (this should be documented) |
315 |
|
316 |
* Thu Mar 19 2009 Daniel B. <daniel@firewall-services.com> [0.1-15] |
317 |
- Check if /opt/freepbx/admin exists (retry the install if a first one failed) |
318 |
- Remove tabs from spec |
319 |
|
320 |
* Wed Mar 18 2009 Daniel B. <daniel@firewall-services.com> [0.1-14] |
321 |
- Remove speex from dependencies |
322 |
|
323 |
* Thu Mar 12 2009 Daniel B. <daniel@firewall-services.com> [0.1-13] |
324 |
- Remove zaptel dependency, replaced with dahdi-tools and dahdi-linux |
325 |
|
326 |
* Mon Feb 23 2009 Daniel B. <daniel@firewall-services.com> [0.1-12] |
327 |
- Fix logrotate issue (send a sigusr1 signal to httpd-fpbx) |
328 |
|
329 |
* Thu Feb 12 2009 Daniel B. <daniel@firewall-services.com> [0.1-11] |
330 |
- Full support for the new DAHDI driver, droping zaptel |
331 |
|
332 |
* Mon Feb 09 2009 Daniel B. <daniel@firewall-services.com> [0.1-10] |
333 |
- add support for DAHDI channel |
334 |
|
335 |
* Mon Dec 08 2008 Daniel B. <daniel@firewall-services.com> [0.1-9] |
336 |
- move expand-templates from post-upgrade event to bootstrap-console-save |
337 |
|
338 |
* Thu Nov 27 2008 Daniel B. <daniel@firewall-services.com> [0.1-8] |
339 |
- Add support for trunk name in mail alerts |
340 |
|
341 |
* Wed Nov 26 2008 Daniel B. <daniel@firewall-services.com> [0.1-7] |
342 |
- Add a simple script to alert admin by mail on trunk errors |
343 |
|
344 |
* Thu Nov 20 2008 Daniel B. <daniel@firewall-services.com> [0.1-6] |
345 |
- Use AdminPanels props so access can be configured using |
346 |
smeserver-userpanels contrib. AdminUsers and FopUsers |
347 |
props aren't used anymore |
348 |
|
349 |
* Wed Nov 19 2008 Daniel B. <daniel@firewall-services.com> [0.1-5] |
350 |
- add logrotate default config file for asterisk's logs |
351 |
- spec cleanup |
352 |
|
353 |
* Thu Nov 13 2008 Daniel B. <daniel@firewall-services.com> [0.1-4] |
354 |
- Re-build and link to latest devtools logrotate issue |
355 |
|
356 |
* Wed Nov 05 2008 Daniel B. <daniel@firewall-services.com> [0.1-3] |
357 |
- split freepbx sources in a separate package (freepbx-src) |
358 |
- alternative genzaptelconf |
359 |
|
360 |
* Mon Oct 13 2008 Daniel B. <daniel@firewall-services.com> [0.1-2] |
361 |
- Fix fop not being displayed in admin page |
362 |
|
363 |
* Sat Sep 20 2008 Daniel B. <daniel@firewall-services.com> [0.1-1] |
364 |
- updated to 2.5.0 final |
365 |
- spec cleaning |
366 |
- templates cleaning |
367 |
- templates to update mysql informations |
368 |
|
369 |
* Mon Aug 04 2008 daniel B. <daniel@firewall-services.com> [0.1-0] |
370 |
- initial release |
371 |
|
372 |
%prep |
373 |
%setup -q -n %{name}-%{version} |
374 |
%patch0 -p1 |
375 |
%patch1 -p1 |
376 |
%patch2 -p1 |
377 |
%patch3 -p1 |
378 |
%patch4 -p1 |
379 |
%patch5 -p1 |
380 |
%patch6 -p1 |
381 |
%patch7 -p1 |
382 |
|
383 |
%build |
384 |
# Build symlinks |
385 |
perl createlinks |
386 |
|
387 |
%install |
388 |
rm -rf $RPM_BUILD_ROOT |
389 |
|
390 |
%{__mkdir_p} $RPM_BUILD_ROOT/var/lib/php/fpbx-session |
391 |
|
392 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
393 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
394 |
--file /sbin/e-smith/fwconsole 'attr(0755,root,root)' \ |
395 |
--file /usr/share/freepbx/scripts/uninstall.sh 'attr(0750,root,root)' \ |
396 |
--file /usr/share/freepbx/scripts/restore-astdb.php 'attr(0750,root,root)' \ |
397 |
--dir /var/service/httpd-fpbx 'attr(01755,root,root)' \ |
398 |
--dir /var/service/httpd-fpbx/supervise 'attr(0700,root,root)' \ |
399 |
--dir /var/service/httpd-fpbx/log 'attr(0755,root,root)' \ |
400 |
--file /var/service/httpd-fpbx/log/run 'attr(0755,root,root)' \ |
401 |
--dir /var/service/httpd-fpbx/log/supervise 'attr(0700,root,root)' \ |
402 |
--file /var/lib/asterisk/bin/genzaptelconf 'attr(0750,root,root)' \ |
403 |
--file /usr/share/asterisk/agi-bin/trunk_alert_mail.agi 'attr(0750,asterisk,asterisk)' \ |
404 |
--file /etc/logrotate.d/asterisk 'config(noreplace)' \ |
405 |
--dir /var/lib/php/fpbx-session 'attr(0770,root,asterisk)' \ |
406 |
--file /usr/sbin/safe_asterisk 'attr(0755,root,root)' \ |
407 |
--dir /var/log/php/freepbx 'attr(0770,root,asterisk)' \ |
408 |
--dir /var/lib/php/freepbx/sessions 'attr(0770,root,asterisk)' \ |
409 |
--dir /var/lib/php/freepbx/temp 'attr(0770,root,asterisk)' \ |
410 |
|grep -v '/var/lib/asterisk$'| grep -v '/etc/asterisk$' \ |
411 |
> %{name}-%{version}-%{release}-filelist |
412 |
|
413 |
%clean |
414 |
rm -rf $RPM_BUILD_ROOT |
415 |
|
416 |
%files -f %{name}-%{version}-%{release}-filelist |
417 |
%defattr(-,root,root) |
418 |
|
419 |
|
420 |
%post |
421 |
|
422 |
#bug 9744, restore tmp permissions |
423 |
if [ `stat -c %U /tmp` == "asterisk" ]; then |
424 |
chmod o+rwxt /tmp/ |
425 |
chown root:root /tmp/ |
426 |
fi |
427 |
|
428 |
%preun |
429 |
if [ $1 = 0 ] ; then |
430 |
/usr/bin/systemctl stop freepbx >& /dev/null || : |
431 |
fi |
432 |
true |
433 |
%postun |
434 |
if [ $1 = 0 ] ; then |
435 |
#remove cron for asterisk on uninstallation to avoid noise |
436 |
/usr/bin/crontab -u asterisk -r >& /dev/null || : |
437 |
fi |
438 |
true |
439 |
|
440 |
|
441 |
|