1 |
# $Id: smeserver-freepbx.spec,v 1.16 2022/12/07 06:01:37 jpp Exp $ |
2 |
# Authority: vip-ire |
3 |
# Name: Daniel Berteaud |
4 |
|
5 |
#%define fpbxversion 2.5.0 |
6 |
%define version 14 |
7 |
%define release 8 |
8 |
%define name smeserver-freepbx |
9 |
|
10 |
Summary: Asterisk web GUI |
11 |
Name: %{name} |
12 |
Version: %{version} |
13 |
Release: %{release}%{?dist} |
14 |
License: GPL |
15 |
Group: System/Servers |
16 |
Source: %{name}-%{version}.tar.gz |
17 |
Patch0: smeserver-freepbx-14-bz11940-bz9756-cron.patch |
18 |
Patch1: smeserver-freepbx-14-bz11924-sounds.patch |
19 |
Patch2: smeserver-freepbx-14-bz11986-service-fwconsole.patch |
20 |
Patch3: smeserver-freepbx-14-bz12009-backup.patch |
21 |
Patch4: smeserver-freepbx-14-bz12046-httpd24.patch |
22 |
Patch5: smeserver-freepbx-14-bz12226.patch |
23 |
|
24 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
25 |
URL: http://www.freepbx.org/ |
26 |
|
27 |
BuildRequires: e-smith-devtools |
28 |
BuildRequires: tar |
29 |
|
30 |
Requires: mariadb |
31 |
Requires: nodejs >= 10 |
32 |
#Requires: php-pear php-cgi php-common php-curl php-mbstring php-gd php-mysql php-gettext php-bcmath php-zip php-xml php-imap php-json php-process php-snmp |
33 |
# freepbx 14 requires php56 |
34 |
Requires: php56-php-pear php56-php-cgi php56-php-common php56-php-curl php56-php-mbstring php56-php-gd php56-php-mysql php56-php-gettext php56-php-bcmath php56-php-zip php56-php-xml php56-php-imap php56-php-json php56-php-process php56-php-snmp |
35 |
#Requires: php74-php-pear php74-php-cgi php74-php-common php74-php-curl php74-php-mbstring php74-php-gd php74-php-mysql php74-php-gettext php74-php-bcmath php74-php-zip php74-php-xml php74-php-imap php74-php-json php74-php-process php74-php-snmp |
36 |
Requires: httpd |
37 |
Requires: php-pear |
38 |
Requires: /usr/sbin/asterisk |
39 |
# not available for SME10 need to find module for mysql Requires: asterisk-addons |
40 |
#Requires: dahdi-tools |
41 |
#Requires: dahdi-linux |
42 |
Requires: sox |
43 |
Requires: mod_auth_tkt |
44 |
Requires: e-smith-base |
45 |
Requires: freepbx-src |
46 |
Requires: asterisk-sounds-core-en-ulaw |
47 |
# not available for sme10 Requires: asterisk-sounds-extra-en-ulaw |
48 |
# not available for sme10 Requires: asterisk-resample |
49 |
Requires: asterisk-voicemail |
50 |
Requires: asterisk-configs |
51 |
#SME10 |
52 |
Requires: asterisk-mysql asterisk-odbc asterisk-pjsip asterisk-sip asterisk-festival asterisk-moh-opsound asterisk-snmp asterisk-mp3 asterisk-sounds-core-en asterisk-moh-opsound |
53 |
Requires: asterisk-voicemail-plain |
54 |
# conlicts with imap asterisk-voicemail-odbc asterisk-voicemail-plain |
55 |
Requires: ffmpeg |
56 |
Requires: mpg123 |
57 |
Requires: mysql-connector-odbc |
58 |
Requires: unixODBC |
59 |
Requires: asterisk-odbc |
60 |
Requires: lame |
61 |
Requires: xz |
62 |
Requires: asterisk-ael asterisk-iax2 asterisk-fax asterisk-ldap asterisk-misdn |
63 |
Requires: MySQL-python opus nmap icu vsftpd libicu-devel gcc-c++ |
64 |
Requires: asterisk-moh-opsound-alaw asterisk-moh-opsound-g722 asterisk-moh-opsound-g729 asterisk-moh-opsound-gsm asterisk-moh-opsound-siren14 asterisk-moh-opsound-siren7 asterisk-moh-opsound-sln16 asterisk-moh-opsound-ulaw asterisk-moh-opsound-wav |
65 |
Requires: asterisk-sounds-core-en-alaw asterisk-sounds-core-en-g722 asterisk-sounds-core-en-g729 asterisk-sounds-core-en-gsm asterisk-sounds-core-en-siren14 asterisk-sounds-core-en-siren7 asterisk-sounds-core-en-sln16 asterisk-sounds-core-en-ulaw asterisk-sounds-core-en-wav |
66 |
# Requires: asterisk-sounds-core-fr-alaw asterisk-sounds-core-fr-g722 asterisk-sounds-core-fr-g729 asterisk-sounds-core-fr-gsm asterisk-sounds-core-fr-siren14 asterisk-sounds-core-fr-siren7 asterisk-sounds-core-fr-sln16 asterisk-sounds-core-fr-ulaw asterisk-sounds-core-fr-wav |
67 |
# Requires: asterisk-sounds-core-it-alaw asterisk-sounds-core-it-g722 asterisk-sounds-core-it-g729 asterisk-sounds-core-it-gsm asterisk-sounds-core-it-siren14 asterisk-sounds-core-it-siren7 asterisk-sounds-core-it-sln16 asterisk-sounds-core-it-ulaw asterisk-sounds-core-it-wav |
68 |
# Requires: asterisk-sounds-core-es-alaw asterisk-sounds-core-es-g722 asterisk-sounds-core-es-g729 asterisk-sounds-core-es-gsm asterisk-sounds-core-es-siren14 asterisk-sounds-core-es-siren7 asterisk-sounds-core-es-sln16 asterisk-sounds-core-es-ulaw asterisk-sounds-core-es-wav |
69 |
Requires: e-smith-apache >= 2.6.0-19 |
70 |
Requires: smeserver-php >= 3.0.0-43 |
71 |
#Buildarch: noarch |
72 |
AutoReqProv: no |
73 |
|
74 |
|
75 |
%description |
76 |
FreePBX is a Standardised Implementation of Asterisk that gives you a GUI to manage your system. If you have looked into Asterisk, you would know that it does not come with any built in programming. You cannot plug a phone into it and make it work without editing configuration files, writing dialplans, and various messing about. FreePBX simplifies this by giving you a pre-written set of dialplans that allow you to have a fully functional PBX pretty much straight away. |
77 |
This package provide the integration of FreePBX on SME Server. |
78 |
|
79 |
|
80 |
%changelog |
81 |
* Wed Dec 07 2022 Jean-Philippe Pialasse <tests@pialasse.com> 14-8.sme |
82 |
- fix patch for asterisk crontab [SME: 12227] |
83 |
|
84 |
* Wed Dec 07 2022 Jean-Philippe Pialasse <tests@pialasse.com> 14-7.sme |
85 |
- fix voicemail not visible in UCP [SME: 12254] |
86 |
force asterisk-voicemail-plain |
87 |
|
88 |
* Fri Nov 18 2022 Jean-Philippe Pialasse <tests@pialasse.com> 14-6.sme |
89 |
- fix creation of folder preventing migration [SME: 12226] |
90 |
|
91 |
* Sat Jul 30 2022 Brian Read <brianr@bjsystems.co.uk> 14-5.sme |
92 |
- Re-build and link to latest devtools [SME: 11997] |
93 |
|
94 |
* Fri Jul 22 2022 Jean-Philippe Pialasse <tests@pialasse.com> 14-4.sme |
95 |
- add to core backup [SME: 12009] |
96 |
- httpd 2.4 syntax [SME: 12046] |
97 |
|
98 |
* Tue May 31 2022 Jean-Philippe Pialasse <tests@pialasse.com> 14-3.sme |
99 |
- Re-build and link to latest devtools service file fwconsole path [SME: 11986] |
100 |
|
101 |
* Sat Apr 16 2022 Jean-Philippe Pialasse <tests@pialasse.com> 14-2.sme |
102 |
- Re-build and link to latest devtools huge amount of error if asterisk disabled [SME: 9756] |
103 |
- Re-build and link to latest devtools multiple email sent because of asterisk cron php path [SME: 11940] |
104 |
- on uninstall remove asterisk crontab to avoid noise [SME: 10131] |
105 |
- allow access to sounds folder for gui [SME: 11924] |
106 |
|
107 |
* Sun Mar 27 2022 Jean-Philippe Pialasse <tests@pialasse.com> 14-1.sme |
108 |
- first version 14 [SME: 11613] |
109 |
|
110 |
* Wed Nov 10 2021 Jean-Philippe Pialasse <tests@pialasse.com> 13-17.sme |
111 |
- first import to SME10 [SME: 11613] |
112 |
- make it Freepbx 14 compatible [SME: 10705] |
113 |
add dependencies for SME10 mariadb nodejs >= 10 php70* |
114 |
remove missing rpms asterisk-sounds-extra-en-ulaw asterisk-resample asterisk-addons |
115 |
remove double owned folders /etc/asterisk /var/lib/asterisk |
116 |
systemd ready for asterisk(disabled), freepbx, httpd-fpbx |
117 |
smeserver-freepbx-update event created NEED TEST |
118 |
php70-php-fpm fragment |
119 |
update httpd-fpbx template for php-fpm use |
120 |
update httpd-e-smith to use php-fpm for fpbx |
121 |
update install script for php74 |
122 |
add a copy of safe_asterisk |
123 |
create php folders and set rights |
124 |
improve logrotate |
125 |
|
126 |
* Mon Jan 20 2020 Jean-Philipe Pialasse <tests@pialasse.com> 13-16.sme |
127 |
- add required modules to enable cel and cdr logging and search [SME: 10620] |
128 |
- add requires lame [SME: 9859] |
129 |
- Re-build and link to latest devtools sounds ownership so they can be handled via gui [SME: 11924] |
130 |
|
131 |
* Mon Jan 29 2018 Jean-Philipe Pialasse <tests@pialasse.com> 13-15.sme |
132 |
- Re-build and link to latest devtools warning tampered files in GUI [SME: 10496] |
133 |
- remove DeviceAndUser property [SME: 10503] |
134 |
|
135 |
* Wed May 03 2017 Jean-Philipe Pialasse <tests@pialasse.com> 13-14.sme |
136 |
- update TKT auth parameter for SME 9.2 [SME: 10268] |
137 |
|
138 |
* Sat Feb 25 2017 Jean-Philipe Pialasse <tests@pialasse.com> 13-13.sme |
139 |
- Re-build and link to latest devtools noise rebooting and restarting freepbx [SME: 10120] |
140 |
|
141 |
* Wed Jan 25 2017 Jean-Philipe Pialasse <tests@pialasse.com> 13-11.sme |
142 |
- NFR: auto backup of whole FBX config during pre-backup event [SME: 9637] |
143 |
- both asdb and fpbx, asterisk config files, freepbx folders, voicemails are part of backup |
144 |
- 2 versions are kepts |
145 |
- weekly backup is also done. |
146 |
|
147 |
* Mon Jan 23 2017 Jean-Philipe Pialasse <tests@pialasse.com> 13-10.sme |
148 |
- Re-build and link to latest devtools Missing HTML5 format converters [SME: 9859] |
149 |
- added requirement for mpg123 and ffmpeg available in smecontribs |
150 |
|
151 |
* Mon Jan 23 2017 Jean-Philipe Pialasse <tests@pialasse.com> 13-9.sme |
152 |
- update framework before other modules [SME: 9860] |
153 |
|
154 |
* Mon Jan 09 2017 Jean-Philipe Pialasse <tests@pialasse.com> 13-8.sme |
155 |
- autoupgrade modules [SME: 9860] |
156 |
|
157 |
* Mon Jan 09 2017 Jean-Philipe Pialasse <tests@pialasse.com> 13-7.sme |
158 |
- Re-build and link to latest devtools wrong default UDPPorts on new install [SME: 9918] |
159 |
|
160 |
* Mon Oct 24 2016 Jean-Philipe Pialasse <tests@pialasse.com> 13-6.sme |
161 |
- Re-build and link to latest devtools error while backup with workstation [SME: 9760] |
162 |
|
163 |
* Mon Oct 24 2016 Jean-Philipe Pialasse <tests@pialasse.com> 13-5.sme |
164 |
-fix typo in smeserver-freepbx-13.bz9744.patch |
165 |
|
166 |
* Sun Oct 23 2016 Jean-Philipe Pialasse <tests@pialasse.com> 13-4.sme |
167 |
- Re-build and link to latest devtools [SME: 9702] |
168 |
- corrected syntax for port range |
169 |
|
170 |
* Sun Oct 23 2016 Jean-Philipe Pialasse <tests@pialasse.com> 13-3.sme |
171 |
- Re-build and link to latest devtools [SME: 9744] |
172 |
- Re-build and link to latest devtools wrong /tmp folder permission after update |
173 |
- Thank you Hsing-Foo Wang. |
174 |
|
175 |
* Tue Jul 26 2016 Jean-Philipe Pialasse <tests@pialasse.com> 13-2.sme |
176 |
- Re-build and link to latest devtools wrong UDP ports change 1000:2000 to 10000:20000 [SME: 9702] |
177 |
|
178 |
* Mon Jun 13 2016 Jean-Philipe Pialasse <tests@pialasse.com> 13-1.sme |
179 |
- bump version to current Freepbx version 13 |
180 |
|
181 |
* Mon Jun 13 2016 Jean-Philipe Pialasse <tests@pialasse.com> -47.sme |
182 |
- add all needed port for Freepbx sip pjsip and RTP [SME: 9495] |
183 |
|
184 |
* Sat Jun 11 2016 Jean-Philipe Pialasse <tests@pialasse.com> -46.sme |
185 |
- Re-build and link to latest devtools missing config files (requires asterisk-configs) [SME: 9577] |
186 |
- Re-build and link to latest devtools recuring reconfiguration error while installing digium phone module [SME: 9575] |
187 |
- added port 5061 for tls to TCP ports [SME: 9576] |
188 |
|
189 |
* Thu Jun 09 2016 Jean-Philipe Pialasse <tests@pialasse.com> -45.sme |
190 |
- Re-build and link to latest devtools wrong logrotate pattern [SME: 9516] |
191 |
- as the contrib is only in smedev, i do not fix existing log files badly rotated |
192 |
|
193 |
* Mon May 16 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.1-44.sme |
194 |
- remove fop db [SME: 9495] |
195 |
- add some mysql setting for freepbxdb (user, email) |
196 |
- smeserver-freepbx-0.1-Sme9Ast13Fpbx13-7.patch |
197 |
|
198 |
* Sun May 15 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.1-43.sme |
199 |
- add path to ucp module [SME: 9495] |
200 |
- add 256Mo as default for freepbx php Memory |
201 |
- add AllowOveride All for .htaccess |
202 |
- remove httpd config to old FOP panel |
203 |
- add port 5061 for freepbx |
204 |
- smeserver-freepbx-0.1-Sme9Ast13Fpbx13-5.patch |
205 |
- configuration of amportal.conf and its mysql equivalent |
206 |
- smeserver-freepbx-0.1-Sme9Ast13Fpbx13-6.patch |
207 |
|
208 |
* Sun May 15 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.1-42.sme |
209 |
- remove FOP patches [SME: 9495] |
210 |
- deleted link to expand amportal.conf |
211 |
- smeserver-freepbx-0.1-Sme9Ast13Fpbx13-4.patch |
212 |
|
213 |
* Sun May 15 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.1-41.sme |
214 |
- remove heading of /etc/asterisk/asterisk.conf [SME: 9495] |
215 |
- smeserver-freepbx-0.1-Sme9Ast13Fpbx13-3.patch |
216 |
- bump |
217 |
|
218 |
* Sun May 15 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.1-38.sme |
219 |
- remove expand template amportal.conf [SME: 9495] |
220 |
- chown /var/lib/asterisk |
221 |
- installation configuration options |
222 |
- smeserver-freepbx-0.1-Sme9Ast13Fpbx13-2.patch |
223 |
- Requires: asterisk-sounds-core-en-ulaw asterisk-sounds-extra-en-ulaw asterisk-voicemail |
224 |
|
225 |
* Sun May 15 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.1-37.sme |
226 |
- new path to sql files [SME: 9495] |
227 |
- smeserver-freepbx-0.1-Sme9Ast13Fpbx13-1.patch |
228 |
|
229 |
* Fri May 06 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.1-36.sme |
230 |
- adapt script to fpbx13 and asterisk 13 [SME: 9495] |
231 |
- change Requires Requires: %{_libdir}/asterisk/modules/app_addon_sql_mysql.so to |
232 |
- Requires: asterisk-addons as this is the paquet providing it, and it changed name to app_mysql.so |
233 |
|
234 |
* Fri May 06 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.1-35.sme |
235 |
- adapt script to fpbx13 and asterisk 13 [SME: 9495] |
236 |
- smeserver-freepbx-0.1-Sme9Ast13Fpbx13-0.patch |
237 |
|
238 |
* Fri May 06 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.1-34.sme |
239 |
- first import to SME9 [SME: 9495] |
240 |
|
241 |
* Sun May 12 2013 JP Pialasse <tests@pialasse.com> 0.1-33.sme |
242 |
- buildarch removed in order to find the correct %{_libdir}/asterisk/modules/app_addon_sql_mysql.so |
243 |
|
244 |
* Thu Oct 20 2011 Daniel B. <daniel@firewall-services.com> 0.1-32.sme |
245 |
- Protect by locations (so other alias can be defined to protect with LL::NG for example) |
246 |
|
247 |
* Mon Oct 17 2011 Daniel B. <daniel@firewall-services.com> 0.1-31.sme |
248 |
- Add misdn.log to logrotate |
249 |
|
250 |
* Thu Oct 13 2011 Daniel B. <daniel@firewall-services.com> 0.1-30.sme |
251 |
- Change session path [SME: 6661] |
252 |
|
253 |
* Wed Jan 05 2011 Daniel B. <daniel@firewall-services.com> 0.1-29.sme |
254 |
- astdatadir is /var/lib/asterisk |
255 |
- templates for /etc/logrotate.d/asterisk |
256 |
|
257 |
* Mon Sep 20 2010 Daniel B. <daniel@firewall-services.com> 0.1-28.sme |
258 |
- Create and populate the mysql databases in mysql.init |
259 |
- Templates for /etc/asterisk/asterisk.conf |
260 |
|
261 |
* Thu Jul 15 2010 Daniel B. <daniel@firewall-services.com> [0.1-27] |
262 |
- Read ARI password from the DB (and initialize a random one) |
263 |
|
264 |
* Mon Feb 22 2010 Daniel B. <daniel@firewall-services.com> [0.1-26] |
265 |
- Remove hard-coded dependencies on asterisk and asterisk-addons14 |
266 |
Depends now on asterisk binary and app_addon_sql_mysql.so files |
267 |
(so it can work with asterisk or asterisk14) |
268 |
|
269 |
* Mon Feb 15 2010 Daniel B. <daniel@firewall-services.com> [0.1-25] |
270 |
- Remove /etc/logrotate.d/asterisk which is now included in asterisk14 |
271 |
|
272 |
* Tue Feb 09 2010 Daniel B. <daniel@firewall-services.com> [0.1-24] |
273 |
- Depends now on asterisk14 and asterisk-addons14 |
274 |
|
275 |
* Wed Jan 06 2010 Daniel B. <daniel@firewall-services.com> [0.1-23] |
276 |
- disable dynamic hints |
277 |
|
278 |
* Tue Oct 06 2009 Daniel B. <daniel@firewall-services.com> [0.1-22] |
279 |
- include /opt/freepbx/admin/functions.inc.php in freepbx-dump-astdb |
280 |
action script for FreePBX 2.6 compatibility |
281 |
|
282 |
* Tue May 19 2009 Daniel B. <daniel@firewall-services.com> [0.1-21] |
283 |
- Add CHECKREFERER=FALSE in amportal.conf to repvent error message in some |
284 |
modules (due to the ProxyPass configuration) |
285 |
|
286 |
* Tue Apr 28 2009 Daniel B. <daniel@firewall-services.com> [0.1-20] |
287 |
- Fix CDR db password in cdr_mysql.conf template |
288 |
- Use a separate service in SME db for FOP |
289 |
|
290 |
* Thu Apr 16 2009 Daniel B. <daniel@firewall-services.com> [0.1-19] |
291 |
- remove scoreboard directive from httpd-fpbx config |
292 |
- remove some modules (mod_ssl, mod_proxy) |
293 |
|
294 |
* Sat Apr 11 2009 Daniel B. <daniel@firewall-services.com> [0.1-18] |
295 |
- templatize cdr_mysql.conf [SME: 5153] |
296 |
- templatize manager.conf |
297 |
- remove freepbx-cron-scheduler.php from root crontab so only |
298 |
asterisk user runs it (prevent email error sent from cron) |
299 |
|
300 |
* Fri Mar 27 2009 Daniel B. <daniel@firewall-services.com> [0.1-17] |
301 |
- Remove obsolete /admin Alias from apache |
302 |
- Run the security script on bootsrape-console-save event |
303 |
|
304 |
* Mon Mar 23 2009 Daniel B. <daniel@firewall-services.com> [0.1-16] |
305 |
- Security Fixe: put a random password for ARI admin (this should be documented) |
306 |
|
307 |
* Thu Mar 19 2009 Daniel B. <daniel@firewall-services.com> [0.1-15] |
308 |
- Check if /opt/freepbx/admin exists (retry the install if a first one failed) |
309 |
- Remove tabs from spec |
310 |
|
311 |
* Wed Mar 18 2009 Daniel B. <daniel@firewall-services.com> [0.1-14] |
312 |
- Remove speex from dependencies |
313 |
|
314 |
* Thu Mar 12 2009 Daniel B. <daniel@firewall-services.com> [0.1-13] |
315 |
- Remove zaptel dependency, replaced with dahdi-tools and dahdi-linux |
316 |
|
317 |
* Mon Feb 23 2009 Daniel B. <daniel@firewall-services.com> [0.1-12] |
318 |
- Fix logrotate issue (send a sigusr1 signal to httpd-fpbx) |
319 |
|
320 |
* Thu Feb 12 2009 Daniel B. <daniel@firewall-services.com> [0.1-11] |
321 |
- Full support for the new DAHDI driver, droping zaptel |
322 |
|
323 |
* Mon Feb 09 2009 Daniel B. <daniel@firewall-services.com> [0.1-10] |
324 |
- add support for DAHDI channel |
325 |
|
326 |
* Mon Dec 08 2008 Daniel B. <daniel@firewall-services.com> [0.1-9] |
327 |
- move expand-templates from post-upgrade event to bootstrap-console-save |
328 |
|
329 |
* Thu Nov 27 2008 Daniel B. <daniel@firewall-services.com> [0.1-8] |
330 |
- Add support for trunk name in mail alerts |
331 |
|
332 |
* Wed Nov 26 2008 Daniel B. <daniel@firewall-services.com> [0.1-7] |
333 |
- Add a simple script to alert admin by mail on trunk errors |
334 |
|
335 |
* Thu Nov 20 2008 Daniel B. <daniel@firewall-services.com> [0.1-6] |
336 |
- Use AdminPanels props so access can be configured using |
337 |
smeserver-userpanels contrib. AdminUsers and FopUsers |
338 |
props aren't used anymore |
339 |
|
340 |
* Wed Nov 19 2008 Daniel B. <daniel@firewall-services.com> [0.1-5] |
341 |
- add logrotate default config file for asterisk's logs |
342 |
- spec cleanup |
343 |
|
344 |
* Thu Nov 13 2008 Daniel B. <daniel@firewall-services.com> [0.1-4] |
345 |
- Re-build and link to latest devtools logrotate issue |
346 |
|
347 |
* Wed Nov 05 2008 Daniel B. <daniel@firewall-services.com> [0.1-3] |
348 |
- split freepbx sources in a separate package (freepbx-src) |
349 |
- alternative genzaptelconf |
350 |
|
351 |
* Mon Oct 13 2008 Daniel B. <daniel@firewall-services.com> [0.1-2] |
352 |
- Fix fop not being displayed in admin page |
353 |
|
354 |
* Sat Sep 20 2008 Daniel B. <daniel@firewall-services.com> [0.1-1] |
355 |
- updated to 2.5.0 final |
356 |
- spec cleaning |
357 |
- templates cleaning |
358 |
- templates to update mysql informations |
359 |
|
360 |
* Mon Aug 04 2008 daniel B. <daniel@firewall-services.com> [0.1-0] |
361 |
- initial release |
362 |
|
363 |
%prep |
364 |
%setup -q -n %{name}-%{version} |
365 |
%patch0 -p1 |
366 |
%patch1 -p1 |
367 |
%patch2 -p1 |
368 |
%patch3 -p1 |
369 |
%patch4 -p1 |
370 |
%patch5 -p1 |
371 |
|
372 |
%build |
373 |
# Build symlinks |
374 |
perl createlinks |
375 |
|
376 |
%install |
377 |
rm -rf $RPM_BUILD_ROOT |
378 |
|
379 |
%{__mkdir_p} $RPM_BUILD_ROOT/var/lib/php/fpbx-session |
380 |
|
381 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
382 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
383 |
--file /usr/share/freepbx/scripts/uninstall.sh 'attr(0750,root,root)' \ |
384 |
--file /usr/share/freepbx/scripts/restore-astdb.php 'attr(0750,root,root)' \ |
385 |
--dir /var/service/httpd-fpbx 'attr(01755,root,root)' \ |
386 |
--dir /var/service/httpd-fpbx/supervise 'attr(0700,root,root)' \ |
387 |
--dir /var/service/httpd-fpbx/log 'attr(0755,root,root)' \ |
388 |
--file /var/service/httpd-fpbx/log/run 'attr(0755,root,root)' \ |
389 |
--dir /var/service/httpd-fpbx/log/supervise 'attr(0700,root,root)' \ |
390 |
--file /var/lib/asterisk/bin/genzaptelconf 'attr(0750,root,root)' \ |
391 |
--file /usr/share/asterisk/agi-bin/trunk_alert_mail.agi 'attr(0750,asterisk,asterisk)' \ |
392 |
--file /etc/logrotate.d/asterisk 'config(noreplace)' \ |
393 |
--dir /var/lib/php/fpbx-session 'attr(0770,root,asterisk)' \ |
394 |
--file /usr/sbin/safe_asterisk 'attr(0755,root,root)' \ |
395 |
--dir /var/log/php/freepbx 'attr(0770,root,asterisk)' \ |
396 |
--dir /var/lib/php/freepbx/sessions 'attr(0770,root,asterisk)' \ |
397 |
--dir /var/lib/php/freepbx/temp 'attr(0770,root,asterisk)' \ |
398 |
|grep -v '/var/lib/asterisk$'| grep -v '/etc/asterisk$' \ |
399 |
> %{name}-%{version}-%{release}-filelist |
400 |
|
401 |
%clean |
402 |
rm -rf $RPM_BUILD_ROOT |
403 |
|
404 |
%files -f %{name}-%{version}-%{release}-filelist |
405 |
%defattr(-,root,root) |
406 |
|
407 |
|
408 |
%post |
409 |
|
410 |
#bug 9744, restore tmp permissions |
411 |
if [ `stat -c %U /tmp` == "asterisk" ]; then |
412 |
chmod o+rwxt /tmp/ |
413 |
chown root:root /tmp/ |
414 |
fi |
415 |
|
416 |
%preun |
417 |
if [ $1 = 0 ] ; then |
418 |
/usr/bin/systemctl stop freepbx >& /dev/null || : |
419 |
fi |
420 |
true |
421 |
%postun |
422 |
if [ $1 = 0 ] ; then |
423 |
#remove cron for asterisk on uninstallation to avoid noise |
424 |
/usr/bin/crontab -u asterisk -r >& /dev/null || : |
425 |
fi |
426 |
true |
427 |
|
428 |
|
429 |
|