1 |
michel |
1.1 |
Summary: Package to integrate GeneWeb (V6) into SME Server |
2 |
|
|
%define name smeserver-geneweb |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 2.3.0 |
5 |
michel |
1.2 |
%define release 2 |
6 |
michel |
1.1 |
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
License: GPL |
9 |
|
|
Group: Applications/Internet |
10 |
|
|
Source: %{name}-%{version}.tar.xz |
11 |
michel |
1.2 |
Patch0: %{name}-%{version}-init_v10_systemd.patch |
12 |
|
|
Patch1: %{name}-%{version}-to_smanager.patch |
13 |
michel |
1.1 |
|
14 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
15 |
|
|
BuildArchitectures: noarch |
16 |
|
|
Requires: geneweb >= 6.08 |
17 |
|
|
Requires: smeserver-release >= 10.0 |
18 |
|
|
Requires: e-smith-formmagick >= 2.4.0-1 |
19 |
|
|
BuildRequires: e-smith-devtools |
20 |
michel |
1.2 |
AutoReqProv: no |
21 |
michel |
1.1 |
|
22 |
|
|
%description |
23 |
|
|
This RPM must be installed after the geneweb*.el6.sme package |
24 |
|
|
to complete the integration for SME Server. |
25 |
|
|
|
26 |
|
|
%changelog |
27 |
michel |
1.2 |
* Mon Mar 15 2021 Michel Begue <mab974@gmail.com> 2.3.0-2.sme |
28 |
|
|
- change geneweb & gwsetup to systemd services |
29 |
|
|
- add smeserver-geneweb-update event |
30 |
|
|
- add template and controller for smanager |
31 |
|
|
|
32 |
michel |
1.1 |
* Thu Nov 05 2020 Michel Begue <mab974@gmail.com> 2.3.0-1.sme |
33 |
|
|
- first import to sme 10 for geneweb v6.08 |
34 |
|
|
|
35 |
|
|
* Thu Jul 30 2020 SME Translation Server <translations@contribs.org> 2.1.0-5.sme |
36 |
|
|
- apply locale 2020-07-30 patch |
37 |
|
|
|
38 |
|
|
* Sat Jul 11 2020 Michel Begue <mab974@gmail.com> 2.1.0-4.sme |
39 |
|
|
- geneweb and gwsetup services thru proxypass [SME: 10930] |
40 |
|
|
|
41 |
|
|
* Sat Dec 07 2019 SME Translation Server <translations@contribs.org> 2.1.0-2.sme |
42 |
|
|
- apply locale 2019-12-07 patch |
43 |
|
|
|
44 |
|
|
* Wed Apr 03 2019 Michel Begue <mab974@gmail.com> 2.1-1.sme |
45 |
|
|
- first import in sme9 for geneweb v6.08 |
46 |
|
|
- geneweb service not started [SME: 6371] |
47 |
|
|
- Add "Base directory" input in panel console. |
48 |
|
|
- perms corrected in templates.metadata |
49 |
|
|
- normalize template and .spec |
50 |
|
|
|
51 |
|
|
%prep |
52 |
|
|
|
53 |
|
|
rm -rf $RPM_BUILD_ROOT |
54 |
|
|
|
55 |
|
|
%setup |
56 |
michel |
1.2 |
%patch0 -p1 |
57 |
|
|
%patch1 -p1 |
58 |
michel |
1.1 |
|
59 |
|
|
%build |
60 |
|
|
perl createlinks |
61 |
|
|
|
62 |
|
|
LEXICONS=$(find root/etc/e-smith/{locale/,web/functions/} -type f ) |
63 |
|
|
for lexicon in $LEXICONS |
64 |
|
|
do |
65 |
|
|
/sbin/e-smith/validate-lexicon $lexicon |
66 |
|
|
done |
67 |
|
|
|
68 |
|
|
%install |
69 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
70 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
71 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
72 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
73 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
74 |
|
|
|
75 |
|
|
%files -f %{name}-%{version}-filelist |
76 |
|
|
|
77 |
|
|
%defattr(-,root,root) |
78 |
michel |
1.2 |
%attr(755, root, root) /usr/lib/systemd/systemd-geneweb |
79 |
|
|
%attr(755, root, root) /usr/lib/systemd/systemd-gwsetup |
80 |
michel |
1.1 |
|
81 |
|
|
|
82 |
|
|
%clean |
83 |
|
|
rm -rf $RPM_BUILD_ROOT |
84 |
|
|
|
85 |
|
|
%pre |
86 |
|
|
|
87 |
|
|
%post |
88 |
|
|
mkdir -p /var/log/geneweb |
89 |
michel |
1.2 |
chown geneweb:geneweb /var/log/geneweb |
90 |
michel |
1.1 |
mkdir -p /var/log/gwsetup |
91 |
michel |
1.2 |
chown geneweb:geneweb /var/log/gwsetup |
92 |
michel |
1.1 |
|
93 |
|
|
%preun |
94 |
|
|
/sbin/e-smith/db configuration setprop geneweb status disabled |
95 |
|
|
/sbin/e-smith/db configuration setprop gwsetup status disabled |
96 |
michel |
1.2 |
/usr/bin/systemctl stop geneweb gwsetup |
97 |
michel |
1.1 |
|
98 |
|
|
%postun |