1 |
michel |
1.1 |
Summary: Package to integrate GeneWeb (V6) into SME Server |
2 |
michel |
1.3 |
|
3 |
michel |
1.1 |
%define name smeserver-geneweb |
4 |
|
|
Name: %{name} |
5 |
|
|
%define version 2.3.0 |
6 |
terryfage |
1.4 |
%define release 4 |
7 |
michel |
1.1 |
Version: %{version} |
8 |
|
|
Release: %{release}%{?dist} |
9 |
|
|
License: GPL |
10 |
|
|
Group: Applications/Internet |
11 |
|
|
Source: %{name}-%{version}.tar.xz |
12 |
michel |
1.2 |
Patch0: %{name}-%{version}-init_v10_systemd.patch |
13 |
|
|
Patch1: %{name}-%{version}-to_smanager.patch |
14 |
michel |
1.3 |
Patch2: %{name}-%{version}-TcpPort.patch |
15 |
terryfage |
1.4 |
Patch3: smeserver-geneweb-2.3.0-locale-2021-08-22.patch |
16 |
michel |
1.1 |
|
17 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
18 |
|
|
BuildArchitectures: noarch |
19 |
|
|
Requires: geneweb >= 6.08 |
20 |
|
|
Requires: smeserver-release >= 10.0 |
21 |
|
|
Requires: e-smith-formmagick >= 2.4.0-1 |
22 |
|
|
BuildRequires: e-smith-devtools |
23 |
michel |
1.2 |
AutoReqProv: no |
24 |
michel |
1.1 |
|
25 |
|
|
%description |
26 |
michel |
1.3 |
This RPM must be installed after the geneweb package |
27 |
michel |
1.1 |
to complete the integration for SME Server. |
28 |
|
|
|
29 |
|
|
%prep |
30 |
|
|
|
31 |
|
|
rm -rf $RPM_BUILD_ROOT |
32 |
|
|
|
33 |
|
|
%setup |
34 |
michel |
1.2 |
%patch0 -p1 |
35 |
|
|
%patch1 -p1 |
36 |
michel |
1.3 |
%patch2 -p1 |
37 |
terryfage |
1.4 |
%patch3 -p1 |
38 |
michel |
1.1 |
|
39 |
|
|
%build |
40 |
|
|
perl createlinks |
41 |
|
|
|
42 |
|
|
LEXICONS=$(find root/etc/e-smith/{locale/,web/functions/} -type f ) |
43 |
|
|
for lexicon in $LEXICONS |
44 |
|
|
do |
45 |
|
|
/sbin/e-smith/validate-lexicon $lexicon |
46 |
|
|
done |
47 |
|
|
|
48 |
|
|
%install |
49 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
50 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
51 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
52 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
53 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
54 |
|
|
|
55 |
|
|
%files -f %{name}-%{version}-filelist |
56 |
|
|
|
57 |
|
|
%defattr(-,root,root) |
58 |
michel |
1.2 |
%attr(755, root, root) /usr/lib/systemd/systemd-geneweb |
59 |
|
|
%attr(755, root, root) /usr/lib/systemd/systemd-gwsetup |
60 |
michel |
1.1 |
|
61 |
|
|
%clean |
62 |
|
|
rm -rf $RPM_BUILD_ROOT |
63 |
|
|
|
64 |
|
|
%pre |
65 |
|
|
|
66 |
|
|
%post |
67 |
|
|
mkdir -p /var/log/geneweb |
68 |
michel |
1.2 |
chown geneweb:geneweb /var/log/geneweb |
69 |
michel |
1.1 |
mkdir -p /var/log/gwsetup |
70 |
michel |
1.2 |
chown geneweb:geneweb /var/log/gwsetup |
71 |
michel |
1.1 |
|
72 |
|
|
%preun |
73 |
|
|
/sbin/e-smith/db configuration setprop geneweb status disabled |
74 |
|
|
/sbin/e-smith/db configuration setprop gwsetup status disabled |
75 |
michel |
1.2 |
/usr/bin/systemctl stop geneweb gwsetup |
76 |
michel |
1.1 |
|
77 |
|
|
%postun |
78 |
michel |
1.3 |
|
79 |
|
|
%changelog |
80 |
terryfage |
1.4 |
* Sun Aug 22 2021 Terry Fage <terry.fage@gmail.com> 2.3.0-4.sme |
81 |
|
|
- apply locale 2021-08-22 patch |
82 |
|
|
|
83 |
michel |
1.3 |
* Tue Mar 23 2021 Michel Begue <mab974@gmail.com> 2.3.0-3.sme |
84 |
|
|
- change TCPPort attributes to avoid filtering effect [SME: 10930] |
85 |
|
|
- move changelog to the bottom of spec |
86 |
|
|
- readd changelog from contribs9 |
87 |
|
|
|
88 |
|
|
* Mon Mar 15 2021 Michel Begue <mab974@gmail.com> 2.3.0-2.sme |
89 |
|
|
- change geneweb & gwsetup to systemd services |
90 |
|
|
- add smeserver-geneweb-update event |
91 |
|
|
- add template and controller for smanager |
92 |
|
|
|
93 |
|
|
* Thu Nov 05 2020 Michel Begue <mab974@gmail.com> 2.3.0-1.sme |
94 |
|
|
- first import to sme 10 for geneweb v6.08 |
95 |
|
|
|
96 |
|
|
* Thu Jul 30 2020 SME Translation Server <translations@contribs.org> 2.1.0-5.sme |
97 |
|
|
- apply locale 2020-07-30 patch |
98 |
|
|
|
99 |
|
|
* Sat Jul 11 2020 Michel Begue <mab974@gmail.com> 2.1.0-4.sme |
100 |
|
|
- geneweb and gwsetup services thru proxypass [SME: 10930] |
101 |
|
|
|
102 |
|
|
* Sat Dec 07 2019 SME Translation Server <translations@contribs.org> 2.1.0-2.sme |
103 |
|
|
- apply locale 2019-12-07 patch |
104 |
|
|
|
105 |
|
|
* Wed Apr 03 2019 Michel Begue <mab974@gmail.com> 2.1-1.sme |
106 |
|
|
- first import in sme9 for geneweb v6.08 |
107 |
|
|
- geneweb service not started [SME: 6371] |
108 |
|
|
- Add "Base directory" input in panel console. |
109 |
|
|
- perms corrected in templates.metadata |
110 |
|
|
- normalize template and .spec |