1 |
michel |
1.1 |
Summary: Package to integrate GeneWeb (V6) into SME Server |
2 |
michel |
1.3 |
|
3 |
michel |
1.1 |
%define name smeserver-geneweb |
4 |
|
|
Name: %{name} |
5 |
|
|
%define version 2.3.0 |
6 |
brianr |
1.7 |
%define release 7 |
7 |
michel |
1.1 |
Version: %{version} |
8 |
|
|
Release: %{release}%{?dist} |
9 |
|
|
License: GPL |
10 |
|
|
Group: Applications/Internet |
11 |
|
|
Source: %{name}-%{version}.tar.xz |
12 |
michel |
1.2 |
Patch0: %{name}-%{version}-init_v10_systemd.patch |
13 |
|
|
Patch1: %{name}-%{version}-to_smanager.patch |
14 |
michel |
1.3 |
Patch2: %{name}-%{version}-TcpPort.patch |
15 |
terryfage |
1.4 |
Patch3: smeserver-geneweb-2.3.0-locale-2021-08-22.patch |
16 |
brianr |
1.5 |
Patch4: smeserver-geneweb-2.3.0-Add-class-to-div-for-AdminLTE.patch |
17 |
michel |
1.6 |
Patch5: smeserver-geneweb-2.3.0-migrate-logs-users-bz12047_httpd-bz12074_backup.patch |
18 |
michel |
1.1 |
|
19 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
20 |
|
|
BuildArchitectures: noarch |
21 |
|
|
Requires: geneweb >= 6.08 |
22 |
|
|
Requires: smeserver-release >= 10.0 |
23 |
|
|
Requires: e-smith-formmagick >= 2.4.0-1 |
24 |
|
|
BuildRequires: e-smith-devtools |
25 |
michel |
1.6 |
Requires: e-smith-apache >= 2.6.0-19 |
26 |
|
|
Requires: smeserver-php >= 3.0.0-43 |
27 |
michel |
1.2 |
AutoReqProv: no |
28 |
michel |
1.1 |
|
29 |
|
|
%description |
30 |
michel |
1.3 |
This RPM must be installed after the geneweb package |
31 |
michel |
1.1 |
to complete the integration for SME Server. |
32 |
|
|
|
33 |
|
|
%prep |
34 |
|
|
|
35 |
|
|
rm -rf $RPM_BUILD_ROOT |
36 |
|
|
|
37 |
|
|
%setup |
38 |
michel |
1.2 |
%patch0 -p1 |
39 |
|
|
%patch1 -p1 |
40 |
michel |
1.3 |
%patch2 -p1 |
41 |
terryfage |
1.4 |
%patch3 -p1 |
42 |
brianr |
1.5 |
%patch4 -p1 |
43 |
michel |
1.6 |
%patch5 -p1 |
44 |
michel |
1.1 |
|
45 |
|
|
%build |
46 |
|
|
perl createlinks |
47 |
|
|
|
48 |
|
|
LEXICONS=$(find root/etc/e-smith/{locale/,web/functions/} -type f ) |
49 |
|
|
for lexicon in $LEXICONS |
50 |
|
|
do |
51 |
|
|
/sbin/e-smith/validate-lexicon $lexicon |
52 |
|
|
done |
53 |
|
|
|
54 |
|
|
%install |
55 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
56 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
57 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
58 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
59 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
60 |
|
|
|
61 |
|
|
%files -f %{name}-%{version}-filelist |
62 |
|
|
|
63 |
|
|
%defattr(-,root,root) |
64 |
michel |
1.2 |
%attr(755, root, root) /usr/lib/systemd/systemd-geneweb |
65 |
|
|
%attr(755, root, root) /usr/lib/systemd/systemd-gwsetup |
66 |
michel |
1.1 |
|
67 |
|
|
%clean |
68 |
|
|
rm -rf $RPM_BUILD_ROOT |
69 |
|
|
|
70 |
|
|
%pre |
71 |
|
|
|
72 |
|
|
%post |
73 |
|
|
|
74 |
|
|
%preun |
75 |
|
|
/sbin/e-smith/db configuration setprop geneweb status disabled |
76 |
|
|
/sbin/e-smith/db configuration setprop gwsetup status disabled |
77 |
michel |
1.2 |
/usr/bin/systemctl stop geneweb gwsetup |
78 |
michel |
1.1 |
|
79 |
|
|
%postun |
80 |
michel |
1.3 |
|
81 |
|
|
%changelog |
82 |
brianr |
1.7 |
* Sat Jul 30 2022 Brian Read <brianr@bjsystems.co.uk> 2.3.0-7.sme |
83 |
|
|
- Re-build and link to latest devtools [SME: 11997] |
84 |
|
|
|
85 |
michel |
1.6 |
* Thu Jul 14 2022 Michel Begue <mab974@misouk.com> 2.3.0-6.sme |
86 |
brianr |
1.7 |
- Re-build and link to latest devtools migrate fragment error [SME: 11610] |
87 |
michel |
1.6 |
- back to standard log files and fix log files not fed |
88 |
|
|
- run 2 services with user geneweb |
89 |
|
|
- add geneweb to backup list [SME: 12074] |
90 |
|
|
- update to httpd 2.4 syntax [SME: 12047] |
91 |
|
|
|
92 |
brianr |
1.5 |
* Fri Jan 07 2022 Brian Read <brianr@bjsystems.co.uk> 2.3.0-5.sme |
93 |
|
|
- Add-class-to-div-for-AdminLTE [SME: 11838] |
94 |
|
|
|
95 |
terryfage |
1.4 |
* Sun Aug 22 2021 Terry Fage <terry.fage@gmail.com> 2.3.0-4.sme |
96 |
|
|
- apply locale 2021-08-22 patch |
97 |
|
|
|
98 |
michel |
1.3 |
* Tue Mar 23 2021 Michel Begue <mab974@gmail.com> 2.3.0-3.sme |
99 |
|
|
- change TCPPort attributes to avoid filtering effect [SME: 10930] |
100 |
|
|
- move changelog to the bottom of spec |
101 |
|
|
- readd changelog from contribs9 |
102 |
|
|
|
103 |
|
|
* Mon Mar 15 2021 Michel Begue <mab974@gmail.com> 2.3.0-2.sme |
104 |
|
|
- change geneweb & gwsetup to systemd services |
105 |
|
|
- add smeserver-geneweb-update event |
106 |
|
|
- add template and controller for smanager |
107 |
|
|
|
108 |
|
|
* Thu Nov 05 2020 Michel Begue <mab974@gmail.com> 2.3.0-1.sme |
109 |
|
|
- first import to sme 10 for geneweb v6.08 |
110 |
|
|
|
111 |
|
|
* Thu Jul 30 2020 SME Translation Server <translations@contribs.org> 2.1.0-5.sme |
112 |
|
|
- apply locale 2020-07-30 patch |
113 |
|
|
|
114 |
|
|
* Sat Jul 11 2020 Michel Begue <mab974@gmail.com> 2.1.0-4.sme |
115 |
|
|
- geneweb and gwsetup services thru proxypass [SME: 10930] |
116 |
|
|
|
117 |
|
|
* Sat Dec 07 2019 SME Translation Server <translations@contribs.org> 2.1.0-2.sme |
118 |
|
|
- apply locale 2019-12-07 patch |
119 |
|
|
|
120 |
|
|
* Wed Apr 03 2019 Michel Begue <mab974@gmail.com> 2.1-1.sme |
121 |
|
|
- first import in sme9 for geneweb v6.08 |
122 |
|
|
- geneweb service not started [SME: 6371] |
123 |
|
|
- Add "Base directory" input in panel console. |
124 |
|
|
- perms corrected in templates.metadata |
125 |
|
|
- normalize template and .spec |