1 |
michel |
1.1 |
Summary: Package to integrate GeneWeb (V6) into SME Server |
2 |
michel |
1.3 |
|
3 |
michel |
1.1 |
%define name smeserver-geneweb |
4 |
|
|
Name: %{name} |
5 |
|
|
%define version 2.3.0 |
6 |
brianr |
1.8 |
%define release 8 |
7 |
michel |
1.1 |
Version: %{version} |
8 |
|
|
Release: %{release}%{?dist} |
9 |
|
|
License: GPL |
10 |
|
|
Group: Applications/Internet |
11 |
|
|
Source: %{name}-%{version}.tar.xz |
12 |
michel |
1.2 |
Patch0: %{name}-%{version}-init_v10_systemd.patch |
13 |
|
|
Patch1: %{name}-%{version}-to_smanager.patch |
14 |
michel |
1.3 |
Patch2: %{name}-%{version}-TcpPort.patch |
15 |
terryfage |
1.4 |
Patch3: smeserver-geneweb-2.3.0-locale-2021-08-22.patch |
16 |
brianr |
1.5 |
Patch4: smeserver-geneweb-2.3.0-Add-class-to-div-for-AdminLTE.patch |
17 |
michel |
1.6 |
Patch5: smeserver-geneweb-2.3.0-migrate-logs-users-bz12047_httpd-bz12074_backup.patch |
18 |
brianr |
1.8 |
Patch6: smeserver-geneweb-2.3.0-Alter-menu-category-for-new-arrangement.patch |
19 |
michel |
1.1 |
|
20 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
21 |
|
|
BuildArchitectures: noarch |
22 |
|
|
Requires: geneweb >= 6.08 |
23 |
|
|
Requires: smeserver-release >= 10.0 |
24 |
|
|
Requires: e-smith-formmagick >= 2.4.0-1 |
25 |
|
|
BuildRequires: e-smith-devtools |
26 |
michel |
1.6 |
Requires: e-smith-apache >= 2.6.0-19 |
27 |
|
|
Requires: smeserver-php >= 3.0.0-43 |
28 |
michel |
1.2 |
AutoReqProv: no |
29 |
michel |
1.1 |
|
30 |
|
|
%description |
31 |
michel |
1.3 |
This RPM must be installed after the geneweb package |
32 |
michel |
1.1 |
to complete the integration for SME Server. |
33 |
|
|
|
34 |
|
|
%prep |
35 |
|
|
|
36 |
|
|
rm -rf $RPM_BUILD_ROOT |
37 |
|
|
|
38 |
|
|
%setup |
39 |
michel |
1.2 |
%patch0 -p1 |
40 |
|
|
%patch1 -p1 |
41 |
michel |
1.3 |
%patch2 -p1 |
42 |
terryfage |
1.4 |
%patch3 -p1 |
43 |
brianr |
1.5 |
%patch4 -p1 |
44 |
michel |
1.6 |
%patch5 -p1 |
45 |
brianr |
1.8 |
%patch6 -p1 |
46 |
michel |
1.1 |
|
47 |
|
|
%build |
48 |
|
|
perl createlinks |
49 |
|
|
|
50 |
|
|
LEXICONS=$(find root/etc/e-smith/{locale/,web/functions/} -type f ) |
51 |
|
|
for lexicon in $LEXICONS |
52 |
|
|
do |
53 |
|
|
/sbin/e-smith/validate-lexicon $lexicon |
54 |
|
|
done |
55 |
|
|
|
56 |
|
|
%install |
57 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
58 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
59 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
60 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
61 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
62 |
|
|
|
63 |
|
|
%files -f %{name}-%{version}-filelist |
64 |
|
|
|
65 |
|
|
%defattr(-,root,root) |
66 |
michel |
1.2 |
%attr(755, root, root) /usr/lib/systemd/systemd-geneweb |
67 |
|
|
%attr(755, root, root) /usr/lib/systemd/systemd-gwsetup |
68 |
michel |
1.1 |
|
69 |
|
|
%clean |
70 |
|
|
rm -rf $RPM_BUILD_ROOT |
71 |
|
|
|
72 |
|
|
%pre |
73 |
|
|
|
74 |
|
|
%post |
75 |
|
|
|
76 |
brianr |
1.8 |
if (systemctl list-unit-files |grep smanager) then |
77 |
|
|
echo "Smanager restart in spec file" |
78 |
|
|
/sbin/e-smith/signal-event smanager-refresh; |
79 |
|
|
fi |
80 |
|
|
|
81 |
michel |
1.1 |
%preun |
82 |
|
|
/sbin/e-smith/db configuration setprop geneweb status disabled |
83 |
|
|
/sbin/e-smith/db configuration setprop gwsetup status disabled |
84 |
michel |
1.2 |
/usr/bin/systemctl stop geneweb gwsetup |
85 |
michel |
1.1 |
|
86 |
|
|
%postun |
87 |
michel |
1.3 |
|
88 |
|
|
%changelog |
89 |
brianr |
1.8 |
* Sat Mar 02 2024 Brian Read <brianr@koozali.org> 2.3.0-8.sme |
90 |
|
|
- Edit SM2 Menu entry to conform to new arrangements [SME: 12493] |
91 |
|
|
|
92 |
brianr |
1.7 |
* Sat Jul 30 2022 Brian Read <brianr@bjsystems.co.uk> 2.3.0-7.sme |
93 |
|
|
- Re-build and link to latest devtools [SME: 11997] |
94 |
|
|
|
95 |
michel |
1.6 |
* Thu Jul 14 2022 Michel Begue <mab974@misouk.com> 2.3.0-6.sme |
96 |
brianr |
1.7 |
- Re-build and link to latest devtools migrate fragment error [SME: 11610] |
97 |
michel |
1.6 |
- back to standard log files and fix log files not fed |
98 |
|
|
- run 2 services with user geneweb |
99 |
|
|
- add geneweb to backup list [SME: 12074] |
100 |
|
|
- update to httpd 2.4 syntax [SME: 12047] |
101 |
|
|
|
102 |
brianr |
1.5 |
* Fri Jan 07 2022 Brian Read <brianr@bjsystems.co.uk> 2.3.0-5.sme |
103 |
|
|
- Add-class-to-div-for-AdminLTE [SME: 11838] |
104 |
|
|
|
105 |
terryfage |
1.4 |
* Sun Aug 22 2021 Terry Fage <terry.fage@gmail.com> 2.3.0-4.sme |
106 |
|
|
- apply locale 2021-08-22 patch |
107 |
|
|
|
108 |
michel |
1.3 |
* Tue Mar 23 2021 Michel Begue <mab974@gmail.com> 2.3.0-3.sme |
109 |
|
|
- change TCPPort attributes to avoid filtering effect [SME: 10930] |
110 |
|
|
- move changelog to the bottom of spec |
111 |
|
|
- readd changelog from contribs9 |
112 |
|
|
|
113 |
|
|
* Mon Mar 15 2021 Michel Begue <mab974@gmail.com> 2.3.0-2.sme |
114 |
|
|
- change geneweb & gwsetup to systemd services |
115 |
|
|
- add smeserver-geneweb-update event |
116 |
|
|
- add template and controller for smanager |
117 |
|
|
|
118 |
|
|
* Thu Nov 05 2020 Michel Begue <mab974@gmail.com> 2.3.0-1.sme |
119 |
|
|
- first import to sme 10 for geneweb v6.08 |
120 |
|
|
|
121 |
|
|
* Thu Jul 30 2020 SME Translation Server <translations@contribs.org> 2.1.0-5.sme |
122 |
|
|
- apply locale 2020-07-30 patch |
123 |
|
|
|
124 |
|
|
* Sat Jul 11 2020 Michel Begue <mab974@gmail.com> 2.1.0-4.sme |
125 |
|
|
- geneweb and gwsetup services thru proxypass [SME: 10930] |
126 |
|
|
|
127 |
|
|
* Sat Dec 07 2019 SME Translation Server <translations@contribs.org> 2.1.0-2.sme |
128 |
|
|
- apply locale 2019-12-07 patch |
129 |
|
|
|
130 |
|
|
* Wed Apr 03 2019 Michel Begue <mab974@gmail.com> 2.1-1.sme |
131 |
|
|
- first import in sme9 for geneweb v6.08 |
132 |
|
|
- geneweb service not started [SME: 6371] |
133 |
|
|
- Add "Base directory" input in panel console. |
134 |
|
|
- perms corrected in templates.metadata |
135 |
|
|
- normalize template and .spec |