1 |
michel |
1.1 |
Summary: Package to integrate GeneWeb (V6) into SME Server |
2 |
michel |
1.3 |
|
3 |
michel |
1.1 |
%define name smeserver-geneweb |
4 |
|
|
Name: %{name} |
5 |
|
|
%define version 2.3.0 |
6 |
terryfage |
1.9 |
%define release 9 |
7 |
michel |
1.1 |
Version: %{version} |
8 |
|
|
Release: %{release}%{?dist} |
9 |
|
|
License: GPL |
10 |
|
|
Group: Applications/Internet |
11 |
|
|
Source: %{name}-%{version}.tar.xz |
12 |
michel |
1.2 |
Patch0: %{name}-%{version}-init_v10_systemd.patch |
13 |
|
|
Patch1: %{name}-%{version}-to_smanager.patch |
14 |
michel |
1.3 |
Patch2: %{name}-%{version}-TcpPort.patch |
15 |
terryfage |
1.4 |
Patch3: smeserver-geneweb-2.3.0-locale-2021-08-22.patch |
16 |
brianr |
1.5 |
Patch4: smeserver-geneweb-2.3.0-Add-class-to-div-for-AdminLTE.patch |
17 |
michel |
1.6 |
Patch5: smeserver-geneweb-2.3.0-migrate-logs-users-bz12047_httpd-bz12074_backup.patch |
18 |
brianr |
1.8 |
Patch6: smeserver-geneweb-2.3.0-Alter-menu-category-for-new-arrangement.patch |
19 |
terryfage |
1.9 |
Patch7: smeserver-geneweb-2.3.0-locale-2024-09-05.patch |
20 |
michel |
1.1 |
|
21 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
22 |
|
|
BuildArchitectures: noarch |
23 |
|
|
Requires: geneweb >= 6.08 |
24 |
|
|
Requires: smeserver-release >= 10.0 |
25 |
|
|
Requires: e-smith-formmagick >= 2.4.0-1 |
26 |
|
|
BuildRequires: e-smith-devtools |
27 |
michel |
1.6 |
Requires: e-smith-apache >= 2.6.0-19 |
28 |
|
|
Requires: smeserver-php >= 3.0.0-43 |
29 |
michel |
1.2 |
AutoReqProv: no |
30 |
michel |
1.1 |
|
31 |
|
|
%description |
32 |
michel |
1.3 |
This RPM must be installed after the geneweb package |
33 |
michel |
1.1 |
to complete the integration for SME Server. |
34 |
|
|
|
35 |
|
|
%prep |
36 |
|
|
|
37 |
|
|
rm -rf $RPM_BUILD_ROOT |
38 |
|
|
|
39 |
|
|
%setup |
40 |
michel |
1.2 |
%patch0 -p1 |
41 |
|
|
%patch1 -p1 |
42 |
michel |
1.3 |
%patch2 -p1 |
43 |
terryfage |
1.4 |
%patch3 -p1 |
44 |
brianr |
1.5 |
%patch4 -p1 |
45 |
michel |
1.6 |
%patch5 -p1 |
46 |
brianr |
1.8 |
%patch6 -p1 |
47 |
terryfage |
1.9 |
%patch7 -p1 |
48 |
michel |
1.1 |
|
49 |
|
|
%build |
50 |
|
|
perl createlinks |
51 |
|
|
|
52 |
|
|
LEXICONS=$(find root/etc/e-smith/{locale/,web/functions/} -type f ) |
53 |
|
|
for lexicon in $LEXICONS |
54 |
|
|
do |
55 |
|
|
/sbin/e-smith/validate-lexicon $lexicon |
56 |
|
|
done |
57 |
|
|
|
58 |
|
|
%install |
59 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
60 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
61 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
62 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
63 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
64 |
|
|
|
65 |
|
|
%files -f %{name}-%{version}-filelist |
66 |
|
|
|
67 |
|
|
%defattr(-,root,root) |
68 |
michel |
1.2 |
%attr(755, root, root) /usr/lib/systemd/systemd-geneweb |
69 |
|
|
%attr(755, root, root) /usr/lib/systemd/systemd-gwsetup |
70 |
michel |
1.1 |
|
71 |
|
|
%clean |
72 |
|
|
rm -rf $RPM_BUILD_ROOT |
73 |
|
|
|
74 |
|
|
%pre |
75 |
|
|
|
76 |
|
|
%post |
77 |
|
|
|
78 |
brianr |
1.8 |
if (systemctl list-unit-files |grep smanager) then |
79 |
|
|
echo "Smanager restart in spec file" |
80 |
|
|
/sbin/e-smith/signal-event smanager-refresh; |
81 |
|
|
fi |
82 |
|
|
|
83 |
michel |
1.1 |
%preun |
84 |
|
|
/sbin/e-smith/db configuration setprop geneweb status disabled |
85 |
|
|
/sbin/e-smith/db configuration setprop gwsetup status disabled |
86 |
michel |
1.2 |
/usr/bin/systemctl stop geneweb gwsetup |
87 |
michel |
1.1 |
|
88 |
|
|
%postun |
89 |
michel |
1.3 |
|
90 |
|
|
%changelog |
91 |
terryfage |
1.9 |
* Thu Sep 05 2024 Terry Fage <terry@fage.id.au> 2.3.0-9.sme |
92 |
|
|
- apply locale 2.3.0-locale-2024-09-05.patch |
93 |
|
|
|
94 |
brianr |
1.8 |
* Sat Mar 02 2024 Brian Read <brianr@koozali.org> 2.3.0-8.sme |
95 |
|
|
- Edit SM2 Menu entry to conform to new arrangements [SME: 12493] |
96 |
|
|
|
97 |
brianr |
1.7 |
* Sat Jul 30 2022 Brian Read <brianr@bjsystems.co.uk> 2.3.0-7.sme |
98 |
|
|
- Re-build and link to latest devtools [SME: 11997] |
99 |
|
|
|
100 |
michel |
1.6 |
* Thu Jul 14 2022 Michel Begue <mab974@misouk.com> 2.3.0-6.sme |
101 |
brianr |
1.7 |
- Re-build and link to latest devtools migrate fragment error [SME: 11610] |
102 |
michel |
1.6 |
- back to standard log files and fix log files not fed |
103 |
|
|
- run 2 services with user geneweb |
104 |
|
|
- add geneweb to backup list [SME: 12074] |
105 |
|
|
- update to httpd 2.4 syntax [SME: 12047] |
106 |
|
|
|
107 |
brianr |
1.5 |
* Fri Jan 07 2022 Brian Read <brianr@bjsystems.co.uk> 2.3.0-5.sme |
108 |
|
|
- Add-class-to-div-for-AdminLTE [SME: 11838] |
109 |
|
|
|
110 |
terryfage |
1.4 |
* Sun Aug 22 2021 Terry Fage <terry.fage@gmail.com> 2.3.0-4.sme |
111 |
|
|
- apply locale 2021-08-22 patch |
112 |
|
|
|
113 |
michel |
1.3 |
* Tue Mar 23 2021 Michel Begue <mab974@gmail.com> 2.3.0-3.sme |
114 |
|
|
- change TCPPort attributes to avoid filtering effect [SME: 10930] |
115 |
|
|
- move changelog to the bottom of spec |
116 |
|
|
- readd changelog from contribs9 |
117 |
|
|
|
118 |
|
|
* Mon Mar 15 2021 Michel Begue <mab974@gmail.com> 2.3.0-2.sme |
119 |
|
|
- change geneweb & gwsetup to systemd services |
120 |
|
|
- add smeserver-geneweb-update event |
121 |
|
|
- add template and controller for smanager |
122 |
|
|
|
123 |
|
|
* Thu Nov 05 2020 Michel Begue <mab974@gmail.com> 2.3.0-1.sme |
124 |
|
|
- first import to sme 10 for geneweb v6.08 |
125 |
|
|
|
126 |
|
|
* Thu Jul 30 2020 SME Translation Server <translations@contribs.org> 2.1.0-5.sme |
127 |
|
|
- apply locale 2020-07-30 patch |
128 |
|
|
|
129 |
|
|
* Sat Jul 11 2020 Michel Begue <mab974@gmail.com> 2.1.0-4.sme |
130 |
|
|
- geneweb and gwsetup services thru proxypass [SME: 10930] |
131 |
|
|
|
132 |
|
|
* Sat Dec 07 2019 SME Translation Server <translations@contribs.org> 2.1.0-2.sme |
133 |
|
|
- apply locale 2019-12-07 patch |
134 |
|
|
|
135 |
|
|
* Wed Apr 03 2019 Michel Begue <mab974@gmail.com> 2.1-1.sme |
136 |
|
|
- first import in sme9 for geneweb v6.08 |
137 |
|
|
- geneweb service not started [SME: 6371] |
138 |
|
|
- Add "Base directory" input in panel console. |
139 |
|
|
- perms corrected in templates.metadata |
140 |
|
|
- normalize template and .spec |