1 |
slords |
1.1 |
Summary: Package to integrate GeneWeb (V5) into SME Server |
2 |
|
|
%define name smeserver-geneweb |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 2.0 |
5 |
|
|
%define release 3 |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %smerelease %{release} |
8 |
|
|
Copyright: GPL |
9 |
|
|
Group: Applications/Internet |
10 |
|
|
Source: %{name}-%{version}.tar.gz |
11 |
|
|
#Patch0: |
12 |
|
|
Packager: %{_packager} |
13 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
14 |
|
|
BuildArchitectures: noarch |
15 |
|
|
Requires: geneweb >= 5.00 |
16 |
|
|
Requires: smeserver-release >= 7.0 |
17 |
|
|
|
18 |
|
|
%description |
19 |
|
|
This RPM must be installed after the geneweb*.el4.sme.i386.rpm package |
20 |
|
|
to complete the integration for SME Server. |
21 |
|
|
|
22 |
|
|
%changelog |
23 |
|
|
* Thu Apr 12 2007 Craig D. Jensen <craig.d.jensen@gmail.com> |
24 |
|
|
- [2.0-1] First companion to Geneweb v5 w/panel for admin allowing |
25 |
|
|
for setting the desired IP on the LAN for Geneweb administrative |
26 |
|
|
access. |
27 |
|
|
|
28 |
|
|
%prep |
29 |
|
|
|
30 |
|
|
rm -rf $RPM_BUILD_ROOT |
31 |
|
|
|
32 |
|
|
%setup |
33 |
|
|
#%patch0 -p1 |
34 |
|
|
|
35 |
|
|
%build |
36 |
|
|
perl createlinks |
37 |
|
|
DEFAULTS=root/etc/e-smith/db/configuration/defaults/geneweb |
38 |
|
|
mkdir -p $DEFAULTS |
39 |
|
|
echo "service" > $DEFAULTS/type |
40 |
|
|
echo "disabled" > $DEFAULTS/status |
41 |
|
|
echo "127.0.0.1" >$DEFAULTS/only |
42 |
|
|
|
43 |
|
|
%install |
44 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
45 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
46 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
47 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
48 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
49 |
|
|
|
50 |
|
|
%files -f %{name}-%{version}-filelist |
51 |
|
|
|
52 |
|
|
%defattr(-,root,root) |
53 |
|
|
|
54 |
|
|
%clean |
55 |
|
|
rm -rf $RPM_BUILD_ROOT |
56 |
|
|
|
57 |
|
|
%pre |
58 |
|
|
|
59 |
|
|
%post |
60 |
|
|
/etc/e-smith/events/actions/navigation-conf |
61 |
|
|
#/etc/e-smith/events/actions/initialize-default-databases |
62 |
|
|
#mkdir -p /etc/e-smith/templates/etc/rc.d/init.d/masq |
63 |
|
|
#/bin/chmod 644 /etc/e-smith/templates/etc/rc.d/init.d/masq/45AllowGeneWeb |
64 |
|
|
/sbin/e-smith/expand-template /etc/rc.d/init.d/masq |
65 |
|
|
#/etc/rc.d/init.d/masq restart |
66 |
|
|
true |
67 |
|
|
|
68 |
|
|
%preun |
69 |
|
|
/sbin/e-smith/db configuration setprop geneweb status disabled |
70 |
|
|
/etc/rc.d/init.d/gwd stop |
71 |
|
|
true |
72 |
|
|
|
73 |
|
|
%postun |
74 |
|
|
/sbin/e-smith/expand-template /etc/rc.d/init.d/masq |
75 |
|
|
#/etc/rc.d/init.d/masq restart |