1 |
slords |
1.1 |
Summary: Package to integrate GeneWeb (V5) into SME Server |
2 |
|
|
%define name smeserver-geneweb |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 2.0 |
5 |
slords |
1.8 |
%define release 7 |
6 |
slords |
1.1 |
Version: %{version} |
7 |
slords |
1.3 |
Release: %{release}%{?dist} |
8 |
slords |
1.2 |
License: GPL |
9 |
slords |
1.1 |
Group: Applications/Internet |
10 |
|
|
Source: %{name}-%{version}.tar.gz |
11 |
fetcher |
1.5 |
Patch1: smeserver-geneweb-2.0-pod-corrections.patch |
12 |
fetcher |
1.6 |
Patch2: smeserver-geneweb-2.0-ip_number-validation.patch |
13 |
dungog |
1.7 |
Patch3: smeserver-geneweb-2.0-locale-2008-03-11.patch |
14 |
slords |
1.1 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
15 |
|
|
BuildArchitectures: noarch |
16 |
|
|
Requires: geneweb >= 5.00 |
17 |
|
|
Requires: smeserver-release >= 7.0 |
18 |
slords |
1.8 |
Requires: e-smith-formmagick >= 1.4.0-10 |
19 |
slords |
1.4 |
BuildRequires: e-smith-devtools |
20 |
slords |
1.1 |
|
21 |
|
|
%description |
22 |
|
|
This RPM must be installed after the geneweb*.el4.sme.i386.rpm package |
23 |
|
|
to complete the integration for SME Server. |
24 |
|
|
|
25 |
|
|
%changelog |
26 |
slords |
1.8 |
* Wed Mar 12 2008 Shad L. Lords <slords@mail.com> - 2.0-7 |
27 |
|
|
- Add requires for e-smith-formmagick for UTF-8 support [SME: 3858] |
28 |
|
|
|
29 |
dungog |
1.7 |
* Tue Mar 11 2008 Stephen Noble <support@dungog.net> - 2.0-6 |
30 |
|
|
- add locale patch, validate lexicon in spec |
31 |
|
|
|
32 |
fetcher |
1.6 |
* Tue Jan 15 2008 Craig Jensen <craig.d.jensen@gmail.com> 2.0-5 |
33 |
|
|
- geneweb.pm fix to correctly validate IP numbers 'and' localIP |
34 |
|
|
|
35 |
fetcher |
1.5 |
* Sun Jan 13 2008 Craig Jensen <craig.d.jensen@gmail.com> 2.0-4 |
36 |
|
|
- geneweb.pm edited for pod corrections (pass podchecker) |
37 |
|
|
|
38 |
slords |
1.1 |
* Thu Apr 12 2007 Craig D. Jensen <craig.d.jensen@gmail.com> |
39 |
|
|
- [2.0-1] First companion to Geneweb v5 w/panel for admin allowing |
40 |
|
|
for setting the desired IP on the LAN for Geneweb administrative |
41 |
|
|
access. |
42 |
|
|
|
43 |
|
|
%prep |
44 |
|
|
|
45 |
|
|
rm -rf $RPM_BUILD_ROOT |
46 |
|
|
|
47 |
|
|
%setup |
48 |
fetcher |
1.5 |
%patch1 -p1 |
49 |
fetcher |
1.6 |
%patch2 -p1 |
50 |
dungog |
1.7 |
%patch3 -p1 |
51 |
slords |
1.1 |
|
52 |
|
|
%build |
53 |
|
|
perl createlinks |
54 |
|
|
DEFAULTS=root/etc/e-smith/db/configuration/defaults/geneweb |
55 |
|
|
mkdir -p $DEFAULTS |
56 |
|
|
echo "service" > $DEFAULTS/type |
57 |
|
|
echo "disabled" > $DEFAULTS/status |
58 |
|
|
echo "127.0.0.1" >$DEFAULTS/only |
59 |
|
|
|
60 |
dungog |
1.7 |
LEXICONS=$(find root/etc/e-smith/{locale/,web/functions/} -type f ) |
61 |
|
|
for lexicon in $LEXICONS |
62 |
|
|
do |
63 |
|
|
/sbin/e-smith/validate-lexicon $lexicon |
64 |
|
|
done |
65 |
|
|
|
66 |
slords |
1.1 |
%install |
67 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
68 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
69 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
70 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
71 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
72 |
|
|
|
73 |
|
|
%files -f %{name}-%{version}-filelist |
74 |
|
|
|
75 |
|
|
%defattr(-,root,root) |
76 |
|
|
|
77 |
|
|
%clean |
78 |
|
|
rm -rf $RPM_BUILD_ROOT |
79 |
|
|
|
80 |
|
|
%pre |
81 |
|
|
|
82 |
|
|
%post |
83 |
|
|
/etc/e-smith/events/actions/navigation-conf |
84 |
|
|
#/etc/e-smith/events/actions/initialize-default-databases |
85 |
|
|
#mkdir -p /etc/e-smith/templates/etc/rc.d/init.d/masq |
86 |
|
|
#/bin/chmod 644 /etc/e-smith/templates/etc/rc.d/init.d/masq/45AllowGeneWeb |
87 |
|
|
/sbin/e-smith/expand-template /etc/rc.d/init.d/masq |
88 |
|
|
#/etc/rc.d/init.d/masq restart |
89 |
|
|
true |
90 |
|
|
|
91 |
|
|
%preun |
92 |
|
|
/sbin/e-smith/db configuration setprop geneweb status disabled |
93 |
|
|
/etc/rc.d/init.d/gwd stop |
94 |
|
|
true |
95 |
|
|
|
96 |
|
|
%postun |
97 |
|
|
/sbin/e-smith/expand-template /etc/rc.d/init.d/masq |
98 |
|
|
#/etc/rc.d/init.d/masq restart |