1 |
michel |
1.2 |
Summary: Package to integrate GeneWeb (V6) into SME Server |
2 |
michel |
1.1 |
%define name smeserver-geneweb |
3 |
|
|
Name: %{name} |
4 |
michel |
1.3 |
%define version 2.1.0 |
5 |
jpp |
1.4 |
%define release 2 |
6 |
michel |
1.1 |
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
License: GPL |
9 |
|
|
Group: Applications/Internet |
10 |
|
|
Source: %{name}-%{version}.tar.gz |
11 |
jpp |
1.4 |
Patch1: smeserver-geneweb-2.1.0-locale-2019-12-07.patch |
12 |
michel |
1.3 |
#Patch0: smeserver-geneweb-2.1.0-init.patch |
13 |
michel |
1.1 |
|
14 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
15 |
|
|
BuildArchitectures: noarch |
16 |
|
|
Requires: geneweb >= 6.08 |
17 |
|
|
Requires: smeserver-release >= 9.0 |
18 |
|
|
Requires: e-smith-formmagick >= 2.4.0-1 |
19 |
|
|
BuildRequires: e-smith-devtools |
20 |
|
|
|
21 |
|
|
%description |
22 |
|
|
This RPM must be installed after the geneweb*.el6.sme package |
23 |
|
|
to complete the integration for SME Server. |
24 |
|
|
|
25 |
|
|
%changelog |
26 |
jpp |
1.4 |
* Sat Dec 07 2019 SME Translation Server <translations@contribs.org> 2.1.0-2.sme |
27 |
|
|
- apply locale 2019-12-07 patch |
28 |
|
|
|
29 |
michel |
1.1 |
* Wed Apr 03 2019 Michel Begue <mab974@gmail.com> 2.1-1.sme |
30 |
|
|
- first import in sme9 for geneweb v6.08 |
31 |
|
|
- geneweb service not started [SME: 6371] |
32 |
|
|
- Add "Base directory" input in panel console. |
33 |
|
|
- perms corrected in templates.metadata |
34 |
michel |
1.3 |
- normalize template and .spec |
35 |
michel |
1.1 |
|
36 |
|
|
%prep |
37 |
|
|
|
38 |
|
|
rm -rf $RPM_BUILD_ROOT |
39 |
|
|
|
40 |
|
|
%setup |
41 |
jpp |
1.4 |
%patch1 -p1 |
42 |
michel |
1.3 |
#%patch0 -p1 |
43 |
michel |
1.1 |
|
44 |
|
|
%build |
45 |
|
|
perl createlinks |
46 |
|
|
|
47 |
|
|
LEXICONS=$(find root/etc/e-smith/{locale/,web/functions/} -type f ) |
48 |
|
|
for lexicon in $LEXICONS |
49 |
|
|
do |
50 |
|
|
/sbin/e-smith/validate-lexicon $lexicon |
51 |
|
|
done |
52 |
|
|
|
53 |
|
|
%install |
54 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
55 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
56 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
57 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
58 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
59 |
|
|
|
60 |
|
|
%files -f %{name}-%{version}-filelist |
61 |
|
|
|
62 |
|
|
%defattr(-,root,root) |
63 |
|
|
|
64 |
|
|
%clean |
65 |
|
|
rm -rf $RPM_BUILD_ROOT |
66 |
|
|
|
67 |
|
|
%pre |
68 |
|
|
|
69 |
|
|
%post |
70 |
michel |
1.2 |
ln -s /etc/rc.d/init.d/geneweb /etc/rc.d/rc7.d/S99geneweb |
71 |
michel |
1.1 |
|
72 |
|
|
%preun |
73 |
|
|
/sbin/e-smith/db configuration setprop geneweb status disabled |
74 |
|
|
/etc/rc.d/init.d/gwd stop |
75 |
|
|
|
76 |
|
|
%postun |
77 |
|
|
/sbin/e-smith/expand-template /etc/rc.d/init.d/masq |
78 |
|
|
#/etc/rc.d/init.d/masq restart |