1 |
michel |
1.2 |
Summary: Package to integrate GeneWeb (V6) into SME Server |
2 |
michel |
1.1 |
%define name smeserver-geneweb |
3 |
|
|
Name: %{name} |
4 |
michel |
1.3 |
%define version 2.1.0 |
5 |
michel |
1.7 |
%define release 5 |
6 |
michel |
1.1 |
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
License: GPL |
9 |
|
|
Group: Applications/Internet |
10 |
|
|
Source: %{name}-%{version}.tar.gz |
11 |
jpp |
1.4 |
Patch1: smeserver-geneweb-2.1.0-locale-2019-12-07.patch |
12 |
michel |
1.5 |
Patch2: smeserver-geneweb-2.1.0-proxypass_services.patch |
13 |
michel |
1.7 |
Patch3: smeserver-geneweb-2.1.0-locale-2020-07-30.patch |
14 |
michel |
1.1 |
|
15 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
16 |
|
|
BuildArchitectures: noarch |
17 |
|
|
Requires: geneweb >= 6.08 |
18 |
|
|
Requires: smeserver-release >= 9.0 |
19 |
|
|
Requires: e-smith-formmagick >= 2.4.0-1 |
20 |
|
|
BuildRequires: e-smith-devtools |
21 |
|
|
|
22 |
|
|
%description |
23 |
|
|
This RPM must be installed after the geneweb*.el6.sme package |
24 |
|
|
to complete the integration for SME Server. |
25 |
|
|
|
26 |
|
|
%changelog |
27 |
michel |
1.7 |
* Thu Jul 30 2020 SME Translation Server <translations@contribs.org> 2.1.0-5.sme |
28 |
|
|
- apply locale 2020-07-30 patch |
29 |
|
|
|
30 |
michel |
1.6 |
* Sat Jul 11 2020 Michel Begue <mab974@gmail.com> 2.1.0-4.sme |
31 |
michel |
1.5 |
- geneweb and gwsetup services thru proxypass [SME: 10930] |
32 |
|
|
|
33 |
jpp |
1.4 |
* Sat Dec 07 2019 SME Translation Server <translations@contribs.org> 2.1.0-2.sme |
34 |
|
|
- apply locale 2019-12-07 patch |
35 |
|
|
|
36 |
michel |
1.1 |
* Wed Apr 03 2019 Michel Begue <mab974@gmail.com> 2.1-1.sme |
37 |
|
|
- first import in sme9 for geneweb v6.08 |
38 |
|
|
- geneweb service not started [SME: 6371] |
39 |
|
|
- Add "Base directory" input in panel console. |
40 |
|
|
- perms corrected in templates.metadata |
41 |
michel |
1.3 |
- normalize template and .spec |
42 |
michel |
1.1 |
|
43 |
|
|
%prep |
44 |
|
|
|
45 |
|
|
rm -rf $RPM_BUILD_ROOT |
46 |
|
|
|
47 |
|
|
%setup |
48 |
michel |
1.5 |
# tmp fix before creating a new source archive 2.1.0-3 |
49 |
|
|
rm -f root/etc/e-smith/events/geneweb-modify/services2adjust/* |
50 |
jpp |
1.4 |
%patch1 -p1 |
51 |
michel |
1.5 |
%patch2 -p1 |
52 |
michel |
1.7 |
%patch3 -p1 |
53 |
michel |
1.1 |
|
54 |
|
|
%build |
55 |
|
|
perl createlinks |
56 |
|
|
|
57 |
|
|
LEXICONS=$(find root/etc/e-smith/{locale/,web/functions/} -type f ) |
58 |
|
|
for lexicon in $LEXICONS |
59 |
|
|
do |
60 |
|
|
/sbin/e-smith/validate-lexicon $lexicon |
61 |
|
|
done |
62 |
|
|
|
63 |
|
|
%install |
64 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
65 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
66 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
67 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
68 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
69 |
|
|
|
70 |
|
|
%files -f %{name}-%{version}-filelist |
71 |
|
|
|
72 |
|
|
%defattr(-,root,root) |
73 |
michel |
1.5 |
%attr(755, root, root) /var/service/geneweb/log/run |
74 |
|
|
%attr(755, root, root) /var/service/gwsetup/log/run |
75 |
|
|
|
76 |
michel |
1.1 |
|
77 |
|
|
%clean |
78 |
|
|
rm -rf $RPM_BUILD_ROOT |
79 |
|
|
|
80 |
|
|
%pre |
81 |
|
|
|
82 |
|
|
%post |
83 |
michel |
1.5 |
ln -s /var/service/geneweb /service/geneweb |
84 |
|
|
touch /var/service/geneweb/down |
85 |
|
|
ln -s /etc/rc.d/init.d/daemontools /etc/rc.d/init.d/supervise/geneweb |
86 |
|
|
##ln -s /etc/rc.d/init.d/e-smith-service /etc/rc.d/rc7.d/S98geneweb |
87 |
|
|
mkdir -p /var/log/geneweb |
88 |
|
|
chown smelog:smelog /var/log/geneweb |
89 |
|
|
ln -s /var/service/gwsetup /service/gwsetup |
90 |
|
|
touch /var/service/gwsetup/down |
91 |
|
|
ln -s /etc/rc.d/init.d/daemontools /etc/rc.d/init.d/supervise/gwsetup |
92 |
|
|
##ln -s /etc/rc.d/init.d/e-smith-service /etc/rc.d/rc7.d/S98gwsetup |
93 |
|
|
mkdir -p /var/log/gwsetup |
94 |
|
|
chown smelog:smelog /var/log/gwsetup |
95 |
michel |
1.1 |
|
96 |
|
|
%preun |
97 |
|
|
/sbin/e-smith/db configuration setprop geneweb status disabled |
98 |
michel |
1.5 |
/sbin/e-smith/db configuration setprop gwsetup status disabled |
99 |
|
|
#/etc/rc.d/init.d/geneweb stop |
100 |
|
|
#/etc/rc.d/init.d/gwsetup stop |
101 |
|
|
/usr/bin/sv stop geneweb |
102 |
|
|
/usr/bin/sv stop gwsetup |
103 |
michel |
1.1 |
|
104 |
|
|
%postun |