1 |
unnilennium |
1.1 |
# $Id: smeserver-geoip.spec,v 1.4 2010/03/04 16:11:51 slords Exp $ |
2 |
|
|
# Authority: nocvs |
3 |
|
|
# Name: Thouvenin Romain |
4 |
|
|
|
5 |
|
|
%define name smeserver-geoip |
6 |
|
|
%define version 1.0.0 |
7 |
|
|
%define release b2 |
8 |
|
|
|
9 |
|
|
Summary: SME Server geoip plugin |
10 |
|
|
Name: %{name} |
11 |
|
|
Version: %{version} |
12 |
|
|
Release: %{release} |
13 |
|
|
License: GPL |
14 |
|
|
Group: Email |
15 |
|
|
Source: %{name}-%{version}.tar.gz |
16 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
17 |
|
|
BuildArchitectures: noarch |
18 |
|
|
BuildRequires: e-smith-devtools |
19 |
|
|
|
20 |
|
|
%description |
21 |
|
|
The GEOIP plugin lets us know which country our mail server is receiving mail from. If we're receiving too much spam from a particular country, this will help track it down and then use that info to reject connections from that country. This ends up taking the load off our servers. |
22 |
|
|
|
23 |
|
|
CHANGE THE CONFIG DB: config setprop qpsmtpd BadCountries <countrycode> (i.e. config setprop qpsmtpd BadCountries BR) |
24 |
|
|
SIGNAL EVENT: signal-event email-update |
25 |
|
|
|
26 |
|
|
%changelog |
27 |
|
|
* Fri Apr 24 2009 Jonathan Martens <smeserver-bugzilla@contribs.org> 1.0.0-b2 |
28 |
|
|
- Add e-smith-devtools as a requirement [SME: 1866] |
29 |
|
|
|
30 |
|
|
* Thu Jun 16 2007 Doug Kruhm <dakruhm@daknetworks.net> |
31 |
|
|
- 1.0.0-01 |
32 |
|
|
- Original version |
33 |
|
|
|
34 |
|
|
%prep |
35 |
|
|
%setup |
36 |
|
|
|
37 |
|
|
%build |
38 |
|
|
|
39 |
|
|
DEFAULTS=root/etc/e-smith/db/configuration/defaults/qpsmtpd |
40 |
|
|
mkdir -p $DEFAULTS |
41 |
|
|
|
42 |
|
|
echo "enabled" > $DEFAULTS/GeoIP |
43 |
|
|
echo "" > $DEFAULTS/BadCountries |
44 |
|
|
|
45 |
|
|
|
46 |
|
|
%install |
47 |
|
|
rm -rf $RPM_BUILD_ROOT |
48 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
49 |
|
|
rm -f %{name}-%{version}-filelist |
50 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
51 |
|
|
|
52 |
|
|
%clean |
53 |
|
|
rm -rf $RPM_BUILD_ROOT |
54 |
|
|
|
55 |
|
|
%post |
56 |
|
|
/etc/e-smith/events/actions/initialize-default-databases |
57 |
|
|
/sbin/e-smith/expand-template /var/service/qpsmtpd/config/badcountries |
58 |
|
|
/sbin/e-smith/expand-template /var/service/qpsmtpd/config/peers/0 |
59 |
|
|
true |
60 |
|
|
|
61 |
|
|
%postun |
62 |
|
|
/sbin/e-smith/expand-template /var/service/qpsmtpd/config/peers/0 |
63 |
|
|
true |
64 |
|
|
|
65 |
|
|
%files -f %{name}-%{version}-filelist |
66 |
|
|
%defattr(-,root,root) |