1 |
%define name smeserver-geoip |
2 |
%define version 1.1.2 |
3 |
%define release 5 |
4 |
|
5 |
Summary: SME Server geoip plugin |
6 |
Name: %{name} |
7 |
Version: %{version} |
8 |
Release: %{release}%{?dist} |
9 |
License: GPL |
10 |
Group: Email |
11 |
Source: %{name}-%{version}.tar.gz |
12 |
Packager: Doug Kruhm <dakruhm@daknetworks.net> |
13 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
14 |
BuildArchitectures: noarch |
15 |
Requires: perl-Geo-IP |
16 |
BuildRequires: e-smith-devtools >= 1.13.1-03 |
17 |
Patch0 : smeserver-geoip-remove-createlink-add-geoip-download-actions.patch |
18 |
Patch1: smeserver-geoip-1.1.2.geoip-update-event.patch |
19 |
Patch2: smeserver-geoip-whitelist_by_IP.patch |
20 |
%description |
21 |
The GEOIP plugin lets us know which country our mail server is receiving mail from. If we're receiving too much spam from a particular country, this will help track it down and then use that info to reject connections from that country. This ends up taking the load off our servers. |
22 |
|
23 |
CHANGE THE CONFIG DB: config setprop qpsmtpd BadCountries <countrycode> (i.e. config setprop qpsmtpd BadCountries BR) |
24 |
SIGNAL EVENT: signal-event email-update |
25 |
|
26 |
%changelog |
27 |
* Wed Sep 23 2015 John Crisp <jcrisp@safeandsoundit.co.uk> 1.1.2-5 |
28 |
- Add ability to whitelist an IP [SME:8981] |
29 |
|
30 |
* Tue Sep 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 1.1.2-4 |
31 |
- the event geoip-update download the geoip database |
32 |
- added smeserver-geoip-1.1.2.geoip-update-event.patch |
33 |
|
34 |
* Sun Jun 14 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 1.1.2-2 |
35 |
- added createlinks |
36 |
- added actions and crontab to download geoip database |
37 |
|
38 |
* Mon Sep 03 2012 Doug Kruhm <dakruhm@daknetworks.net> 1.0.5 |
39 |
- defining $country to reduce noise if not found [SME: 5011] |
40 |
- fixed misspelling in response if country is blocked [SME: 7058] |
41 |
- cleaning up versioning to MAJOR-MINOR-PATCH |
42 |
|
43 |
* Fri May 01 2009 Doug Kruhm <dakruhm@daknetworks.net> 1.0.0-04 |
44 |
- added response to connecting server if blocked [SME: 5011] |
45 |
|
46 |
* Fri May 01 2009 Doug Kruhm <dakruhm@daknetworks.net> 1.0.0-03 |
47 |
- added line to reduce log noise [SME: 5011] |
48 |
|
49 |
* Fri May 01 2009 Doug Kruhm <dakruhm@daknetworks.net> 1.0.0-02 |
50 |
- db defaults migrated from SPEC file to rpm files [SME: 5193] |
51 |
- removed %post and %postun macros [SME: 5194] |
52 |
- added Requires perl-Geo-IP [SME: 1866] |
53 |
- added e-smith-devtools as a requirement [SME: 1866] |
54 |
|
55 |
* Thu Jun 16 2007 Doug Kruhm <dakruhm@daknetworks.net> |
56 |
- 1.0.0-01 |
57 |
- Original version |
58 |
|
59 |
|
60 |
%prep |
61 |
%setup |
62 |
%patch0 -p1 |
63 |
%patch1 -p1 |
64 |
%patch2 -p1 |
65 |
|
66 |
%build |
67 |
%{__mkdir_p} root/var/lib/GeoIP |
68 |
perl createlinks |
69 |
|
70 |
%install |
71 |
rm -rf $RPM_BUILD_ROOT |
72 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
73 |
rm -f %{name}-%{version}-filelist |
74 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
75 |
|
76 |
%clean |
77 |
rm -rf $RPM_BUILD_ROOT |
78 |
|
79 |
%post |
80 |
|
81 |
%postun |
82 |
|
83 |
%files -f %{name}-%{version}-filelist |
84 |
%defattr(-,root,root) |