1 |
stephdl |
1.1 |
%define name smeserver-geoip |
2 |
|
|
%define version 1.1.2 |
3 |
reetspetit |
1.5 |
%define release 5 |
4 |
stephdl |
1.1 |
|
5 |
|
|
Summary: SME Server geoip plugin |
6 |
|
|
Name: %{name} |
7 |
|
|
Version: %{version} |
8 |
|
|
Release: %{release}%{?dist} |
9 |
|
|
License: GPL |
10 |
|
|
Group: Email |
11 |
|
|
Source: %{name}-%{version}.tar.gz |
12 |
|
|
Packager: Doug Kruhm <dakruhm@daknetworks.net> |
13 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
14 |
|
|
BuildArchitectures: noarch |
15 |
|
|
Requires: perl-Geo-IP |
16 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
17 |
|
|
Patch0 : smeserver-geoip-remove-createlink-add-geoip-download-actions.patch |
18 |
stephdl |
1.4 |
Patch1: smeserver-geoip-1.1.2.geoip-update-event.patch |
19 |
reetspetit |
1.5 |
Patch2: smeserver-geoip-whitelist_by_IP.patch |
20 |
stephdl |
1.1 |
%description |
21 |
|
|
The GEOIP plugin lets us know which country our mail server is receiving mail from. If we're receiving too much spam from a particular country, this will help track it down and then use that info to reject connections from that country. This ends up taking the load off our servers. |
22 |
|
|
|
23 |
|
|
CHANGE THE CONFIG DB: config setprop qpsmtpd BadCountries <countrycode> (i.e. config setprop qpsmtpd BadCountries BR) |
24 |
|
|
SIGNAL EVENT: signal-event email-update |
25 |
|
|
|
26 |
|
|
%changelog |
27 |
reetspetit |
1.5 |
%changelog |
28 |
|
|
* Wed Sep 23 2015 John Crisp <jcrisp@safeandsoundit.co.uk> 1.1.2-5 |
29 |
|
|
- Add ability to whitelist an IP [SME:8981] |
30 |
|
|
|
31 |
stephdl |
1.4 |
* Tue Sep 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 1.1.2-4 |
32 |
|
|
- the event geoip-update download the geoip database |
33 |
|
|
- added smeserver-geoip-1.1.2.geoip-update-event.patch |
34 |
stephdl |
1.3 |
|
35 |
stephdl |
1.2 |
* Sun Jun 14 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 1.1.2-2 |
36 |
stephdl |
1.1 |
- added createlinks |
37 |
|
|
- added actions and crontab to download geoip database |
38 |
|
|
|
39 |
|
|
* Mon Sep 03 2012 Doug Kruhm <dakruhm@daknetworks.net> 1.0.5 |
40 |
|
|
- defining $country to reduce noise if not found [SME: 5011] |
41 |
|
|
- fixed misspelling in response if country is blocked [SME: 7058] |
42 |
|
|
- cleaning up versioning to MAJOR-MINOR-PATCH |
43 |
|
|
|
44 |
|
|
* Fri May 01 2009 Doug Kruhm <dakruhm@daknetworks.net> 1.0.0-04 |
45 |
|
|
- added response to connecting server if blocked [SME: 5011] |
46 |
|
|
|
47 |
|
|
* Fri May 01 2009 Doug Kruhm <dakruhm@daknetworks.net> 1.0.0-03 |
48 |
|
|
- added line to reduce log noise [SME: 5011] |
49 |
|
|
|
50 |
|
|
* Fri May 01 2009 Doug Kruhm <dakruhm@daknetworks.net> 1.0.0-02 |
51 |
|
|
- db defaults migrated from SPEC file to rpm files [SME: 5193] |
52 |
|
|
- removed %post and %postun macros [SME: 5194] |
53 |
|
|
- added Requires perl-Geo-IP [SME: 1866] |
54 |
|
|
- added e-smith-devtools as a requirement [SME: 1866] |
55 |
|
|
|
56 |
|
|
* Thu Jun 16 2007 Doug Kruhm <dakruhm@daknetworks.net> |
57 |
|
|
- 1.0.0-01 |
58 |
|
|
- Original version |
59 |
|
|
|
60 |
|
|
|
61 |
|
|
%prep |
62 |
|
|
%setup |
63 |
|
|
%patch0 -p1 |
64 |
stephdl |
1.3 |
%patch1 -p1 |
65 |
reetspetit |
1.5 |
%patch2 -p1 |
66 |
stephdl |
1.1 |
|
67 |
|
|
%build |
68 |
|
|
%{__mkdir_p} root/var/lib/GeoIP |
69 |
|
|
perl createlinks |
70 |
|
|
|
71 |
|
|
%install |
72 |
|
|
rm -rf $RPM_BUILD_ROOT |
73 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
74 |
|
|
rm -f %{name}-%{version}-filelist |
75 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
76 |
|
|
|
77 |
|
|
%clean |
78 |
|
|
rm -rf $RPM_BUILD_ROOT |
79 |
|
|
|
80 |
|
|
%post |
81 |
|
|
|
82 |
|
|
%postun |
83 |
|
|
|
84 |
|
|
%files -f %{name}-%{version}-filelist |
85 |
|
|
%defattr(-,root,root) |