/[smecontribs]/rpms/smeserver-git/contribs8/smeserver-git.spec
ViewVC logotype

Annotation of /rpms/smeserver-git/contribs8/smeserver-git.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Wed Feb 4 18:17:59 2015 UTC (9 years, 3 months ago) by vip-ire
Branch: MAIN
CVS Tags: smeserver-git-1_0_0-40_el5_sme
Initial import

1 vip-ire 1.1 %define name smeserver-git
2     %define version 1.0.0
3     %define release 40
4     Summary: Centralised Git repositories with setup and configuration through SME Server admin panels.
5     Name: %{name}
6     Version: %{version}
7     Release: %{release}%{?dist}
8     Distribution: SME Server
9     License: GNU GPL version 2
10     URL: http://www.through-ip.com
11     Group: SMEserver/addon
12     Source: smeserver-git-%{version}.tar.gz
13     Packager: Marco Hess <marco.hess@through-ip.com>
14     BuildArchitectures: noarch
15     BuildRoot: /var/tmp/%{name}-%{version}
16     BuildRequires: e-smith-devtools
17     Requires: e-smith-release >= 8.0
18     Requires: git
19     AutoReqProv: no
20    
21     %description
22     smeserver-git enables centralised git repositories on an SME server and enables
23     access to these repositories through HTTP/HTTPS. Repositories are created and
24     managed through a server-manager panel that also configures the access permissions
25     to the repositories based on the existing SME users and groups. The package
26     installs and enables the git server on the current host like in
27     host.com/git. Repositories are then available as https://host.com/git/gitrepo.git.
28    
29     %changelog
30     * Tue Feb 2 2015 Marco Hess <marco.hess@through-ip.com> 1.0.0-40
31     - Fixups of 1.1 incompatibilities with older apache.
32     - Allow adjustment of gitweb static path for git 1.7 vs. git 1.8
33    
34     * Tue Feb 2 2015 Marco Hess <marco.hess@through-ip.com> 1.0.0-40
35     - Fixup of GitWeb CSS/JS files under 'static' in this version.
36    
37     * Tue Feb 2 2015 Marco Hess <marco.hess@through-ip.com> 1.0.0-38
38     - Backport changes from 1.1.
39    
40     * Fri May 30 2014 Marco Hess <marco.hess@through-ip.com> 1.0.0-37
41     - Fixed the HTTPS redirection loop. HTTPS redirection is now only done on the HTTP part of of
42     the web server configuration and the full Git configuration part is only done in the HTTPS
43     section.
44    
45     * Tue May 27 2014 Marco Hess <marco.hess@through-ip.com> 1.0.0-36
46     - Changed how git update-server-info is run as the location of the executable changed in git 1.8.
47    
48     * Fri Jan 24 2014 Marco Hess <marco.hess@through-ip.com> 1.0.0-35
49     - Systax error in 29GitRepositories that I though I fixed.
50    
51     * Fri Jan 24 2014 Marco Hess <marco.hess@through-ip.com> 1.0.0-34
52     - git version 1.8 has shifted the location of some executables. Modified the scripts
53     to test on these locations so we generate the right paths.
54    
55     * Sun May 21 2013 Marco Hess <marco.hess@through-ip.com> 1.0.0-33
56     - Set permissions on git repository databaase for GitWeb access also on upgrade install.
57    
58     * Sun May 21 2013 Marco Hess <marco.hess@through-ip.com> 1.0.0-32
59     - Fixed a problem in the repository delete script where File::Path is needed
60     to reference rmtree.
61     - Also cleanup the entry from the database so that repositories of the same
62     name can be created again.
63    
64     * Sun May 21 2013 Marco Hess <marco.hess@through-ip.com> 1.0.0-31
65     - Changed the repository-delete script to ensure the SME Git database
66     permissions are Ok for use by GitWeb after a delete.
67     - Ensure that on 64-bit systems we use /usr/lib64/httpd/modules/pwauth
68    
69     * Sat Jul 21 2012 Marco Hess <marco.hess@through-ip.com> 1.0.0-3
70     - Ensure git database is present in /home/e-smith/db
71     - Create default config database entries for 'git'
72     - Moved retrieving maxNameLength for panel validations from config 'git'
73     - In the user and group list boxes, added support to the special group admin
74     and shared to allow either the admin or everybody to be included in the access lists.
75     - Updated the HTTP config db error messages to be more clear as to which property needs
76     to be configured.
77    
78     * Sun Jun 17 2012 Jonathan Martens <smeserver-contribs@snetram.nl> 1.0.0-2
79     - Rip out gitweb and create tgz file
80    
81     * Sun Apr 29 2012 Marco Hess <marco.hess@through-ip.com> 1.0.0-1
82     - initial release
83    
84     %prep
85     %setup
86     mkdir -p root/home/e-smith/files/git/
87    
88     %build
89     perl createlinks
90    
91     %install
92     rm -rf $RPM_BUILD_ROOT
93     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
94     rm -f %{name}-%{version}-filelist
95     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist
96    
97     %clean
98     rm -rf $RPM_BUILD_ROOT
99    
100     %post
101     echo "---------------------------------------------------------"
102     if [ $1 -eq 1 ] ; then
103     echo "Initial installation:"
104     echo " - Ensuring git repositories configuration database exist ..."
105     touch /home/e-smith/db/git
106     echo " - Ensuring git repositories root directory exist with the right permissions ..."
107     mkdir -p /home/e-smith/files/git
108     chmod 770 /home/e-smith/files/git
109     chmod g+s /home/e-smith/files/git
110     echo " - Rebuilding server-manager ..."
111     /sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf
112     /etc/e-smith/events/actions/navigation-conf
113     fi
114     echo " - Ensuring git repositories configuration database has the right permissions ..."
115     chmod 664 /home/e-smith/db/git
116     chown admin:www /home/e-smith/files/git
117     /etc/rc7.d/S86httpd-e-smith sighup
118     echo "---------------------------------------------------------"
119    
120     %postun
121     if [ $1 -eq 0 ] ; then
122     echo "---------------------------------------------------------"
123     echo " - Rebuilding server-manager ..."
124     /sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf
125     /etc/e-smith/events/actions/navigation-conf
126     echo " - Final Uninstall:"
127     echo " smeserver-git has been removed but the git repositories and the git config database are left in place ..."
128     echo " To manually remove the git repositories, use: 'rm -rf /home/e-smith/files/git'"
129     echo " To manually remove the git config database, use: 'rm -rf /home/e-smith/db/git'"
130     echo "---------------------------------------------------------"
131     fi
132    
133     %files -f %{name}-%{version}-filelist
134     %defattr(-,root,root)

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed