/[smecontribs]/rpms/smeserver-git/contribs9/smeserver-git.spec
ViewVC logotype

Annotation of /rpms/smeserver-git/contribs9/smeserver-git.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Wed Feb 4 18:29:39 2015 UTC (9 years, 3 months ago) by vip-ire
Branch: MAIN
CVS Tags: smeserver-git-1_1_0-0_el6_sme
Initial import

1 vip-ire 1.1 %define name smeserver-git
2     %define version 1.1.0
3     %define release 0
4     Summary: Centralised Git repositories with setup and configuration through SME Server admin panels.
5     Name: %{name}
6     Version: %{version}
7     Release: %{release}%{?dist}
8     Distribution: SME Server
9     License: GNU GPL version 2
10     URL: http://www.through-ip.com
11     Group: SMEserver/addon
12     Source: smeserver-git-%{version}.tar.gz
13     Packager: Marco Hess <marco.hess@through-ip.com>
14     BuildArchitectures: noarch
15     BuildRoot: /var/tmp/%{name}-%{version}
16     BuildRequires: e-smith-devtools
17     Requires: e-smith-release >= 9.0
18     Requires: git
19     AutoReqProv: no
20    
21     %description
22     smeserver-git enables centralised git repositories on an SME server and enables
23     access to these repositories through HTTP/HTTPS. Repositories are created and
24     managed through a server-manager panel that also configures the access permissions
25     to the repositories based on the existing SME users and groups. The package
26     installs and enables the git server on the current host like in
27     host.com/git. Repositories are then available as https://host.com/git/gitrepo.git.
28    
29     %changelog
30     * Fri Jan 30 2015 Marco Hess <marco.hess@through-ip.com> 1.1.0-0
31     - Require >= SME9.
32     - Moved /usr/lib/perl5/site_perl to /usr/share/perl5/vendor_perl.
33     - Fixed pwauth setup.
34     - Added AuthBasicProvider external in authentication setup.
35     - Fixed GitWebRoot variable scope.
36     - Allow adjustment of gitweb static path for git 1.7 vs. git 1.8
37    
38     * Fri May 30 2014 Marco Hess <marco.hess@through-ip.com> 1.0.0-37
39     - Fixed the HTTPS redirection loop. HTTPS redirection is now only done on the HTTP part of of
40     the web server configuration and the full Git configuration part is only done in the HTTPS
41     section.
42    
43     * Tue May 27 2014 Marco Hess <marco.hess@through-ip.com> 1.0.0-36
44     - Changed how git update-server-info is run as the location of the executable changed in git 1.8.
45    
46     * Fri Jan 24 2014 Marco Hess <marco.hess@through-ip.com> 1.0.0-35
47     - Systax error in 29GitRepositories that I though I fixed.
48    
49     * Fri Jan 24 2014 Marco Hess <marco.hess@through-ip.com> 1.0.0-34
50     - git version 1.8 has shifted the location of some executables. Modified the scripts
51     to test on these locations so we generate the right paths.
52    
53     * Sun May 21 2013 Marco Hess <marco.hess@through-ip.com> 1.0.0-33
54     - Set permissions on git repository databaase for GitWeb access also on upgrade install.
55    
56     * Sun May 21 2013 Marco Hess <marco.hess@through-ip.com> 1.0.0-32
57     - Fixed a problem in the repository delete script where File::Path is needed
58     to reference rmtree.
59     - Also cleanup the entry from the database so that repositories of the same
60     name can be created again.
61    
62     * Sun May 21 2013 Marco Hess <marco.hess@through-ip.com> 1.0.0-31
63     - Changed the repository-delete script to ensure the SME Git database
64     permissions are Ok for use by GitWeb after a delete.
65     - Ensure that on 64-bit systems we use /usr/lib64/httpd/modules/pwauth
66    
67     * Sat Jul 21 2012 Marco Hess <marco.hess@through-ip.com> 1.0.0-3
68     - Ensure git database is present in /home/e-smith/db
69     - Create default config database entries for 'git'
70     - Moved retrieving maxNameLength for panel validations from config 'git'
71     - In the user and group list boxes, added support to the special group admin
72     and shared to allow either the admin or everybody to be included in the access lists.
73     - Updated the HTTP config db error messages to be more clear as to which property needs
74     to be configured.
75    
76     * Sun Jun 17 2012 Jonathan Martens <smeserver-contribs@snetram.nl> 1.0.0-2
77     - Rip out gitweb and create tgz file
78    
79     * Sun Apr 29 2012 Marco Hess <marco.hess@through-ip.com> 1.0.0-1
80     - initial release
81    
82     %prep
83     %setup
84     mkdir -p root/home/e-smith/files/git/
85    
86     %build
87     perl createlinks
88    
89     %install
90     rm -rf $RPM_BUILD_ROOT
91     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
92     rm -f %{name}-%{version}-filelist
93     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist
94    
95     %clean
96     rm -rf $RPM_BUILD_ROOT
97    
98     %post
99     echo "---------------------------------------------------------"
100     if [ $1 -eq 1 ] ; then
101     echo "Initial installation:"
102     echo " - Ensuring git repositories configuration database exist ..."
103     touch /home/e-smith/db/git
104     echo " - Ensuring git repositories root directory exist with the right permissions ..."
105     mkdir -p /home/e-smith/files/git
106     chmod 770 /home/e-smith/files/git
107     chmod g+s /home/e-smith/files/git
108     echo " - Rebuilding server-manager ..."
109     /sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf
110     /etc/e-smith/events/actions/navigation-conf
111     fi
112     echo " - Ensuring git repositories configuration database has the right permissions ..."
113     chmod 664 /home/e-smith/db/git
114     chown admin:www /home/e-smith/files/git
115     /etc/rc7.d/S86httpd-e-smith sighup
116     echo "---------------------------------------------------------"
117    
118     %postun
119     if [ $1 -eq 0 ] ; then
120     echo "---------------------------------------------------------"
121     echo " - Rebuilding server-manager ..."
122     /sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf
123     /etc/e-smith/events/actions/navigation-conf
124     echo " - Final Uninstall:"
125     echo " smeserver-git has been removed but the git repositories and the git config database are left in place ..."
126     echo " To manually remove the git repositories, use: 'rm -rf /home/e-smith/files/git'"
127     echo " To manually remove the git config database, use: 'rm -rf /home/e-smith/db/git'"
128     echo "---------------------------------------------------------"
129     fi
130    
131     %files -f %{name}-%{version}-filelist
132     %defattr(-,root,root)

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed