1 |
vip-ire |
1.1 |
%define name smeserver-gitweb |
2 |
|
|
%define version 1.1.0 |
3 |
marcohess |
1.4 |
%define release 3 |
4 |
vip-ire |
1.1 |
Summary: GitWeb is a web based Git repository viewer on SME Server |
5 |
|
|
Name: %{name} |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
Distribution: SME Server |
9 |
|
|
License: GNU GPL version 2 |
10 |
|
|
URL: http://www.through-ip.com |
11 |
|
|
Group: SMEserver/addon |
12 |
|
|
Source: smeserver-gitweb-%{version}.tar.gz |
13 |
|
|
Packager: Marco Hess <marco.hess@through-ip.com> |
14 |
|
|
BuildArchitectures: noarch |
15 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
16 |
|
|
BuildRequires: e-smith-devtools |
17 |
|
|
Requires: e-smith-release >= 9.0 |
18 |
|
|
Requires: smeserver-git |
19 |
|
|
Requires: gitweb |
20 |
|
|
Requires: highlight |
21 |
|
|
AutoReqProv: no |
22 |
marcohess |
1.2 |
Patch1: smeserver-gitweb-1.1.0-remove_unused_linefeed_from_auth_error.patch |
23 |
marcohess |
1.3 |
Patch2: smeserver-gitweb-1.1.0-remove_runtime_access_to_networks_db.patch |
24 |
marcohess |
1.4 |
patch3: smeserver-gitweb-1.1.0-runtime_search_for_pwauth.patch |
25 |
vip-ire |
1.1 |
|
26 |
|
|
%description |
27 |
|
|
HTTP access to https://git.host.com provides a gitweb view of the repositories. |
28 |
|
|
|
29 |
|
|
%changelog |
30 |
marcohess |
1.4 |
* Wed Feb 17 2016 Marco Hess <marco.hess@through-ip.com> 1.1.0-3 |
31 |
|
|
- Changed the trypass function in 60ExportAuthHook to dynamically |
32 |
|
|
check for the location of pwauth so this becomes universal for |
33 |
|
|
SME8 and SME9. |
34 |
|
|
|
35 |
marcohess |
1.3 |
* Wed Feb 17 2016 Marco Hess <marco.hess@through-ip.com> 1.1.0-2 |
36 |
|
|
- Remove runtime access to NetworkDB [SME: 9217] |
37 |
|
|
- Some trailing whitespace cleanup |
38 |
|
|
|
39 |
marcohess |
1.2 |
* Thu Feb 11 2016 Marco Hess <marco.hess@through-ip.com> 1.1.0-1 |
40 |
|
|
- Remove unused line feeds from auth_error messages [SME: 9217] |
41 |
|
|
|
42 |
vip-ire |
1.1 |
* Fri Jan 30 2015 Marco Hess <marco.hess@through-ip.com> 1.1.0-0 |
43 |
|
|
- Split spec package to version 1.1 for SME9 |
44 |
|
|
- Fixed user authorisation for repositories viewable from internet |
45 |
|
|
|
46 |
|
|
* Fri Jan 24 2014 Marco Hess <marco.hess@through-ip.com> 1.0.0-12 |
47 |
|
|
- Added support for displaying a clone URL. |
48 |
|
|
|
49 |
|
|
* Mon Jul 23 2012 Marco Hess <marco.hess@through-ip.com> 1.0.0-3 |
50 |
|
|
- Setup default config parameters for gitweb as a service |
51 |
|
|
- Removed HTTP template as this is shared with smeserver-git |
52 |
|
|
- Added require on gitweb rpm |
53 |
|
|
|
54 |
|
|
* Sun Jun 17 2012 Jonathan Martens <smeserver-contribs@snetram.nl> 1.0.0-2 |
55 |
|
|
- Remove all smeserver-git related files in order to split the packages |
56 |
|
|
|
57 |
|
|
* Sun Apr 29 2012 Marco Hess <marco.hess@through-ip.com> 1.0.0-1 |
58 |
|
|
- initial release |
59 |
|
|
|
60 |
|
|
%prep |
61 |
|
|
%setup |
62 |
marcohess |
1.2 |
%patch1 -p1 |
63 |
marcohess |
1.3 |
%patch2 -p1 |
64 |
marcohess |
1.4 |
%patch3 -p1 |
65 |
vip-ire |
1.1 |
%build |
66 |
|
|
|
67 |
|
|
%install |
68 |
|
|
rm -rf $RPM_BUILD_ROOT |
69 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
70 |
|
|
rm -f %{name}-%{version}-filelist |
71 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
72 |
|
|
|
73 |
|
|
%clean |
74 |
|
|
rm -rf $RPM_BUILD_ROOT |
75 |
|
|
|
76 |
|
|
%post |
77 |
|
|
echo "Ensuring git database is accessible to GitWeb ..." |
78 |
|
|
touch /home/e-smith/db/git |
79 |
|
|
chmod 644 /home/e-smith/db/git |
80 |
|
|
echo "Ensuring networks database is accessible to GitWeb ..." |
81 |
|
|
chmod 644 /home/e-smith/db/networks |
82 |
|
|
echo "Expanding gitweb.conf template ..." |
83 |
|
|
/sbin/e-smith/expand-template /etc/gitweb.conf |
84 |
|
|
echo "Expanding GitWeb home page text template ..." |
85 |
|
|
/sbin/e-smith/expand-template /etc/e-smith/web/common/gitweb/home_text.html |
86 |
|
|
echo "Expanding web server template ..." |
87 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
88 |
|
|
/etc/rc7.d/S86httpd-e-smith sighup |
89 |
|
|
|
90 |
|
|
%files -f %{name}-%{version}-filelist |
91 |
|
|
%defattr(-,root,root) |