1 |
slords |
1.1 |
Summary: guardian for SME server |
2 |
|
|
%define name smeserver-guardiand |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 1.7 |
5 |
|
|
%define release 4 |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release} |
8 |
|
|
Copyright: Freely distributable |
9 |
|
|
Group: Networking/Daemons |
10 |
|
|
Source: %{name}-%{version}.tar.gz |
11 |
|
|
#Patch0: %{name}-%{version}.patch.yyyymmddnn |
12 |
|
|
Packager: Michel Van hees <michel@vanhees.cc> |
13 |
|
|
BuildRoot: /var/tmp/e-smith-buildroot |
14 |
|
|
BuildRequires: e-smith-devtools |
15 |
|
|
BuildArchitectures: noarch |
16 |
|
|
Requires: smeserver-release >= 7, smeserver-snort > 2.4 |
17 |
|
|
AutoReqProv: no |
18 |
|
|
|
19 |
|
|
%changelog |
20 |
|
|
* Sun Jan 21 2007 Michel Van hees <michel@vanhees.cc> |
21 |
|
|
* Better service integration |
22 |
|
|
|
23 |
|
|
* Wed Aug 16 2006 Michel Van hees <michel@vanhees.cc> |
24 |
|
|
- Bug correction in run script |
25 |
|
|
|
26 |
|
|
* Sat Feb 14 2006 Michel Van hees <mvanhees@vanhees.homeip.net> |
27 |
|
|
- initial release |
28 |
|
|
|
29 |
|
|
%description |
30 |
|
|
SME server - guardian for snort |
31 |
|
|
|
32 |
|
|
%prep |
33 |
|
|
%setup |
34 |
|
|
#%patch0 -p1 |
35 |
|
|
#%patch1 -p1 |
36 |
|
|
|
37 |
|
|
%build |
38 |
|
|
perl createlinks |
39 |
|
|
|
40 |
|
|
%install |
41 |
|
|
rm -rf $RPM_BUILD_ROOT |
42 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
43 |
|
|
rm -f %{name}-%{version}-filelist |
44 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
45 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
46 |
|
|
|
47 |
|
|
%clean |
48 |
|
|
rm -rf $RPM_BUILD_ROOT |
49 |
|
|
|
50 |
|
|
%pre |
51 |
|
|
|
52 |
|
|
%preun |
53 |
|
|
/sbin/e-smith/service guardiand stop 1>/dev/null 2>/dev/null |
54 |
|
|
|
55 |
|
|
%post |
56 |
|
|
chown -R smelog:smelog /var/log/guardiand |
57 |
|
|
/sbin/e-smith/db configuration set guardiand service status enabled |
58 |
|
|
/sbin/e-smith/expand-template /etc/guardian.conf |
59 |
|
|
|
60 |
|
|
# We should restart it to activate the new binary if it was upgraded |
61 |
|
|
/sbin/e-smith/service guardiand start 1>/dev/null 2>/dev/null |
62 |
|
|
|
63 |
|
|
%postun |
64 |
|
|
|
65 |
|
|
%files -f %{name}-%{version}-filelist |
66 |
|
|
%defattr(-,root,root) |