1 |
slords |
1.1 |
Summary: guardian for SME server |
2 |
|
|
%define name smeserver-guardiand |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 1.7 |
5 |
|
|
%define release 4 |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
License: Freely distributable |
9 |
|
|
Group: Networking/Daemons |
10 |
|
|
Source: %{name}-%{version}.tar.gz |
11 |
|
|
#Patch0: %{name}-%{version}.patch.yyyymmddnn |
12 |
|
|
BuildRoot: /var/tmp/e-smith-buildroot |
13 |
|
|
BuildRequires: e-smith-devtools |
14 |
|
|
BuildArchitectures: noarch |
15 |
|
|
Requires: smeserver-release >= 7, smeserver-snort > 2.4 |
16 |
|
|
AutoReqProv: no |
17 |
|
|
|
18 |
|
|
%changelog |
19 |
|
|
* Sun Jan 21 2007 Michel Van hees <michel@vanhees.cc> |
20 |
|
|
* Better service integration |
21 |
|
|
|
22 |
|
|
* Wed Aug 16 2006 Michel Van hees <michel@vanhees.cc> |
23 |
|
|
- Bug correction in run script |
24 |
|
|
|
25 |
|
|
* Sat Feb 14 2006 Michel Van hees <mvanhees@vanhees.homeip.net> |
26 |
|
|
- initial release |
27 |
|
|
|
28 |
|
|
%description |
29 |
|
|
SME server - guardian for snort |
30 |
|
|
|
31 |
|
|
%prep |
32 |
|
|
%setup |
33 |
|
|
#%patch0 -p1 |
34 |
|
|
#%patch1 -p1 |
35 |
|
|
|
36 |
|
|
%build |
37 |
|
|
perl createlinks |
38 |
|
|
|
39 |
|
|
%install |
40 |
|
|
rm -rf $RPM_BUILD_ROOT |
41 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
42 |
|
|
rm -f %{name}-%{version}-filelist |
43 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
44 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
45 |
|
|
|
46 |
|
|
%clean |
47 |
|
|
rm -rf $RPM_BUILD_ROOT |
48 |
|
|
|
49 |
|
|
%pre |
50 |
|
|
|
51 |
|
|
%preun |
52 |
|
|
/sbin/e-smith/service guardiand stop 1>/dev/null 2>/dev/null |
53 |
|
|
|
54 |
|
|
%post |
55 |
|
|
chown -R smelog:smelog /var/log/guardiand |
56 |
|
|
/sbin/e-smith/db configuration set guardiand service status enabled |
57 |
|
|
/sbin/e-smith/expand-template /etc/guardian.conf |
58 |
|
|
|
59 |
|
|
# We should restart it to activate the new binary if it was upgraded |
60 |
|
|
/sbin/e-smith/service guardiand start 1>/dev/null 2>/dev/null |
61 |
|
|
|
62 |
|
|
%postun |
63 |
|
|
|
64 |
|
|
%files -f %{name}-%{version}-filelist |
65 |
|
|
%defattr(-,root,root) |