1 |
slords |
1.3 |
# $Id: smeserver-guardiand.spec,v 1.2 2008/04/02 15:03:57 slords Exp $ |
2 |
slords |
1.2 |
# Authority: nocvs |
3 |
|
|
# Name: Michel Van hees |
4 |
|
|
|
5 |
slords |
1.1 |
Summary: guardian for SME server |
6 |
|
|
%define name smeserver-guardiand |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 1.7 |
9 |
|
|
%define release 4 |
10 |
|
|
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: Freely distributable |
13 |
|
|
Group: Networking/Daemons |
14 |
|
|
Source: %{name}-%{version}.tar.gz |
15 |
|
|
#Patch0: %{name}-%{version}.patch.yyyymmddnn |
16 |
|
|
BuildRoot: /var/tmp/e-smith-buildroot |
17 |
|
|
BuildRequires: e-smith-devtools |
18 |
|
|
BuildArchitectures: noarch |
19 |
|
|
Requires: smeserver-release >= 7, smeserver-snort > 2.4 |
20 |
|
|
AutoReqProv: no |
21 |
|
|
|
22 |
|
|
%changelog |
23 |
|
|
* Sun Jan 21 2007 Michel Van hees <michel@vanhees.cc> |
24 |
|
|
* Better service integration |
25 |
|
|
|
26 |
|
|
* Wed Aug 16 2006 Michel Van hees <michel@vanhees.cc> |
27 |
|
|
- Bug correction in run script |
28 |
|
|
|
29 |
|
|
* Sat Feb 14 2006 Michel Van hees <mvanhees@vanhees.homeip.net> |
30 |
|
|
- initial release |
31 |
|
|
|
32 |
|
|
%description |
33 |
|
|
SME server - guardian for snort |
34 |
|
|
|
35 |
|
|
%prep |
36 |
|
|
%setup |
37 |
|
|
#%patch0 -p1 |
38 |
|
|
#%patch1 -p1 |
39 |
|
|
|
40 |
|
|
%build |
41 |
|
|
perl createlinks |
42 |
|
|
|
43 |
|
|
%install |
44 |
|
|
rm -rf $RPM_BUILD_ROOT |
45 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
46 |
|
|
rm -f %{name}-%{version}-filelist |
47 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
48 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
49 |
|
|
|
50 |
|
|
%clean |
51 |
|
|
rm -rf $RPM_BUILD_ROOT |
52 |
|
|
|
53 |
|
|
%pre |
54 |
|
|
|
55 |
|
|
%preun |
56 |
|
|
/sbin/e-smith/service guardiand stop 1>/dev/null 2>/dev/null |
57 |
|
|
|
58 |
|
|
%post |
59 |
|
|
chown -R smelog:smelog /var/log/guardiand |
60 |
|
|
/sbin/e-smith/db configuration set guardiand service status enabled |
61 |
|
|
/sbin/e-smith/expand-template /etc/guardian.conf |
62 |
|
|
|
63 |
|
|
# We should restart it to activate the new binary if it was upgraded |
64 |
|
|
/sbin/e-smith/service guardiand start 1>/dev/null 2>/dev/null |
65 |
|
|
|
66 |
|
|
%postun |
67 |
|
|
|
68 |
|
|
%files -f %{name}-%{version}-filelist |
69 |
|
|
%defattr(-,root,root) |